summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2022-05-11 10:20:41 +0200
committerCarlos Rafael Giani <crg7475@mailbox.org>2022-05-11 10:21:04 +0200
commitc1cbe5c6f38bd8a5c45ea19dc757644f1adaf7dd (patch)
tree5c5121925065b5a813a15bd5dcb47989e1a6f7ea
parentd562e1e22cd4b557320386be95402ec5306c7a5e (diff)
downloadmeta-freescale-c1cbe5c6f38bd8a5c45ea19dc757644f1adaf7dd.tar.gz
gstreamer1.0-plugins-imx: Backport version 2.1.0 from kirkstone
gstreamer1.0-plugins-imx version 0.13 remains preferred by default to maintain compatibility with existing BSPs. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
new file mode 100644
index 00000000..9b3bc9b7
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
@@ -0,0 +1,70 @@
1# Copyright (C) 2018 O.S. Systems Software LTDA.
2DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia"
6DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libimxdmabuffer"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
10# built (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS)
11RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
12RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
13RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
14
15PV .= "+git${SRCPV}"
16
17SRCBRANCH ?= "master"
18SRCREV = "b1e5cca1a6df9d2c0dc505ae222775798108d340"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20
21S = "${WORKDIR}/git"
22
23# Setting DEFAULT_PREFERENCE to -1 since dunfell has had gstreamer-imx version
24# 0.13.1 for a long time already, so silently replacing it with version 2.1.0
25# may break existing BSPs.
26DEFAULT_PREFERENCE = "-1"
27
28inherit pkgconfig meson use-imx-headers
29
30# libg2d on i.MX8 SoCs with a DPU is emulated via the DPU.
31# That particular libg2d .so depends on libdrm, however.
32# Also, due to behavioral differences, an additional flag
33# is needed to improve performance.
34LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false"
35LIBG2D_DEPENDENCIES = "virtual/libg2d"
36LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true"
37LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm"
38
39# OE dunfell's meson version does not have the necessary
40# functionality for build scripts to query the sysroot path,
41# so it must be specified manually via the -Dsysroot option.
42EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX} -Dsysroot=${RECIPE_SYSROOT}"
43
44PACKAGECONFIG ?= "uniaudiodec"
45PACKAGECONFIG_append_imxgpu2d = " g2d"
46PACKAGECONFIG_append_imxvpu = " vpu"
47PACKAGECONFIG_append_imxipu = " ipu"
48PACKAGECONFIG_append_imxpxp = " pxp"
49# The custom imxv4l2 elements are only available on the i.MX6.
50# The 2D blitter sinks require an MXC framebuffer, which
51# is not available anymore on the i.MX8 (since these SoCs
52# now use KMS instead of the old Linux framebuffer).
53PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2"
54PACKAGECONFIG_append_mx7 = " imx2dvideosink"
55
56PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
57PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
58PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
59PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
60PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
61PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false,"
62PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
63PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
64
65require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
66
67# the following line is required to produce one package for each plugin
68PACKAGES_DYNAMIC = "^${PN}-.*"
69
70COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx8)"