summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2022-05-07 10:42:53 +0200
committerCarlos Rafael Giani <crg7475@mailbox.org>2022-05-11 10:21:04 +0200
commit98d066d125af0602e09d18fc9e404099741f20d0 (patch)
tree0d9fe10ec135c95a97e087b936dd6cc42ac92cd8
parenta926042526abaec91efb7744ab196fb2e393a790 (diff)
downloadmeta-freescale-98d066d125af0602e09d18fc9e404099741f20d0.tar.gz
libimxdmabuffer: Upgrade to version 1.1.2
* waf: update to 2.0.23 * dma-heap: Add support for uncached dma-heap memory imx_dma_buffer_dma_heap_allocator_new_from_fd() is a new function that partially deprecates the dma_heap_fd argument of imx_dma_buffer_dma_heap_allocator_new(). * Add sync access functions to ensure cache coherency when allocating cached DMA memory; only done by dma-heap allocator at this time * Relax buffer mapping flags checks * Add API functions to retrieve dma-heap / ION FDs Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
-rw-r--r--recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch28
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb (renamed from recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb)5
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
new file mode 100644
index 00000000..490d3a2f
--- /dev/null
+++ b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
@@ -0,0 +1,28 @@
1From 41825b11289be251fed64470893d18b89b0dd38b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <crg7475@mailbox.org>
3Date: Sun, 8 May 2022 16:25:44 +0200
4Subject: [PATCH] g2d: Fix typo
5
6Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
7
8Upstream-Status: Backport [41825b11289be251fed64470893d18b89b0dd38b]
9---
10 imxdmabuffer/imxdmabuffer_g2d_allocator.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/imxdmabuffer/imxdmabuffer_g2d_allocator.c b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
14index f10a909..497dcea 100644
15--- a/imxdmabuffer/imxdmabuffer_g2d_allocator.c
16+++ b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
17@@ -139,7 +139,7 @@ static uint8_t* imx_dma_buffer_g2d_allocator_map(ImxDmaBufferAllocator *allocato
18 * (Other allocators perform more steps than this.) */
19 if (imx_g2d_buffer->mapping_refcount > 0)
20 {
21- assert((imx_dwl_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
22+ assert((imx_g2d_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
23 imx_g2d_buffer->mapping_refcount++;
24 }
25 else
26--
272.32.0
28
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
index b5ac6cd4..dd3b65da 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
@@ -8,8 +8,9 @@ SECTION = "base"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" 11SRCREV = "5410b44fb0c5bbd9fb1f3ba0681e65068d8cde57"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://0001-g2d-Fix-typo.patch \
13 file://run-ptest \ 14 file://run-ptest \
14 " 15 "
15 16
@@ -18,8 +19,10 @@ S = "${WORKDIR}/git"
18 19
19inherit pkgconfig waf use-imx-headers ptest 20inherit pkgconfig waf use-imx-headers ptest
20 21
22# dma-heap allocator is unavailable because it requires kernel 5.6 or newer.
21EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ 23EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
22 --libdir=${libdir} \ 24 --libdir=${libdir} \
25 --with-dma-heap-allocator=no \
23 ${PACKAGECONFIG_CONFARGS}" 26 ${PACKAGECONFIG_CONFARGS}"
24 27
25# If imxdpu is in use, the DPU is also used for implementing 28# If imxdpu is in use, the DPU is also used for implementing