summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-08-01 08:24:48 -0300
committerGitHub <noreply@github.com>2023-08-01 08:24:48 -0300
commit76de0f78cb4519d6212d82c4e374cc2973352ff9 (patch)
tree3381ba187526509c8aab97ede18a0b5a9dbdbd3e
parentf66fdef1c2dc735690a7ec7dd44a534d69ea3918 (diff)
parent3a0dedcb0e4f780d06bc516e9a6fcb13bc075465 (diff)
downloadmeta-freescale-76de0f78cb4519d6212d82c4e374cc2973352ff9.tar.gz
Merge pull request #1631 from dv1/imxdmabuffer-imxvpuapi-gstimx-upgrades-dunfell
Dunfell specific upgrades for libimxdmabuffer, libimxvpuapi2, gstreamer-imx
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb19
-rw-r--r--recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch28
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb (renamed from recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb)3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb)18
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb (renamed from recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb)7
5 files changed, 39 insertions, 36 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
index a44c9027..286f3c87 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
@@ -13,4 +13,23 @@ S = "${WORKDIR}/${BPN}-${PV}"
13SRC_URI[md5sum] = "5c254523ae4c44491ea838e84e9aee49" 13SRC_URI[md5sum] = "5c254523ae4c44491ea838e84e9aee49"
14SRC_URI[sha256sum] = "c5dd1fbf8c9776d7a2844a225e0aa2e489aa24eaab8f55cb48a6e3184def235d" 14SRC_URI[sha256sum] = "c5dd1fbf8c9776d7a2844a225e0aa2e489aa24eaab8f55cb48a6e3184def235d"
15 15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES_${PN} = "/"
34
16COMPATIBLE_MACHINE = "(mx8mp)" 35COMPATIBLE_MACHINE = "(mx8mp)"
diff --git a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
deleted file mode 100644
index 490d3a2f..00000000
--- a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 41825b11289be251fed64470893d18b89b0dd38b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <crg7475@mailbox.org>
3Date: Sun, 8 May 2022 16:25:44 +0200
4Subject: [PATCH] g2d: Fix typo
5
6Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
7
8Upstream-Status: Backport [41825b11289be251fed64470893d18b89b0dd38b]
9---
10 imxdmabuffer/imxdmabuffer_g2d_allocator.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/imxdmabuffer/imxdmabuffer_g2d_allocator.c b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
14index f10a909..497dcea 100644
15--- a/imxdmabuffer/imxdmabuffer_g2d_allocator.c
16+++ b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
17@@ -139,7 +139,7 @@ static uint8_t* imx_dma_buffer_g2d_allocator_map(ImxDmaBufferAllocator *allocato
18 * (Other allocators perform more steps than this.) */
19 if (imx_g2d_buffer->mapping_refcount > 0)
20 {
21- assert((imx_dwl_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
22+ assert((imx_g2d_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
23 imx_g2d_buffer->mapping_refcount++;
24 }
25 else
26--
272.32.0
28
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
index dd3b65da..bc40a1cf 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
@@ -8,9 +8,8 @@ SECTION = "base"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "5410b44fb0c5bbd9fb1f3ba0681e65068d8cde57" 11SRCREV = "faf547cc2345bfbf95507ab7e86530f85289bb5b"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://0001-g2d-Fix-typo.patch \
14 file://run-ptest \ 13 file://run-ptest \
15 " 14 "
16 15
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
index 9b3bc9b7..7e2f2573 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
@@ -15,7 +15,7 @@ RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparser
15PV .= "+git${SRCPV}" 15PV .= "+git${SRCPV}"
16 16
17SRCBRANCH ?= "master" 17SRCBRANCH ?= "master"
18SRCREV = "b1e5cca1a6df9d2c0dc505ae222775798108d340" 18SRCREV = "cb3cd45676e808b222ac573e8a118f44fd70c288"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https" 19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
@@ -46,19 +46,29 @@ PACKAGECONFIG_append_imxgpu2d = " g2d"
46PACKAGECONFIG_append_imxvpu = " vpu" 46PACKAGECONFIG_append_imxvpu = " vpu"
47PACKAGECONFIG_append_imxipu = " ipu" 47PACKAGECONFIG_append_imxipu = " ipu"
48PACKAGECONFIG_append_imxpxp = " pxp" 48PACKAGECONFIG_append_imxpxp = " pxp"
49# The custom imxv4l2 elements are only available on the i.MX6. 49# The custom imxv4l2 source and sink elements are only
50# available on the i.MX6.
50# The 2D blitter sinks require an MXC framebuffer, which 51# The 2D blitter sinks require an MXC framebuffer, which
51# is not available anymore on the i.MX8 (since these SoCs 52# is not available anymore on the i.MX8 (since these SoCs
52# now use KMS instead of the old Linux framebuffer). 53# now use KMS instead of the old Linux framebuffer).
53PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2" 54PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2-mxc-source-sink"
54PACKAGECONFIG_append_mx7 = " imx2dvideosink" 55PACKAGECONFIG_append_mx7 = " imx2dvideosink"
56# The custom Amphion V4L2 mem-2-mem elements are meant for
57# the QuadMax and QuadXPlus SoCs.
58PACKAGECONFIG_append_mx8qm = " v4l2-amphion"
59PACKAGECONFIG_append_mx8qxp = " v4l2-amphion"
55 60
56PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}" 61PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
57PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled," 62PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
58PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled," 63PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
59PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2" 64PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
60PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false," 65PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
61PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false," 66PACKAGECONFIG[v4l2-mxc-source-sink] = "-Dv4l2-mxc-source-sink=true,-Dv4l2-mxc-source-sink=false,"
67# v4l2-isi is not enabled by default because the ISI devices
68# need to be turned on in the devicetree. See the readme on
69# the gstreamer-imx github site for details.
70PACKAGECONFIG[v4l2-isi] = "-Dv4l2-isi=true,-Dv4l2-isi=false,"
71PACKAGECONFIG[v4l2-amphion] = "-Dv4l2-amphion=enabled,-Dv4l2-amphion=disabled,"
62PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec" 72PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
63PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec" 73PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
64 74
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
index c0ee358a..51e6b554 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
@@ -4,11 +4,14 @@ LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia" 5SECTION = "multimedia"
6DEPENDS = "virtual/imxvpu libimxdmabuffer" 6DEPENDS = "virtual/imxvpu libimxdmabuffer"
7# Add imx-vpu-hantro-vc as dependency for being
8# able to encode video using the VC8000E encoder
9DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
7 10
8PV .= "+git${SRCPV}" 11PV .= "+git${SRCPV}"
9 12
10SRCBRANCH ?= "master" 13SRCBRANCH ?= "master"
11SRCREV = "b6486118d47937cd717c4881158dda6e72cf2855" 14SRCREV = "6f803f46d6b53a08cf02fc3d440072e01e2f3a09"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https" 15SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 16
14S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
@@ -18,7 +21,7 @@ inherit waf pkgconfig use-imx-headers
18IMX_PLATFORM_mx6 = "imx6" 21IMX_PLATFORM_mx6 = "imx6"
19IMX_PLATFORM_mx8mq = "imx8m" 22IMX_PLATFORM_mx8mq = "imx8m"
20IMX_PLATFORM_mx8mm = "imx8mm" 23IMX_PLATFORM_mx8mm = "imx8mm"
21IMX_PLATFORM_mx8mp = "imx8mm" 24IMX_PLATFORM_mx8mp = "imx8mp"
22 25
23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}" 26EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
24 27