summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2023-03-30 23:00:37 +0200
committerCarlos Rafael Giani <crg7475@mailbox.org>2023-07-30 16:58:47 +0200
commit5494d046d3442e31cadfe11b614d020028eada29 (patch)
tree324c42f4bbe5bedd3c7f4ad3624fa3987da684d2
parentf66fdef1c2dc735690a7ec7dd44a534d69ea3918 (diff)
downloadmeta-freescale-5494d046d3442e31cadfe11b614d020028eada29.tar.gz
imx-vpu-hantro-vc: add do_install function
The encoding library was not previously being installed. (Backported original commit 1acf098972f9f86b26eee815827667dbd2fcdeaf to dunfell) Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com> Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
index a44c9027..286f3c87 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.1.0.bb
@@ -13,4 +13,23 @@ S = "${WORKDIR}/${BPN}-${PV}"
13SRC_URI[md5sum] = "5c254523ae4c44491ea838e84e9aee49" 13SRC_URI[md5sum] = "5c254523ae4c44491ea838e84e9aee49"
14SRC_URI[sha256sum] = "c5dd1fbf8c9776d7a2844a225e0aa2e489aa24eaab8f55cb48a6e3184def235d" 14SRC_URI[sha256sum] = "c5dd1fbf8c9776d7a2844a225e0aa2e489aa24eaab8f55cb48a6e3184def235d"
15 15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES_${PN} = "/"
34
16COMPATIBLE_MACHINE = "(mx8mp)" 35COMPATIBLE_MACHINE = "(mx8mp)"