summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-04-14 19:46:20 -0300
committerGitHub <noreply@github.com>2022-04-14 19:46:20 -0300
commit3dbca0ef2ae1ea3862e540c59ad77adbcb419d57 (patch)
treedab96a4e2d3f652bcc3b170e4494fef7dc6c0233
parent96fc99f8153609ecf7e9a36a7b120b60cad6f625 (diff)
parenta926042526abaec91efb7744ab196fb2e393a790 (diff)
downloadmeta-freescale-3dbca0ef2ae1ea3862e540c59ad77adbcb419d57.tar.gz
Merge pull request #902 from dv1/enable-ion-mmgr-for-imx6-7
Enable ION memory manager for i.MX6 and 7
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb6
-rw-r--r--recipes-kernel/linux/linux-fslc-imx/imx/defconfig2
-rw-r--r--recipes-kernel/linux/linux-fslc/defconfig2
-rw-r--r--recipes-kernel/linux/linux-imx/imx/defconfig2
4 files changed, 8 insertions, 4 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
index c1228b4d..b5ac6cd4 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
@@ -28,13 +28,11 @@ EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
28LIBG2D_PACKAGECONFIG = "g2d" 28LIBG2D_PACKAGECONFIG = "g2d"
29LIBG2D_PACKAGECONFIG_imxdpu = "" 29LIBG2D_PACKAGECONFIG_imxdpu = ""
30 30
31PACKAGECONFIG ?= " " 31PACKAGECONFIG ?= " ion "
32PACKAGECONFIG_append_imxgpu2d = " ${LIBG2D_PACKAGECONFIG}" 32PACKAGECONFIG_append_imxgpu2d = " ${LIBG2D_PACKAGECONFIG}"
33PACKAGECONFIG_append_imxipu = " ipu" 33PACKAGECONFIG_append_imxipu = " ipu"
34PACKAGECONFIG_append_imxpxp = " pxp" 34PACKAGECONFIG_append_imxpxp = " pxp"
35PACKAGECONFIG_append_mx8m = " ion dwl" 35PACKAGECONFIG_append_mx8m = " dwl"
36PACKAGECONFIG_append_mx8qm = " ion"
37PACKAGECONFIG_append_mx8qxp = " ion"
38 36
39HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2" 37HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2"
40 38
diff --git a/recipes-kernel/linux/linux-fslc-imx/imx/defconfig b/recipes-kernel/linux/linux-fslc-imx/imx/defconfig
index 742400a9..8781d8bb 100644
--- a/recipes-kernel/linux/linux-fslc-imx/imx/defconfig
+++ b/recipes-kernel/linux/linux-fslc-imx/imx/defconfig
@@ -577,3 +577,5 @@ CONFIG_MAGIC_SYSRQ=y
577# CONFIG_DEBUG_PREEMPT is not set 577# CONFIG_DEBUG_PREEMPT is not set
578# CONFIG_DEBUG_BUGVERBOSE is not set 578# CONFIG_DEBUG_BUGVERBOSE is not set
579# CONFIG_FTRACE is not set 579# CONFIG_FTRACE is not set
580CONFIG_ION=y
581CONFIG_ION_CMA_HEAP=y
diff --git a/recipes-kernel/linux/linux-fslc/defconfig b/recipes-kernel/linux/linux-fslc/defconfig
index dbb2387c..3526cee7 100644
--- a/recipes-kernel/linux/linux-fslc/defconfig
+++ b/recipes-kernel/linux/linux-fslc/defconfig
@@ -467,3 +467,5 @@ CONFIG_PROVE_LOCKING=y
467CONFIG_NET_SCHED=y 467CONFIG_NET_SCHED=y
468CONFIG_NET_SCH_FQ_CODEL=y 468CONFIG_NET_SCH_FQ_CODEL=y
469CONFIG_NET_SCH_FIFO=y 469CONFIG_NET_SCH_FIFO=y
470CONFIG_ION=y
471CONFIG_ION_CMA_HEAP=y
diff --git a/recipes-kernel/linux/linux-imx/imx/defconfig b/recipes-kernel/linux/linux-imx/imx/defconfig
index 30792d23..7ac298a7 100644
--- a/recipes-kernel/linux/linux-imx/imx/defconfig
+++ b/recipes-kernel/linux/linux-imx/imx/defconfig
@@ -577,3 +577,5 @@ CONFIG_MAGIC_SYSRQ=y
577# CONFIG_DEBUG_PREEMPT is not set 577# CONFIG_DEBUG_PREEMPT is not set
578# CONFIG_DEBUG_BUGVERBOSE is not set 578# CONFIG_DEBUG_BUGVERBOSE is not set
579# CONFIG_FTRACE is not set 579# CONFIG_FTRACE is not set
580CONFIG_ION=y
581CONFIG_ION_CMA_HEAP=y