summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-05-11 07:39:55 -0300
committerGitHub <noreply@github.com>2022-05-11 07:39:55 -0300
commit3cb29cff92568ea835ef070490f185349d712837 (patch)
tree5c5121925065b5a813a15bd5dcb47989e1a6f7ea
parent3dbca0ef2ae1ea3862e540c59ad77adbcb419d57 (diff)
parentc1cbe5c6f38bd8a5c45ea19dc757644f1adaf7dd (diff)
downloadmeta-freescale-3cb29cff92568ea835ef070490f185349d712837.tar.gz
Merge pull request #1076 from dv1/dunfell
libimxdmabuffer, libimxvpuapi2, gstreamer1.0-plugins-imx upgrades and backports for dunfell
-rw-r--r--recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch28
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb (renamed from recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb)5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb70
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.1.bb (renamed from recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb)2
4 files changed, 103 insertions, 2 deletions
diff --git a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
new file mode 100644
index 00000000..490d3a2f
--- /dev/null
+++ b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
@@ -0,0 +1,28 @@
1From 41825b11289be251fed64470893d18b89b0dd38b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <crg7475@mailbox.org>
3Date: Sun, 8 May 2022 16:25:44 +0200
4Subject: [PATCH] g2d: Fix typo
5
6Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
7
8Upstream-Status: Backport [41825b11289be251fed64470893d18b89b0dd38b]
9---
10 imxdmabuffer/imxdmabuffer_g2d_allocator.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/imxdmabuffer/imxdmabuffer_g2d_allocator.c b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
14index f10a909..497dcea 100644
15--- a/imxdmabuffer/imxdmabuffer_g2d_allocator.c
16+++ b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
17@@ -139,7 +139,7 @@ static uint8_t* imx_dma_buffer_g2d_allocator_map(ImxDmaBufferAllocator *allocato
18 * (Other allocators perform more steps than this.) */
19 if (imx_g2d_buffer->mapping_refcount > 0)
20 {
21- assert((imx_dwl_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
22+ assert((imx_g2d_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
23 imx_g2d_buffer->mapping_refcount++;
24 }
25 else
26--
272.32.0
28
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
index b5ac6cd4..dd3b65da 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
@@ -8,8 +8,9 @@ SECTION = "base"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" 11SRCREV = "5410b44fb0c5bbd9fb1f3ba0681e65068d8cde57"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://0001-g2d-Fix-typo.patch \
13 file://run-ptest \ 14 file://run-ptest \
14 " 15 "
15 16
@@ -18,8 +19,10 @@ S = "${WORKDIR}/git"
18 19
19inherit pkgconfig waf use-imx-headers ptest 20inherit pkgconfig waf use-imx-headers ptest
20 21
22# dma-heap allocator is unavailable because it requires kernel 5.6 or newer.
21EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ 23EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
22 --libdir=${libdir} \ 24 --libdir=${libdir} \
25 --with-dma-heap-allocator=no \
23 ${PACKAGECONFIG_CONFARGS}" 26 ${PACKAGECONFIG_CONFARGS}"
24 27
25# If imxdpu is in use, the DPU is also used for implementing 28# If imxdpu is in use, the DPU is also used for implementing
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
new file mode 100644
index 00000000..9b3bc9b7
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
@@ -0,0 +1,70 @@
1# Copyright (C) 2018 O.S. Systems Software LTDA.
2DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia"
6DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libimxdmabuffer"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
10# built (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS)
11RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
12RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
13RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
14
15PV .= "+git${SRCPV}"
16
17SRCBRANCH ?= "master"
18SRCREV = "b1e5cca1a6df9d2c0dc505ae222775798108d340"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20
21S = "${WORKDIR}/git"
22
23# Setting DEFAULT_PREFERENCE to -1 since dunfell has had gstreamer-imx version
24# 0.13.1 for a long time already, so silently replacing it with version 2.1.0
25# may break existing BSPs.
26DEFAULT_PREFERENCE = "-1"
27
28inherit pkgconfig meson use-imx-headers
29
30# libg2d on i.MX8 SoCs with a DPU is emulated via the DPU.
31# That particular libg2d .so depends on libdrm, however.
32# Also, due to behavioral differences, an additional flag
33# is needed to improve performance.
34LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false"
35LIBG2D_DEPENDENCIES = "virtual/libg2d"
36LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true"
37LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm"
38
39# OE dunfell's meson version does not have the necessary
40# functionality for build scripts to query the sysroot path,
41# so it must be specified manually via the -Dsysroot option.
42EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX} -Dsysroot=${RECIPE_SYSROOT}"
43
44PACKAGECONFIG ?= "uniaudiodec"
45PACKAGECONFIG_append_imxgpu2d = " g2d"
46PACKAGECONFIG_append_imxvpu = " vpu"
47PACKAGECONFIG_append_imxipu = " ipu"
48PACKAGECONFIG_append_imxpxp = " pxp"
49# The custom imxv4l2 elements are only available on the i.MX6.
50# The 2D blitter sinks require an MXC framebuffer, which
51# is not available anymore on the i.MX8 (since these SoCs
52# now use KMS instead of the old Linux framebuffer).
53PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2"
54PACKAGECONFIG_append_mx7 = " imx2dvideosink"
55
56PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
57PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
58PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
59PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
60PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
61PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false,"
62PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
63PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
64
65require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
66
67# the following line is required to produce one package for each plugin
68PACKAGES_DYNAMIC = "^${PN}-.*"
69
70COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx8)"
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.1.bb
index 8b2f4138..ab5c5b85 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.1.bb
@@ -8,7 +8,7 @@ DEPENDS = "virtual/imxvpu libimxdmabuffer"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "a650f13fb5de94e0c7c9e77f4d07ea275ea80dac" 11SRCREV = "e81db32d10aee42c74ab50172487e04cbec6cbe0"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https" 12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"