summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-11-24 10:19:48 -0300
committerGitHub <noreply@github.com>2021-11-24 10:19:48 -0300
commit225d7561788d9488055707b9a7e4b38185d3d6c8 (patch)
tree546351390398988de37214a21ae47b884ce33627
parent727fd8df20c8ee58474ce15cd5e1459f14bee977 (diff)
parent182b4a6a6e6dd0c86e0e15f1152bb1c65f746015 (diff)
downloadmeta-freescale-225d7561788d9488055707b9a7e4b38185d3d6c8.tar.gz
Merge pull request #930 from rohieb/dunfell
[backport dunfell] recipes: use https protocol and add explicit branch parameter
-rw-r--r--dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc2
-rw-r--r--recipes-bsp/ddr-phy/ddr-phy_git.bb2
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_git.bb2
-rw-r--r--recipes-bsp/imx-uuc/imx-uuc_git.bb2
-rw-r--r--recipes-bsp/inphi/inphi_git.bb2
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb2
-rw-r--r--recipes-bsp/ls2-phy/ls2-phy_git.bb2
-rw-r--r--recipes-bsp/mxsldr/mxsldr_git.bb2
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb2
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2020.04.inc2
-rw-r--r--recipes-bsp/uefi/uefi_git.bb2
-rw-r--r--recipes-devtools/devregs/devregs_git.bb2
-rw-r--r--recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb2
-rw-r--r--recipes-devtools/utp-com/utp-com_git.bb2
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb2
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.14.1.bb2
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.20.4.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-qoriq_5.4.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc.inc2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb2
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb2
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb2
24 files changed, 24 insertions, 24 deletions
diff --git a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
index cdd0f08f..d5e67874 100644
--- a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
+++ b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
@@ -14,7 +14,7 @@ CHROMIUM_IMX_COMMON_PATCHES ?= " "
14CHROMIUM_IMX_VPU_PATCHES ?= " " 14CHROMIUM_IMX_VPU_PATCHES ?= " "
15CHROMIUM_IMX_WAYLAND_PATCHES ?= " " 15CHROMIUM_IMX_WAYLAND_PATCHES ?= " "
16 16
17SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV}" 17SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV};protocol=https"
18 18
19do_unpack[postfuncs] += "copy_chromium_imx_files" 19do_unpack[postfuncs] += "copy_chromium_imx_files"
20# using =+ instead of += to make sure add_chromium_imx_patches is 20# using =+ instead of += to make sure add_chromium_imx_patches is
diff --git a/recipes-bsp/ddr-phy/ddr-phy_git.bb b/recipes-bsp/ddr-phy/ddr-phy_git.bb
index 31f6c101..c196fcad 100644
--- a/recipes-bsp/ddr-phy/ddr-phy_git.bb
+++ b/recipes-bsp/ddr-phy/ddr-phy_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=89cc852481956e861228286ac7430
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;nobranch=1;protocol=https"
8SRCREV = "fbc036b88acb6c06ffed02c898cbae9856ec75ba" 8SRCREV = "fbc036b88acb6c06ffed02c898cbae9856ec75ba"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb
index b104fafd..9c19b8eb 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_git.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb
@@ -8,7 +8,7 @@ LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 8LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
9 9
10PV = "5.5+git${SRCPV}" 10PV = "5.5+git${SRCPV}"
11SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocol=https \ 11SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocol=https;branch=master \
12" 12"
13SRCREV = "cee66d0e956a64d03cc866fa8819da5b798c7f1b" 13SRCREV = "cee66d0e956a64d03cc866fa8819da5b798c7f1b"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb
index bfa6607b..a7a9822b 100644
--- a/recipes-bsp/imx-uuc/imx-uuc_git.bb
+++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb
@@ -11,7 +11,7 @@ inherit autotools-brokensep
11PR = "r1" 11PR = "r1"
12PV = "0.5.1+git${SRCPV}" 12PV = "0.5.1+git${SRCPV}"
13 13
14SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https" 14SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https;branch=master"
15SRCREV = "d6afb27e55d73d7ad08cd2dd51c784d8ec9694dc" 15SRCREV = "d6afb27e55d73d7ad08cd2dd51c784d8ec9694dc"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
diff --git a/recipes-bsp/inphi/inphi_git.bb b/recipes-bsp/inphi/inphi_git.bb
index 3f3c5f28..a9718b09 100644
--- a/recipes-bsp/inphi/inphi_git.bb
+++ b/recipes-bsp/inphi/inphi_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;nobranch=1;protocol=https"
8SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695" 8SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
index 9b918f2c..20b1ec13 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" 11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH} \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://run-ptest \ 13 file://run-ptest \
14 " 14 "
15 15
diff --git a/recipes-bsp/ls2-phy/ls2-phy_git.bb b/recipes-bsp/ls2-phy/ls2-phy_git.bb
index a1c412be..7369b540 100644
--- a/recipes-bsp/ls2-phy/ls2-phy_git.bb
+++ b/recipes-bsp/ls2-phy/ls2-phy_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/qoriq-firmware-cortina.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/qoriq-firmware-cortina.git;nobranch=1;protocol=https"
8SRCREV = "9143c2a3adede595966583c00ca4edc99ec698cf" 8SRCREV = "9143c2a3adede595966583c00ca4edc99ec698cf"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/mxsldr/mxsldr_git.bb b/recipes-bsp/mxsldr/mxsldr_git.bb
index 01e24993..62b4b7ad 100644
--- a/recipes-bsp/mxsldr/mxsldr_git.bb
+++ b/recipes-bsp/mxsldr/mxsldr_git.bb
@@ -7,7 +7,7 @@ LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9SRCREV = "c40d80472525e1d57dae5317c028b745968c0399" 9SRCREV = "c40d80472525e1d57dae5317c028b745968c0399"
10SRC_URI = "git://git.denx.de/mxsldr.git \ 10SRC_URI = "git://git.denx.de/mxsldr.git;branch=master \
11 file://0001-Do-not-ignore-OE-cflags-and-ldflags.patch \ 11 file://0001-Do-not-ignore-OE-cflags-and-ldflags.patch \
12 " 12 "
13 13
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index fd53807f..4e5ee6ec 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -7,7 +7,7 @@ INHIBIT_DEFAULT_DEPS = "1"
7 7
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://github.com/NXP/qoriq-engine-pfe-bin.git;nobranch=1" 10SRC_URI = "git://github.com/NXP/qoriq-engine-pfe-bin.git;nobranch=1;protocol=https"
11SRCREV = "d3a8ef0760c54ddc243039c86389497e37be90ab" 11SRCREV = "d3a8ef0760c54ddc243039c86389497e37be90ab"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index cecd5903..9e9a769f 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=c62f8109b4df15ca37ceeb5e4943626c"
5 5
6inherit deploy 6inherit deploy
7 7
8SRC_URI = "git://github.com/NXP/qoriq-qe-ucode.git;nobranch=1" 8SRC_URI = "git://github.com/NXP/qoriq-qe-ucode.git;nobranch=1;protocol=https"
9SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46" 9SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2020.04.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2020.04.inc
index 94db11cc..11d77e92 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2020.04.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2020.04.inc
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
8 8
9DEPENDS += "bison-native" 9DEPENDS += "bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
12 12
13SRCREV = "88c58453be8cd87eb55f8e283ac4dcce5b59006d" 13SRCREV = "88c58453be8cd87eb55f8e283ac4dcce5b59006d"
14SRCBRANCH = "2020.04+fslc" 14SRCBRANCH = "2020.04+fslc"
diff --git a/recipes-bsp/uefi/uefi_git.bb b/recipes-bsp/uefi/uefi_git.bb
index f94a67e2..4c5adf41 100644
--- a/recipes-bsp/uefi/uefi_git.bb
+++ b/recipes-bsp/uefi/uefi_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=343ec8f06efc37467a6de53686fa6315"
5 5
6inherit deploy 6inherit deploy
7 7
8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1" 8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1;protocol=https"
9SRCREV= "e95ed52322f15437f98dee2b27de45a7495d648c" 9SRCREV= "e95ed52322f15437f98dee2b27de45a7495d648c"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
diff --git a/recipes-devtools/devregs/devregs_git.bb b/recipes-devtools/devregs/devregs_git.bb
index 7f158fd8..59328ab3 100644
--- a/recipes-devtools/devregs/devregs_git.bb
+++ b/recipes-devtools/devregs/devregs_git.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL-1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924" 4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
5 5
6SRCREV = "d5f6223027f4d6ae71bd5d432f5611486e0e6074" 6SRCREV = "d5f6223027f4d6ae71bd5d432f5611486e0e6074"
7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http" 7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=https;branch=master"
8 8
9PV = "1.0+${SRCPV}" 9PV = "1.0+${SRCPV}"
10 10
diff --git a/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb
index c5f51983..1a1e1a9c 100644
--- a/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb
+++ b/recipes-devtools/imx-usb-loader/imx-usb-loader_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6DEPENDS = "libusb1" 6DEPENDS = "libusb1"
7 7
8SRCREV = "f009770d841468204ab104bf7d3b0c5bc8425dbb" 8SRCREV = "f009770d841468204ab104bf7d3b0c5bc8425dbb"
9SRC_URI = "git://github.com/boundarydevices/imx_usb_loader.git;protocol=http" 9SRC_URI = "git://github.com/boundarydevices/imx_usb_loader.git;protocol=https;branch=master"
10 10
11PV = "1.0+${SRCPV}" 11PV = "1.0+${SRCPV}"
12 12
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb
index db2d7f08..0b0a6cf2 100644
--- a/recipes-devtools/utp-com/utp-com_git.bb
+++ b/recipes-devtools/utp-com/utp-com_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "sg3-utils"
6 6
7SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6" 7SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6"
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/Freescale/utp_com;protocol=https \ 9 git://github.com/Freescale/utp_com;protocol=https;branch=master \
10" 10"
11 11
12PV = "1.0+git${SRCPV}" 12PV = "1.0+git${SRCPV}"
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
index 39e4f9d0..4b39b006 100644
--- a/recipes-dpaa/fm-ucode/fm-ucode_git.bb
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -7,7 +7,7 @@ PR = "r1"
7 7
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://github.com/NXP/qoriq-fm-ucode.git;nobranch=1" 10SRC_URI = "git://github.com/NXP/qoriq-fm-ucode.git;nobranch=1;protocol=https"
11SRCREV = "c275e91392e2adab1ed22f3867b8269ca3c54014" 11SRCREV = "c275e91392e2adab1ed22f3867b8269ca3c54014"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
index ddb305c1..4f30ae93 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
@@ -6,7 +6,7 @@ inherit deploy
6 6
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8 8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1" 9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc" 10SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
index 3e14a26e..684ca9a9 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
@@ -6,7 +6,7 @@ inherit deploy
6 6
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8 8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1" 9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321" 10SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
index af0b2d60..3e3f8aff 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
10PV .= "+git${SRCPV}" 10PV .= "+git${SRCPV}"
11 11
12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749" 12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749"
13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https" 13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb b/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
index eb8cf0c4..a82483c3 100644
--- a/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
@@ -14,4 +14,4 @@ LINUX_VERSION = "5.4.64"
14 14
15SRCBRANCH = "5.4.y+qoriq+fslc" 15SRCBRANCH = "5.4.y+qoriq+fslc"
16SRCREV = "4c04c442c0e91e7cf01f830aca524f09b5613f29" 16SRCREV = "4c04c442c0e91e7cf01f830aca524f09b5613f29"
17SRC_URI := "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH}" 17SRC_URI := "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH};protocol=https"
diff --git a/recipes-kernel/linux/linux-fslc.inc b/recipes-kernel/linux/linux-fslc.inc
index f6d04d59..7315df0d 100644
--- a/recipes-kernel/linux/linux-fslc.inc
+++ b/recipes-kernel/linux/linux-fslc.inc
@@ -5,6 +5,6 @@ require recipes-kernel/linux/linux-imx.inc
5 5
6DEPENDS += "lzop-native bc-native" 6DEPENDS += "lzop-native bc-native"
7 7
8SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH} \ 8SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH};protocol=https \
9 file://defconfig" 9 file://defconfig"
10LOCALVERSION = "-fslc" 10LOCALVERSION = "-fslc"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
index 35996337..394fe39b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
@@ -18,7 +18,7 @@ PV .= "+git${SRCPV}"
18 18
19SRCBRANCH ?= "master" 19SRCBRANCH ?= "master"
20SRCREV = "805987bff74af13fcb14ff111955206f1c92554d" 20SRCREV = "805987bff74af13fcb14ff111955206f1c92554d"
21SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" 21SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
index f66eff27..8b2f4138 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "a650f13fb5de94e0c7c9e77f4d07ea275ea80dac" 11SRCREV = "a650f13fb5de94e0c7c9e77f4d07ea275ea80dac"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}" 12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
index 2d0f8571..778514fb 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
@@ -10,7 +10,7 @@ PV = "0.10.3+${SRCPV}"
10 10
11SRCBRANCH ?= "v1" 11SRCBRANCH ?= "v1"
12SRCREV = "3a1ee3a54fe93813868d38c3d32ea065b59e227e" 12SRCREV = "3a1ee3a54fe93813868d38c3d32ea065b59e227e"
13SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}" 13SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16