diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-11-10 08:04:06 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-11-15 15:50:12 -0700 |
commit | cb85cf427da817a9db93b01df01c32e15aefeb74 (patch) | |
tree | 5ce6364b1e4a9be562c840a2764c963641e6bd9f | |
parent | 032c0c3402ae70190170fc714fecc254726e376c (diff) | |
download | meta-freescale-cb85cf427da817a9db93b01df01c32e15aefeb74.tar.gz |
qt6-layer: Add Qt6 support
Copy the qt5-layer bbappends with the following modifications:
- qtbase: Use eglfs for KMS backend for i.MX 8 with GPU on NXP BSP
- qtbase: Drop build config patches no longer needed
Testing is done using the quick3d and webengine examples.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | conf/layer.conf | 3 | ||||
-rw-r--r-- | dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend | 50 | ||||
-rw-r--r-- | dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend | 6 |
3 files changed, 59 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index e57c3b59..167a7590 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -51,6 +51,9 @@ BBFILES_DYNAMIC += " \ | |||
51 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ | 51 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ |
52 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ | 52 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ |
53 | \ | 53 | \ |
54 | qt6-layer:${LAYERDIR}/dynamic-layers/qt6-layer/*/*/*.bb \ | ||
55 | qt6-layer:${LAYERDIR}/dynamic-layers/qt6-layer/*/*/*.bbappend \ | ||
56 | \ | ||
54 | virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \ | 57 | virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \ |
55 | virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \ | 58 | virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \ |
56 | " | 59 | " |
diff --git a/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend new file mode 100644 index 00000000..fe2cd9e3 --- /dev/null +++ b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend | |||
@@ -0,0 +1,50 @@ | |||
1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique | ||
2 | # Copyright (C) 2016 Freescale Semiconductor | ||
3 | # Copyright (C) 2016, 2017 O.S. Systems Software LTDA. | ||
4 | # Copyright (C) 2017-2018 NXP | ||
5 | |||
6 | PACKAGECONFIG_GRAPHICS:imxpxp = " \ | ||
7 | gles2" | ||
8 | PACKAGECONFIG_GRAPHICS:imxgpu2d = " \ | ||
9 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \ | ||
10 | ${PACKAGECONFIG_GRAPHICS_IMX_GPU}" | ||
11 | PACKAGECONFIG_GRAPHICS:imxgpu3d = " \ | ||
12 | gles2 \ | ||
13 | ${PACKAGECONFIG_GRAPHICS_IMX_GPU}" | ||
14 | PACKAGECONFIG_GRAPHICS_IMX_GPU = "" | ||
15 | PACKAGECONFIG_GRAPHICS_IMX_GPU:mx8-nxp-bsp = " \ | ||
16 | gbm kms" | ||
17 | |||
18 | PACKAGECONFIG_GRAPHICS:use-mainline-bsp ?= " \ | ||
19 | gles2 gbm kms" | ||
20 | |||
21 | PACKAGECONFIG += " \ | ||
22 | ${PACKAGECONFIG_PLATFORM}" | ||
23 | |||
24 | PACKAGECONFIG_PLATFORM = "" | ||
25 | PACKAGECONFIG_PLATFORM:imxgpu2d = " \ | ||
26 | no-opengl \ | ||
27 | linuxfb \ | ||
28 | ${PACKAGECONFIG_PLATFORM_EGLFS}" | ||
29 | PACKAGECONFIG_PLATFORM:imxgpu3d = " \ | ||
30 | ${PACKAGECONFIG_PLATFORM_EGLFS}" | ||
31 | |||
32 | PACKAGECONFIG_PLATFORM_EGLFS = "" | ||
33 | PACKAGECONFIG_PLATFORM_EGLFS:imxgpu3d = " \ | ||
34 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | ||
35 | bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ | ||
36 | 'eglfs', d), d)}" | ||
37 | PACKAGECONFIG_PLATFORM_EGLFS:mx8-nxp-bsp = " \ | ||
38 | eglfs" | ||
39 | |||
40 | PACKAGECONFIG_PLATFORM:use-mainline-bsp = " \ | ||
41 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}" | ||
42 | |||
43 | PACKAGECONFIG += " \ | ||
44 | ${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}" | ||
45 | PACKAGECONFIG_VULKAN = "" | ||
46 | PACKAGECONFIG_VULKAN:imxgpu = " \ | ||
47 | ${PACKAGECONFIG_VULKAN_IMX_GPU}" | ||
48 | PACKAGECONFIG_VULKAN_IMX_GPU = "" | ||
49 | PACKAGECONFIG_VULKAN_IMX_GPU:mx8-nxp-bsp = "vulkan" | ||
50 | PACKAGECONFIG_VULKAN_IMX_GPU:mx8mm-nxp-bsp = "" | ||
diff --git a/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend new file mode 100644 index 00000000..ca011758 --- /dev/null +++ b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend | |||
@@ -0,0 +1,6 @@ | |||
1 | # etnaviv mesa does not have glx | ||
2 | PACKAGECONFIG:remove:use-mainline-bsp = "xcomposite-glx" | ||
3 | |||
4 | PACKAGECONFIG:remove:mx6-nxp-bsp = "xcomposite-egl xcomposite-glx" | ||
5 | PACKAGECONFIG:remove:mx7-nxp-bsp = "xcomposite-egl xcomposite-glx" | ||
6 | PACKAGECONFIG:remove:mx8-nxp-bsp = "xcomposite-egl xcomposite-glx" | ||