diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-06-29 14:02:25 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-06-29 14:16:32 -0300 |
commit | 7305e99febb454b216ce7c0ed2ec5495fa73d739 (patch) | |
tree | 44e78e0294870412e51d6365cb992bfc0172c5d4 | |
parent | 1140b85a914f0746b802ea5aab7699a8c718da32 (diff) | |
download | meta-freescale-7305e99febb454b216ce7c0ed2ec5495fa73d739.tar.gz |
libdrm: Remove unused patches
Since we are using the NXP's fork of libdrm, we can now drop the fork
and as consequence the SoC architecture setting for it.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch | 35 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch | 35 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm_%.bbappend | 5 |
3 files changed, 0 insertions, 75 deletions
diff --git a/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch b/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch deleted file mode 100644 index 1160cd10..00000000 --- a/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | Add ARM support into xf86arm.h. This provides support for Xorg interface. | ||
2 | Without this the vivante samples will hang during close requiring a reboot | ||
3 | |||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Signed-off-by: Lauren Post <lauren.post@freescale.com> | ||
7 | Signed-off-by: Evan Kotara <evan.kotara@freescale.com> | ||
8 | |||
9 | diff --git a/xf86drm.h b/xf86drm.h | ||
10 | --- a/xf86drm.h | ||
11 | +++ b/xf86drm.h | ||
12 | @@ -461,6 +461,23 @@ do { register unsigned int __old __asm(" | ||
13 | : "cr0", "memory"); \ | ||
14 | } while (0) | ||
15 | |||
16 | +#elif defined(__arm__) | ||
17 | + #undef DRM_DEV_MODE | ||
18 | + #define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH) | ||
19 | + | ||
20 | + #define DRM_CAS(lock,old,new,__ret) \ | ||
21 | + do { \ | ||
22 | + __asm__ __volatile__ ( \ | ||
23 | + "1: ldrex %0, [%1]\n" \ | ||
24 | + " teq %0, %2\n" \ | ||
25 | + " ite eq\n" \ | ||
26 | + " strexeq %0, %3, [%1]\n" \ | ||
27 | + " movne %0, #1\n" \ | ||
28 | + : "=&r" (__ret) \ | ||
29 | + : "r" (lock), "r" (old), "r" (new) \ | ||
30 | + : "cc","memory"); \ | ||
31 | + } while (0) | ||
32 | + | ||
33 | #endif /* architecture */ | ||
34 | #endif /* __GNUC__ >= 2 */ | ||
35 | |||
diff --git a/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch b/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch deleted file mode 100644 index 1160cd10..00000000 --- a/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | Add ARM support into xf86arm.h. This provides support for Xorg interface. | ||
2 | Without this the vivante samples will hang during close requiring a reboot | ||
3 | |||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Signed-off-by: Lauren Post <lauren.post@freescale.com> | ||
7 | Signed-off-by: Evan Kotara <evan.kotara@freescale.com> | ||
8 | |||
9 | diff --git a/xf86drm.h b/xf86drm.h | ||
10 | --- a/xf86drm.h | ||
11 | +++ b/xf86drm.h | ||
12 | @@ -461,6 +461,23 @@ do { register unsigned int __old __asm(" | ||
13 | : "cr0", "memory"); \ | ||
14 | } while (0) | ||
15 | |||
16 | +#elif defined(__arm__) | ||
17 | + #undef DRM_DEV_MODE | ||
18 | + #define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH) | ||
19 | + | ||
20 | + #define DRM_CAS(lock,old,new,__ret) \ | ||
21 | + do { \ | ||
22 | + __asm__ __volatile__ ( \ | ||
23 | + "1: ldrex %0, [%1]\n" \ | ||
24 | + " teq %0, %2\n" \ | ||
25 | + " ite eq\n" \ | ||
26 | + " strexeq %0, %3, [%1]\n" \ | ||
27 | + " movne %0, #1\n" \ | ||
28 | + : "=&r" (__ret) \ | ||
29 | + : "r" (lock), "r" (old), "r" (new) \ | ||
30 | + : "cc","memory"); \ | ||
31 | + } while (0) | ||
32 | + | ||
33 | #endif /* architecture */ | ||
34 | #endif /* __GNUC__ >= 2 */ | ||
35 | |||
diff --git a/recipes-graphics/drm/libdrm_%.bbappend b/recipes-graphics/drm/libdrm_%.bbappend deleted file mode 100644 index 97b6df92..00000000 --- a/recipes-graphics/drm/libdrm_%.bbappend +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI_append_imxgpu2d = " file://drm-update-arm.patch" | ||
4 | |||
5 | PACKAGE_ARCH_imxgpu2d = "${MACHINE_SOCARCH}" | ||