summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-10-19 19:00:52 +0000
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2021-10-25 15:21:08 +0000
commit60bfa2b5cf9eac026f873300260893e5be718311 (patch)
tree6875b72f8d8670bb69d84739724800698406bde1
parent8f5041615e3cc00903b36b4fc06239d7ac4bbce1 (diff)
downloadmeta-freescale-60bfa2b5cf9eac026f873300260893e5be718311.tar.gz
imx-vpu-hantro[-vc]: upgrade to 5.10.52-2.1.0
Hantro VPU libraries are upgraded to following versions in the NXP release 5.10.52-2.1.0: - imx-vpu-hantro: 1.23.0 - imx-vpu-hantro-daemon: 1.1.0 - imx-vpu-hantro-vc: 1.5.0 Drop patch from imx-vpu-hantro-daemon package build as it has been applied upstream and is present in the updated version. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> (cherry picked from commit e723b4c36c366ab83307b53c172e331ba0dc4be1)
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb (renamed from recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb)6
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch33
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb)5
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb)6
4 files changed, 8 insertions, 42 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
index 33208bdf..e6cffaca 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
@@ -2,7 +2,7 @@
2 2
3DESCRIPTION = "i.MX VC8000E Encoder library" 3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6 6
7inherit fsl-eula-unpack 7inherit fsl-eula-unpack
8 8
@@ -10,8 +10,8 @@ SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10 10
11S = "${WORKDIR}/${BPN}-${PV}" 11S = "${WORKDIR}/${BPN}-${PV}"
12 12
13SRC_URI[md5sum] = "b5270450ba2da5b7468b67ae8c0bcdca" 13SRC_URI[md5sum] = "fbd43a100c27abbae301428f1ae2bc64"
14SRC_URI[sha256sum] = "d5efae484c4271c098286d007590d6bf40c272d4f35702ff65625f2362715ab3" 14SRC_URI[sha256sum] = "e59ac2ded726d722f61793b17fc394ce87b1c5710cb79f0b1d60b87fca5829e1"
15 15
16# SCR is the location and name of the Software Content Register file 16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}. 17# relative to ${D}${D_SUBDIR}.
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch
deleted file mode 100644
index dff2fb8f..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 94ae72948f1ed1a8bad1c13b4edc4b9189207e35 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 26 Jul 2021 09:06:26 -0500
4Subject: [PATCH] Makefile: Honor LDFLAGS from toolchain
5
6The LDFLAGS variable is standard from the toolchain and should be
7honored. Yocto detects the problem with a QA check:
8
9ERROR: imx-vpu-hantro-daemon-1.1.0-r0 do_package_qa: QA Issue: File /usr/bin/vsidaemon in package imx-vpu-hantro-daemon doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
10
11Upstream-Status: Pending
12
13Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14---
15 Makefile | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/Makefile b/Makefile
19index 9a775b0..e73ff47 100755
20--- a/Makefile
21+++ b/Makefile
22@@ -22,7 +22,7 @@ OUT_FILE = vsidaemon
23 DEC = nxp_enc_hw
24 ENC = nxp_dec_hw
25 LIBFILES =
26-LD_FLAGS = -lpthread -lm
27+LD_FLAGS = $(LDFLAGS) -lpthread -lm
28
29 PLATFORM ?= IMX8MP
30
31--
322.17.1
33
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb
index d362fce3..25f54c7a 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb
@@ -8,10 +8,9 @@ DEPENDS:append:mx8mp = " imx-vpu-hantro-vc"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 ${FSL_MIRROR}/${BP}.tar.gz \ 10 ${FSL_MIRROR}/${BP}.tar.gz \
11 file://0001-Makefile-Honor-LDFLAGS-from-toolchain.patch \
12" 11"
13SRC_URI[md5sum] = "65417710ef22214523c37f50f34b6ab2" 12SRC_URI[md5sum] = "980237589af195c2c4b852a7aad175ee"
14SRC_URI[sha256sum] = "897d174c4c0818f31012d8a60ed51fc83fdfc55fca2d2b0fc24a0db3e9f3b6e8" 13SRC_URI[sha256sum] = "a5d915fefd3637e68d693638edd1161c30e75011a6312251b914f04546fd0fc9"
15 14
16PLATFORM:mx8mm = "IMX8MM" 15PLATFORM:mx8mm = "IMX8MM"
17PLATFORM:mx8mq = "IMX8MQ" 16PLATFORM:mx8mq = "IMX8MQ"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
index 2ecb1e4b..427dbf92 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
@@ -2,13 +2,13 @@
2 2
3DESCRIPTION = "i.MX Hantro VPU library" 3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6 6
7PROVIDES = "virtual/imxvpu" 7PROVIDES = "virtual/imxvpu"
8 8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" 9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "b65b49eadb6463b784e1a9e44a94fca1" 10SRC_URI[md5sum] = "3f8d4bb593d851d0523d0146131946ae"
11SRC_URI[sha256sum] = "03c61dfb268b31a0d25a4d1387cb3ad0261029ad5de801f72224602e2b37da00" 11SRC_URI[sha256sum] = "a312a0b6d32ed16527e5bfcff362b231069428362ad5710f816bca019f70c6a2"
12 12
13inherit fsl-eula-unpack use-imx-headers 13inherit fsl-eula-unpack use-imx-headers
14 14