summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-10-21 09:03:35 -0300
committerGitHub <noreply@github.com>2021-10-21 09:03:35 -0300
commit537fc132d921619b98c07b1d2e2362411ae889e0 (patch)
tree3e05546180d63768facf0c4ef489c171f32beb74
parent00f062d105b7617f6503cdec7bac9eefb2628974 (diff)
parent3d39d355867caaee00c42614f7eb4a9b0830b84b (diff)
downloadmeta-freescale-537fc132d921619b98c07b1d2e2362411ae889e0.tar.gz
Merge pull request #894 from hongxu-jia/master
support user merge
-rw-r--r--recipes-dpaa2/dce/dce_git.bb1
-rw-r--r--recipes-dpaa2/dce/files/0001-support-user-merge.patch31
-rw-r--r--recipes-extended/odp/odp-counters_git.bb4
-rw-r--r--recipes-extended/odp/odp-module_git.bb4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ar_git.bb4
5 files changed, 38 insertions, 6 deletions
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb
index 24b39a0b..368e5aa6 100644
--- a/recipes-dpaa2/dce/dce_git.bb
+++ b/recipes-dpaa2/dce/dce_git.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=956df5ea6cfe0a1dcf2dee7ca37c0cdf"
5 5
6SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \ 6SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \
7 git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \ 7 git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \
8 file://0001-support-user-merge.patch \
8" 9"
9SRCREV = "9db9c08379aa89f45f514f4f3f0a8e8212198758" 10SRCREV = "9db9c08379aa89f45f514f4f3f0a8e8212198758"
10SRCREV_qbman = "2f92993a9f34e5221d6b36c63b9e30ef703e9ac3" 11SRCREV_qbman = "2f92993a9f34e5221d6b36c63b9e30ef703e9ac3"
diff --git a/recipes-dpaa2/dce/files/0001-support-user-merge.patch b/recipes-dpaa2/dce/files/0001-support-user-merge.patch
new file mode 100644
index 00000000..33b351a1
--- /dev/null
+++ b/recipes-dpaa2/dce/files/0001-support-user-merge.patch
@@ -0,0 +1,31 @@
1From d4aa7f64db5841242257c5b30dd652afd0f6ff68 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 20 Oct 2021 14:00:35 +0800
4Subject: [PATCH] support user merge
5
6Use Yocto base_sbindir to replace hardcode ./sbin
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11---
12 Makefile | 3 ++-
13 1 file changed, 2 insertions(+), 1 deletion(-)
14
15diff --git a/Makefile b/Makefile
16index 62eff25..18b79b1 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -25,7 +25,8 @@ CFLAGS += -fdiagnostics-color
20
21 LDFLAGS = -static -Wl,--hash-style=gnu ${EXTRA_CFLAGS}
22
23-PREFIX = $(DESTDIR)/sbin
24+base_sbindir ?= ./sbin
25+PREFIX = $(DESTDIR)/${base_sbindir}
26
27 HEADER_DEPENDENCIES = $(subst .o,.d,$(OBJS))
28
29--
302.27.0
31
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb
index 9d88ea43..c8f13208 100644
--- a/recipes-extended/odp/odp-counters_git.bb
+++ b/recipes-extended/odp/odp-counters_git.bb
@@ -9,6 +9,6 @@ do_compile:prepend () {
9} 9}
10 10
11do_install () { 11do_install () {
12 install -d ${D}/lib/modules/${KERNEL_VERSION}/odp 12 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp
13 install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}/lib/modules/${KERNEL_VERSION}/odp 13 install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp
14} 14}
diff --git a/recipes-extended/odp/odp-module_git.bb b/recipes-extended/odp/odp-module_git.bb
index 0748e5bf..ba74a5c0 100644
--- a/recipes-extended/odp/odp-module_git.bb
+++ b/recipes-extended/odp/odp-module_git.bb
@@ -9,8 +9,8 @@ do_compile:prepend () {
9} 9}
10 10
11do_install () { 11do_install () {
12 install -d ${D}/lib/modules/${KERNEL_VERSION}/odp 12 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp
13 install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp 13 install -m 755 ${S}/kern/odpfsl_kni.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp
14} 14}
15 15
16PKG:${PN} = "kernel-module-${PN}" 16PKG:${PN} = "kernel-module-${PN}"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
index f2cd1a57..898afeb2 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
@@ -19,9 +19,9 @@ do_compile:prepend() {
19} 19}
20 20
21do_install(){ 21do_install(){
22 install -d ${D}/lib/modules/${KERNEL_VERSION} 22 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}
23 install -d ${D}${bindir} 23 install -d ${D}${bindir}
24 install -m 644 ${B}/bin/ar.ko ${D}/lib/modules/${KERNEL_VERSION}/ 24 install -m 644 ${B}/bin/ar.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/
25 cp -f ${S}/bin/ar_* ${D}${bindir}/ 25 cp -f ${S}/bin/ar_* ${D}${bindir}/
26} 26}
27 27