summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-14 15:42:11 +0800
committerTing Liu <ting.liu@nxp.com>2021-10-15 21:17:51 +0800
commit1ecb4d68009cd5206f0acabe40fe4037e41b42c7 (patch)
tree9bade8387bc680acc5d360ed8f30825c55c39148
parentcbf7d2dc847cefbe6ad4812ed81cafb4b49daa6c (diff)
downloadmeta-freescale-1ecb4d68009cd5206f0acabe40fe4037e41b42c7.tar.gz
linux-qoriq: upgrade to 5.10
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/linux/linux-qoriq.inc12
-rw-r--r--recipes-kernel/linux/linux-qoriq_5.10.bb8
-rw-r--r--recipes-kernel/linux/linux-qoriq_5.4.bb14
3 files changed, 9 insertions, 25 deletions
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc
index edac1055..cd474aed 100644
--- a/recipes-kernel/linux/linux-qoriq.inc
+++ b/recipes-kernel/linux/linux-qoriq.inc
@@ -25,8 +25,7 @@ SCMVERSION ?= "y"
25LOCALVERSION = "" 25LOCALVERSION = ""
26DELTA_KERNEL_DEFCONFIG ?= "" 26DELTA_KERNEL_DEFCONFIG ?= ""
27DELTA_KERNEL_DEFCONFIG:prepend:qoriq-arm64 = "lsdk.config " 27DELTA_KERNEL_DEFCONFIG:prepend:qoriq-arm64 = "lsdk.config "
28DELTA_KERNEL_DEFCONFIG:prepend:fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " 28DELTA_KERNEL_DEFCONFIG:prepend:qoriq-arm = "multi_v7_lpae.config lsdk.config "
29DELTA_KERNEL_DEFCONFIG:prepend:ls102xa = "multi_v7_lpae.config lsdk.config "
30 29
31do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot" 30do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot"
32do_merge_delta_config[dirs] = "${B}" 31do_merge_delta_config[dirs] = "${B}"
@@ -55,14 +54,5 @@ do_merge_delta_config() {
55} 54}
56addtask merge_delta_config before do_kernel_localversion after do_patch 55addtask merge_delta_config before do_kernel_localversion after do_patch
57 56
58# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
59do_compile:prepend:fsl-lsch2-32b() {
60 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
61}
62
63do_install:prepend:fsl-lsch2-32b() {
64 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
65}
66
67FILES:${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" 57FILES:${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
68COMPATIBLE_MACHINE = "(qoriq)" 58COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/linux/linux-qoriq_5.10.bb b/recipes-kernel/linux/linux-qoriq_5.10.bb
new file mode 100644
index 00000000..b5315c71
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_5.10.bb
@@ -0,0 +1,8 @@
1LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
2
3LINUX_VERSION = "5.10.52"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1"
6SRCREV = "a11753a89ec610768301d4070e10b8bd60fde8cd"
7
8require recipes-kernel/linux/linux-qoriq.inc
diff --git a/recipes-kernel/linux/linux-qoriq_5.4.bb b/recipes-kernel/linux/linux-qoriq_5.4.bb
deleted file mode 100644
index 54fd700c..00000000
--- a/recipes-kernel/linux/linux-qoriq_5.4.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
2
3LINUX_VERSION = "5.4.47"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
6 file://0001-Makfefile-linux-5.4-add-warning-cflags-on-LSDK-20.04.patch \
7 file://0001-perf-tests-bp_account-Make-global-variable-static.patch \
8 file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \
9 file://0001-perf-bench-Share-some-global-variables-to-fix-build-.patch \
10 file://0001-libtraceevent-Fix-build-with-binutils-2.35.patch \
11"
12SRCREV = "6bff40d413b394c2d742e7a42089bfc62aef0a9b"
13
14require recipes-kernel/linux/linux-qoriq.inc