summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-09-20 13:58:10 +0000
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-27 15:25:20 -0300
commite75335b7fa14cea7bae5a921a4070b69ac0cf578 (patch)
tree6350d62d134c7945d0a1fd75ebb2cd4e0989098e
parent711335406ba1216d3833d8bf755f9419b8f11687 (diff)
downloadmeta-freescale-e75335b7fa14cea7bae5a921a4070b69ac0cf578.tar.gz
linux-fslc-imx: update to v5.4.144
Kernel repository has been upgraded up to v5.4.144 from stable korg. Following upstream commits are included in this version: ---- c6bf0ed9d1a7 Linux 5.4.144 0634c0f91995 audit: move put_tree() to avoid trim_trees refcount underflow and UAF cab0003311a0 net: don't unconditionally copy_from_user a struct ifreq for socket ioctls 6752b3b0628e Revert "parisc: Add assembly implementations for memset, strlen, strcpy, strncpy and strcat" 67871ada3a53 Revert "floppy: reintroduce O_NDELAY fix" d7f7eca72ecc btrfs: fix NULL pointer dereference when deleting device by invalid id e644da7ace0f arm64: dts: qcom: msm8994-angler: Fix gpio-reserved-ranges 85-88 4f76285f6df8 KVM: x86/mmu: Treat NX as used (not reserved) for all !TDP shadow MMUs 620681d7201a net: dsa: mt7530: fix VLAN traffic leaks again 38adbf21f37e bpf: Fix cast to pointer from integer of different size warning 812ee47ad76e bpf: Track contents of read-only maps as scalars f4418015201b vt_kdsetmode: extend console locking 8a19e0045086 btrfs: fix race between marking inode needs to be logged and log syncing f3a1ac258ebc net/rds: dma_map_sg is entitled to merge entries ad6a2bc7588a drm/nouveau/disp: power down unused DP links during init 689179c462d8 drm: Copy drm_wait_vblank to user before returning 18ceb99f8483 qed: Fix null-pointer dereference in qed_rdma_create_qp() f1a0db49abd5 qed: qed ll2 race condition fixes 73ba9e4ece4b vringh: Use wiov->used to check for read/write desc order ee52acae6fb5 virtio_pci: Support surprise removal of virtio pci device be9b79e84154 virtio: Improve vq->broken access to avoid any compiler optimization 0d4ba693db48 opp: remove WARN when no valid OPPs remain baf56a1d8199 perf/x86/intel/uncore: Fix integer overflow on 23 bit left shift of a u32 0ad96094ab90 usb: gadget: u_audio: fix race condition on endpoint stop c5c2b4ca5035 drm/i915: Fix syncmap memory leak 2f3cefa6abf0 net: hns3: fix get wrong pfc_en when query PFC configuration 6f0c0b35e277 net: hns3: fix duplicate node in VLAN list 951805c23dff net: hns3: clear hardware resource when loading driver 08162f65642c rtnetlink: Return correct error on changing device netns f58e42d1928c net: marvell: fix MVNETA_TX_IN_PRGRS bit number 45454400a647 xgene-v2: Fix a resource leak in the error handling path of 'xge_probe()' 53b480e68c1c ip_gre: add validation for csum_start bb8ca7e2e67e RDMA/efa: Free IRQ vectors on error flow e29565b4515e e1000e: Fix the max snoop/no-snoop latency for 10M 8a21e84334ec IB/hfi1: Fix possible null-pointer dereference in _extend_sdma_tx_descs() 944a50f56f1b RDMA/bnxt_re: Add missing spin lock initialization 28b189541027 scsi: core: Fix hang of freezing queue between blocking and running device 628c582854d3 usb: dwc3: gadget: Stop EP0 transfers during pullup disable d9da281c8f9e usb: dwc3: gadget: Fix dwc3_calc_trbs_left() 21880abf19ba USB: serial: option: add new VID/PID to support Fibocom FG150 2e098e91eeec Revert "USB: serial: ch341: fix character loss at high transfer rates" 16b281a70a10 can: usb: esd_usb2: esd_usb2_rx_event(): fix the interchange of the CAN RX and TX error counters 765437d1f078 mm, oom: make the calculation of oom badness more accurate 1cccf5c03077 mmc: sdhci-msm: Update the software timeout value for sdhc aec1e470d906 ovl: fix uninitialized pointer read in ovl_lookup_real_one() 57bd5b59f1ce once: Fix panic when module unload 5892f910f401 netfilter: conntrack: collect all entries in one cycle 7c95c89b6929 ARC: Fix CONFIG_STACKDEPOT a6b049aeefa8 net: qrtr: fix another OOB Read in qrtr_endpoint_post ---- Link: https://lore.kernel.org/r/20210901122253.388326997@linuxfoundation.org # v5.4.144 Link: https://github.com/Freescale/linux-fslc/pull/434 Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
index 03d46758..5c3eb1e6 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v5.4.143 31# tag: v5.4.144
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -86,14 +86,14 @@ LICENSE = "GPLv2"
86LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 86LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
87 87
88KBRANCH = "5.4-2.3.x-imx" 88KBRANCH = "5.4-2.3.x-imx"
89SRCREV = "992eac2c403de62a640246018204afc58180ab5e" 89SRCREV = "bead25ae325e60cd00710df183254bd698f8a3d0"
90 90
91# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 91# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
92# required by kernel-yocto.bbclass. 92# required by kernel-yocto.bbclass.
93# 93#
94# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 94# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
95# should be updated once patchlevel is merged. 95# should be updated once patchlevel is merged.
96LINUX_VERSION = "5.4.143" 96LINUX_VERSION = "5.4.144"
97 97
98# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 98# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
99LOCALVERSION = "-5.4.70-2.3.0" 99LOCALVERSION = "-5.4.70-2.3.0"