summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-09-09 16:30:50 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-11 13:46:59 -0300
commitb821d72e7b7fc250eb80fa43a79ce31b88863239 (patch)
tree36a413f5702cd2d29b5023ec0762b71c27e4fac3
parent758ef64466143f464d3e01263bc1c1301a17a431 (diff)
downloadmeta-freescale-b821d72e7b7fc250eb80fa43a79ce31b88863239.tar.gz
qcacld: Drop BSP support
NXP has dropped support for qcacld, plus the code is not compatible with 5.10, so drop BSP support. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/firmware-qca/firmware-qca.inc15
-rw-r--r--recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb27
-rw-r--r--recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb27
-rw-r--r--recipes-bsp/firmware-qca/qca-tools_3.0.2.bb20
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb13
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb12
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb14
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb17
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc23
9 files changed, 0 insertions, 168 deletions
diff --git a/recipes-bsp/firmware-qca/firmware-qca.inc b/recipes-bsp/firmware-qca/firmware-qca.inc
deleted file mode 100644
index f33f4eb9..00000000
--- a/recipes-bsp/firmware-qca/firmware-qca.inc
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2018-2020 NXP
2
3SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware"
4SECTION = "base"
5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d \
7 file://QUALCOMM_ATHEROS_LICENSE_AGREEMENT.pdf;md5=e629669cf17f6a2a6872e067582986e3 \
8"
9
10SRC_URI = " ${FSL_MIRROR}/firmware-qca-${PV}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "75b1b2a8dea8f81609ccfc072d42fa86"
12SRC_URI[sha256sum] = "6ad56ac1df841e252ac6db0a8966082715a3cb6dc7189426bade13333a16fd9d"
13S = "${WORKDIR}/firmware-qca-${PV}"
14
15inherit fsl-eula-unpack
diff --git a/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb b/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb
deleted file mode 100644
index 47b289af..00000000
--- a/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1# Copyright (C) 2019-2020 NXP
2
3require firmware-qca.inc
4
5SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware"
6DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth firmware for modules such as QCA6174A"
7SECTION = "base"
8LICENSE = "Proprietary"
9
10inherit allarch
11
12do_install () {
13 # Install firmware.conf for QCA modules
14 install -d ${D}${sysconfdir}/bluetooth
15 install -m 644 ${S}/1CQ_QCA6174A_LEA_2.0/etc/bluetooth/firmware.conf ${D}${sysconfdir}/bluetooth
16
17 # Install firmware files
18 install -d ${D}${base_libdir}
19 cp -r ${S}/1CQ_QCA6174A_LEA_2.0/lib/firmware ${D}${base_libdir}
20}
21
22FILES_${PN} = " \
23 ${sysconfdir}/bluetooth/firmware.conf \
24 ${base_libdir}/firmware/qca6174 \
25 ${base_libdir}/firmware/wlan \
26 ${base_libdir}/firmware/* \
27"
diff --git a/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb b/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb
deleted file mode 100644
index 26c41d50..00000000
--- a/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1# Copyright (C) 2018-2020 NXP
2
3require firmware-qca.inc
4
5SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware"
6DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth firmware for modules such as QCA9377-3"
7SECTION = "base"
8LICENSE = "Proprietary"
9
10inherit allarch
11
12do_install () {
13 # Install firmware.conf for QCA modules
14 install -d ${D}${sysconfdir}/bluetooth
15 install -m 644 ${S}/1PJ_QCA9377-3_LEA_3.0/etc/bluetooth/firmware.conf ${D}${sysconfdir}/bluetooth
16
17 # Install firmware files
18 install -d ${D}${base_libdir}
19 cp -r ${S}/1PJ_QCA9377-3_LEA_3.0/lib/firmware ${D}${base_libdir}
20}
21
22FILES_${PN} = " \
23 ${sysconfdir}/bluetooth/firmware.conf \
24 ${base_libdir}/firmware/qca \
25 ${base_libdir}/firmware/qca9377 \
26 ${base_libdir}/firmware/wlan \
27"
diff --git a/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb b/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb
deleted file mode 100644
index e996c62d..00000000
--- a/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1# Copyright (C) 2018-2020 NXP
2
3require firmware-qca.inc
4
5SUMMARY = "Qualcomm Wi-Fi and Bluetooth tools"
6DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth tools for modules such as QCA6174A and QCA9377"
7LICENSE = "Proprietary"
8
9DEPENDS = "libnl zlib"
10
11FCC_TOOLS_FOLDER ?= "qca9377_qca6174_arm32"
12FCC_TOOLS_FOLDER_aarch64 = "qca9377_qca6174_arm64"
13
14do_install() {
15 install -d ${D}${sbindir}/fcc_tools
16 cp -r ${S}/fcc_tools/${FCC_TOOLS_FOLDER} ${D}${sbindir}/fcc_tools
17}
18
19COMPATIBLE_HOST = '(aarch64|arm).*-linux'
20COMPATIBLE_HOST_libc-musl = 'null'
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb
deleted file mode 100644
index aeba7623..00000000
--- a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1# Copyright 2019 NXP
2
3SUMMARY = "Qualcomm Wi-Fi support"
4
5inherit packagegroup
6
7RDEPENDS_${PN} = " \
8 kernel-module-qca6174 \
9 firmware-qca6174 \
10"
11
12COMPATIBLE_HOST = '(aarch64|arm).*-linux'
13COMPATIBLE_HOST_libc-musl = 'null'
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb
deleted file mode 100644
index 43df5a70..00000000
--- a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1# Copyright 2019 NXP
2
3SUMMARY = "Qualcomm Wi-Fi support"
4
5inherit packagegroup
6
7RDEPENDS_${PN} = " \
8 kernel-module-qca9377 \
9 firmware-qca9377 \
10"
11COMPATIBLE_HOST = '(aarch64|arm).*-linux'
12COMPATIBLE_HOST_libc-musl = 'null'
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb
deleted file mode 100644
index f78a4c5b..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1require kernel-module-qcacld-lea.inc
2
3SUMMARY = "Qualcomm WiFi driver for QCA module 6174"
4
5EXTRA_OEMAKE += " \
6 CONFIG_ROME_IF=pci \
7 CONFIG_WLAN_FEATURE_11W=y \
8 CONFIG_WLAN_FEATURE_FILS=y \
9 CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \
10 MODNAME=qca6174 \
11 CONFIG_WLAN_FEATURE_DSRC=y \
12"
13
14RDEPENDS_${PN} += "firmware-qca6174"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb
deleted file mode 100644
index fbc87ea2..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1require kernel-module-qcacld-lea.inc
2
3SUMMARY = "Qualcomm WiFi driver for QCA module 9377"
4
5EXTRA_OEMAKE += " \
6 CONFIG_CLD_HL_SDIO_CORE=y \
7 CONFIG_FEATURE_COEX_PTA_CONFIG_ENABLE=y \
8 CONFIG_PER_VDEV_TX_DESC_POOL=1 \
9 CONFIG_QCA_LL_TX_FLOW_CT=1 \
10 CONFIG_QCA_SUPPORT_TXRX_DRIVER_TCP_DEL_ACK=y \
11 CONFIG_WLAN_FEATURE_FILS=y \
12 CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \
13 MODNAME=qca9377 \
14 SAP_AUTH_OFFLOAD=1 \
15"
16
17RDEPENDS_${PN} += "firmware-qca9377"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
deleted file mode 100644
index 0b23a47c..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Qualcomm WiFi driver for QCA module 9377 and 6174"
2LICENSE = "BSD & GPLv2"
3LIC_FILES_CHKSUM = "file://CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=ec8d62116b13db773825ebf7cf91be1d;"
4
5QCACLD_SRC ?= "git://source.codeaurora.org/external/imx/qcacld-2.0-imx.git;protocol=https"
6SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_3.0_KRL5.4"
7SRCREV = "7dc91e5977f31d60741c55682564788c0f930163"
8
9S = "${WORKDIR}/git"
10
11inherit module
12
13EXTRA_OEMAKE += " \
14 CONFIG_CFG80211_INTERNAL_REGDB=y \
15 CONFIG_HDD_WLAN_WAIT_TIME=10000 \
16 CONFIG_LINUX_QCMBR=y \
17 CONFIG_NON_QC_PLATFORM=y \
18 CONFIG_PMF_SUPPORT=y \
19 TARGET_BUILD_VARIANT=user \
20"
21
22COMPATIBLE_MACHINE = "(imx)"
23COMPATIBLE_HOST_libc-musl = 'null'