summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-09-01 12:30:54 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-11 13:35:14 -0300
commit6b19e2160bef2a368336161340396354cae99203 (patch)
tree7c95fd5db194e558ed179fbe07732295dc5804e1
parentc2deae4bfa093582bee9e5f3e6d04a27de14d988 (diff)
downloadmeta-freescale-6b19e2160bef2a368336161340396354cae99203.tar.gz
imx-gst1.0-plugin: Upgrade to 4.6.1
Includes switch to meson. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb (renamed from recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.7.bb)31
1 files changed, 14 insertions, 17 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.7.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index c8bb6cd8..ea059cd8 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.7.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -1,5 +1,5 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor 1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2019 NXP 2# Copyright 2017-2021 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA. 3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
5 5
@@ -20,16 +20,15 @@ RCONFLICTS_${PN} = "gst1.0-fsl-plugin"
20LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ 20LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
21 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" 21 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
22 22
23SRCBRANCH = "MM_04.05.07_2011_L5.4.70" 23SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
24 24
25SRC_URI = " \ 25
26 git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH} \ 26SRC_URI = "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
27" 27SRCREV = "057e6bfbc208ce31e8ed0af0264dd1e86de05808"
28SRCREV = "659ec4947d6b1903d26e4ec9e40ae251a659935d"
29 28
30S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
31 30
32inherit autotools pkgconfig use-imx-headers 31inherit meson pkgconfig use-imx-headers
33 32
34PLATFORM_mx6 = "MX6" 33PLATFORM_mx6 = "MX6"
35PLATFORM_mx6sl = "MX6SL" 34PLATFORM_mx6sl = "MX6SL"
@@ -41,10 +40,9 @@ PLATFORM_mx7ulp= "MX7ULP"
41PLATFORM_mx8 = "MX8" 40PLATFORM_mx8 = "MX8"
42 41
43# Todo add a mechanism to map possible build targets 42# Todo add a mechanism to map possible build targets
44EXTRA_OECONF = "PLATFORM=${PLATFORM} \ 43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
45 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \ 44 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
46 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ 45"
47 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
48 46
49PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine" 47PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
50 48
@@ -60,14 +58,13 @@ PACKAGECONFIG_imxgpu2d = "overlaysink"
60 58
61# FIXME: Add all features 59# FIXME: Add all features
62# feature from excluded mm packages 60# feature from excluded mm packages
63PACKAGECONFIG[ac3] += ",,imx-ac3codec,imx-ac3codec" 61PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec"
64# feature from special mm packages 62# feature from special mm packages
65PACKAGECONFIG[aacp] += ",,imx-aacpcodec,imx-aacpcodec" 63PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec"
66MSDEPENDS = "imx-msparser imx-mscodec" 64MSDEPENDS = "imx-msparser imx-mscodec"
67PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}" 65PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}"
68PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}" 66PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}"
69OVDEPENDS = "virtual/libg2d" 67PACKAGECONFIG[overlaysink] += ",,virtual/libg2d"
70PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
71 68
72FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}" 69FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
73 70