summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-07-23 09:51:17 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-11 13:35:14 -0300
commit1c20118ec1e95b86bee5b4e8e8c51a4d880a216d (patch)
tree36e8fe61d41c2427e866cc1e6cdb5301c6a150e3
parentd28044c155443048725b6750118c771a9685eb71 (diff)
downloadmeta-freescale-1c20118ec1e95b86bee5b4e8e8c51a4d880a216d.tar.gz
imx-vpu-hantro: Upgrade to 1.22.0
4bce755 MA-18860-2 Enable H265 VP9 secure pipe line 8ef26ec MA-18860 Enable H265 VP9 secure pipe line c3fea31 M865SW-737 [VPU/G1G2] RV shouldn't report "DEC_ABORT" if get rpr_buf_idx failed 65bad6d M865SW-636 [VPU/G1G2] H264: fix seg fault at h264bsdResetStorage() 6138127 M865SW-728 [VPU/G1G2] decoder: luma size calculated incorrect for VP9 tiled output 71841a9 M865SW-605 [VPU/G1G2] decoder: Support secure video decoding 9430b52 M865SW-725: [VPU/G1G2] handle some hevc streams that bit-depth changing de7faff M865-682-9: [VPU/G1G2] move Vp9DecRemoveBuffer define location 12da6e6 M865-682-8: [VPU/G1G2] add SateRest into RemoveBuffer e6a9e89 M865-682-7: [VPU/G1G2] fix coverity issue 016adac M865-682-6: [VPU/G1G2] empty dpb buffer before remove 64c2742 M865SW-698 [VPU/G1G2] some kinds of vp9 stream with dtrc output foramt met hang dfe6ea9 M865SW-671 [VPU/V4L2] decoder: seek a resolution changed vp9 stream meet decoding error 91aa05e M865SW-682-5: [VPU/G1G2] fix issue for VP8/VP9 fd73b00 M865SW-693: [VPU/G1G2] VP8 unit test easily segment fault for resolution change clips 7755483 M865SW-682-4: [VPU/G1G2] fix trick mode issue for VP8 34feb35 M865SW-682-3: [VPU/G1G2] fix issue for G1 decoder and HEVC c01cf78 M865SW-522 [VPU/G1G2] decoder: Occurs segmentation fault at H264SetupVlcRegs() f8b2423 M865SW-682-2: [VPU/G1G2] extend API "XxxDecRemoveBuffer" in unfied_sw/decoder_sw 010b83d M865SW-682: [VPU/G1G2] extend API "XxxDecRemoveBuffer" in unfied_sw/decoder_sw 2c556f0 [VPU/G1G2]: merge yocto build workaround about linux version f18167f [VPU/H1]: merge yocto build workaround about linux version d936809 [VPU/G1G2]: Replace ion with dmabuf heaps for G1/G2 ae7b0b2 [VPU/H1]: Replace ion with dmabuf heaps for H1 2317103 M865SW-604: [VPU/G1G2] decoder: failed to decode to dtrc if sps and pps are transferred separately d00bd0b M865SW-656 [VPU/G1] vc1 met hang for some case which has repeat feature e809a90 M865SW-557 [VPU/G1] vp8 decoder get error in dpb_render_buffer: Assertion `id != -1' failed 7e65b5a M865SW-578/M865SW-622: [VPU/G1] Fix segmentation fault issue of one h264 stream 0fa47c3 NVJM850-56 playback fail for one sequence change stream. 2682560 M865SW-586-2: [VPU/G1] VC1: add new API to handle no start code for VC1_G format bf18d25 M865SW-586: [VPU/G1] VC1: add new API to handle no start code for VC1_G format 8e79720 M865SW-562: [VPU/G1] RV: set actual 'HWIF_STRM_START_BIT' through SetDecRegister() 8f210d3 M865SW-231: [G1/G2]: Avoid use virtual YUV buffer address as handler to support security mode Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch54
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb35
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb33
3 files changed, 33 insertions, 89 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
deleted file mode 100644
index 8d9610d5..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From 5bfb24738c47003fd04a86bfd5a49f8c6354ed23 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Fri, 28 Aug 2020 07:46:35 +0000
4Subject: [PATCH] decoder_sw: resolve compilation error with -fcommon
5
6-fcommon is enabled by default in gcc10 compiler, which results in
7following build errors:
8
9decoder_sw/software/source/inc/decapicommon.h:272: multiple definition
10of `DecPicCodingType'; decoder_sw/software/linux/dwl/dwl_linux.o:
11decoder_sw/software/source/inc/decapicommon.h:272: first defined here
12
13decoder_sw/software/source/inc/dwl.h:94: multiple definition of
14`DWLInitParam'; decoder_sw/software/linux/dwl/dwl_linux.o:
15decoder_sw/software/source/inc/dwl.h:94: first defined here
16
17Drop multiple enum name definitions, which solves above compilation
18issues.
19
20Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
21---
22 decoder_sw/software/source/inc/decapicommon.h | 2 +-
23 decoder_sw/software/source/inc/dwl.h | 2 +-
24 2 files changed, 2 insertions(+), 2 deletions(-)
25
26diff --git a/decoder_sw/software/source/inc/decapicommon.h b/decoder_sw/software/source/inc/decapicommon.h
27index 0f02092..fc8cccf 100755
28--- a/decoder_sw/software/source/inc/decapicommon.h
29+++ b/decoder_sw/software/source/inc/decapicommon.h
30@@ -269,7 +269,7 @@ enum DecPicCodingType {
31 DEC_PIC_TYPE_D = 3,
32 DEC_PIC_TYPE_FI = 4,
33 DEC_PIC_TYPE_BI = 5
34-} DecPicCodingType;
35+};
36
37 /* Output picture pixel format types for raster scan or down scale output */
38 enum DecPicturePixelFormat {
39diff --git a/decoder_sw/software/source/inc/dwl.h b/decoder_sw/software/source/inc/dwl.h
40index 6991f03..fd357b3 100755
41--- a/decoder_sw/software/source/inc/dwl.h
42+++ b/decoder_sw/software/source/inc/dwl.h
43@@ -91,7 +91,7 @@ struct DWLLinearMem {
44 /* DWLInitParam is used to pass parameters when initializing the DWL */
45 struct DWLInitParam {
46 u32 client_type;
47-} DWLInitParam;
48+};
49
50 /* Hardware configuration description, same as in top API */
51 typedef struct DecHwConfig DWLHwConfig;
52--
532.17.1
54
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
deleted file mode 100644
index b7c64cbb..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
11"
12SRC_URI[md5sum] = "682b3a73bf5aa22a37d56a433d11fc91"
13SRC_URI[sha256sum] = "e6cdd5b4c628604906466fc9620e2b048cf1b2c863f9ee49616dd5212b9261b0"
14
15inherit fsl-eula-unpack use-imx-headers
16
17PARALLEL_MAKE="-j 1"
18
19PLATFORM_mx8mm = "IMX8MM"
20PLATFORM_mx8mq = "IMX8MQ"
21PLATFORM_mx8mp = "IMX8MP"
22
23do_compile () {
24 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
25 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
26 PLATFORM="${PLATFORM}" all
27}
28
29do_install () {
30 oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
31}
32
33FILES_${PN} += "/unit_tests"
34
35COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb
new file mode 100644
index 00000000..6bac0e46
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb
@@ -0,0 +1,33 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "b65b49eadb6463b784e1a9e44a94fca1"
11SRC_URI[sha256sum] = "03c61dfb268b31a0d25a4d1387cb3ad0261029ad5de801f72224602e2b37da00"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM_mx8mm = "IMX8MM"
18PLATFORM_mx8mq = "IMX8MQ"
19PLATFORM_mx8mp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES_${PN} += "/unit_tests"
32
33COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"