summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-07-21 08:37:10 -0300
committerGitHub <noreply@github.com>2021-07-21 08:37:10 -0300
commit1477d896cdb782e05181ef7204c0a4e8126adeae (patch)
tree799b3a3ef8bb85a0661759ea6a32df8f2ab7427d
parent412ce9250b979dd08ea92f99636a6d17b9cf0bdd (diff)
parentcbf362ab33c2d658bfefd2354a885c8ffc4245a9 (diff)
downloadmeta-freescale-1477d896cdb782e05181ef7204c0a4e8126adeae.tar.gz
Merge pull request #831 from zandrey/kernel-upgrade-hardknott
[hardknott]: Consolidated Kernel update (v5.4.134 + v5.10.52)
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb23
-rw-r--r--recipes-kernel/linux/linux-fslc_5.10.bb4
2 files changed, 21 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
index 92423890..b7a5cd82 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v5.4.114 31# tag: v5.4.134
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -38,6 +38,21 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# 48afde5dc8ee LF-2692: clk: imx: scu: Do not enable runtime PM for CPU clks
42# dc760ca6a531 MLK-25468: seco_mu: hook v2x reset event
43# fee1ade052eb MPSDK-172 remoteproc: imx_rproc: Re-building communication channels when a remote crashes
44# b93083071e9f MLK-23277: 8qm: Fix SW workaround for i.MX8QM TKT340553
45# edfc37d93d8d MLK-25444: arch: arm64: dts: imx8dxl: Fix lcdif nodes
46# 319f1755edf3 MLK-25105-2: dts: arm64: imx8mp-ab2: use AK5552 compatible for sound card
47# 1e306d7fbb17 MLK-25105-1: dts: arm64: imx8mp-ab2: ensure SAI3 RX not in sync with TX
48# 67355ffc4af7 MLK-25103: ASoC: wm8524: avoid EPROBE_DEFER log
49# 090f71d23f8f clk: imx: add mux ops for i.MX8M composite clk
50# a7466010c566 LF-3623: media: imx8: isi: fix Can't match soc version
51# 398435ef11d7 MLK-25427 arm64: dts: imx8mp: add power-domains to irqsteer hdmi
52# 3125360c70f2 LF-3132: dmaengine: imx-sdma: raise up channel0 priority after resume
53# eddc2ac1d148 MLK-25116-2: dmaengine: imx-sdma: correct iram_pool check point
54# c53ff3924c06 MLK-25116-1: dmaengine: imx-sdma: save iram pool for bd allocated
55# 09370995212a MLK-25426 remoteproc: imx_rproc: fix firmware reload
41# b598b85172f7 irq-imx-irqsteer: fix compile error if CONFIG_PM_SLEEP is not set 56# b598b85172f7 irq-imx-irqsteer: fix compile error if CONFIG_PM_SLEEP is not set
42# 845099bfd0b8 fbdev: fix fbinfo flag dropped upstream 57# 845099bfd0b8 fbdev: fix fbinfo flag dropped upstream
43# 847bfb09bb3b arm64: dts: imx8m: change ocotp node name on i.MX8M SoCs 58# 847bfb09bb3b arm64: dts: imx8m: change ocotp node name on i.MX8M SoCs
@@ -71,17 +86,17 @@ LICENSE = "GPLv2"
71LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 86LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
72 87
73KBRANCH = "5.4-2.3.x-imx" 88KBRANCH = "5.4-2.3.x-imx"
74SRCREV = "f5b1a0c923d04cd49158bfb94fcfc5273474c076" 89SRCREV = "e3b082933caab27829e775606708381fe1b7c3ba"
75 90
76# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 91# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
77# required by kernel-yocto.bbclass. 92# required by kernel-yocto.bbclass.
78# 93#
79# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 94# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
80# should be updated once patchlevel is merged. 95# should be updated once patchlevel is merged.
81LINUX_VERSION = "5.4.114" 96LINUX_VERSION = "5.4.134"
82 97
83# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 98# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
84LOCALVERSION = "-imx-5.4.70-2.3.0" 99LOCALVERSION = "-5.4.70-2.3.0"
85 100
86DEFAULT_PREFERENCE = "1" 101DEFAULT_PREFERENCE = "1"
87 102
diff --git a/recipes-kernel/linux/linux-fslc_5.10.bb b/recipes-kernel/linux/linux-fslc_5.10.bb
index c5e99f86..6af937a7 100644
--- a/recipes-kernel/linux/linux-fslc_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc_5.10.bb
@@ -19,9 +19,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19# 19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
22LINUX_VERSION = "5.10.32" 22LINUX_VERSION = "5.10.52"
23 23
24KBRANCH = "5.10.x+fslc" 24KBRANCH = "5.10.x+fslc"
25SRCREV = "692b5e03f4be94f8e6ce381336cd290858841f49" 25SRCREV = "cb67a3e29a88e06e2891f8e2aac289305d8f08ff"
26 26
27COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)" 27COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)"