diff options
author | Ting Liu <ting.liu@nxp.com> | 2020-12-15 15:20:17 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-16 09:42:12 -0300 |
commit | b665fe6ad0a3eac583cab3cb606038a20a53523e (patch) | |
tree | 8aad48d3660d67cb74556287eca718c60a912578 | |
parent | 80a1e3a02dd634e0c2703dddb0e83e7385310040 (diff) | |
download | meta-freescale-b665fe6ad0a3eac583cab3cb606038a20a53523e.tar.gz |
dpdk: update to 7071c27f (LSDK-20.12)
Key changes:
* bump version to 19.11.4
* fix build failures with gcc10
* Support of LX2162A QDS
* Crypto: SEC PDCP-SDAP format on LX2160A, non-HMAC auth algorithm on LX2160A
* Memory pool: optimizing the buffer allocation time
Remove two obosolete patches as fixes are included in source code.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r-- | recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch | 53 | ||||
-rw-r--r-- | recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch | 39 | ||||
-rw-r--r-- | recipes-extended/dpdk/dpdk_19.11-20.12.bb (renamed from recipes-extended/dpdk/dpdk_19.11-20.04.bb) | 4 |
3 files changed, 1 insertions, 95 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch b/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch deleted file mode 100644 index 3b5a2b3a..00000000 --- a/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 6fe3e96ab6e92f8faca9784a46bc33d92790c2b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kevin Traynor <ktraynor@redhat.com> | ||
3 | Date: Wed, 11 Mar 2020 11:33:00 +0000 | ||
4 | Subject: [PATCH] examples/ipsec-gw: fix gcc 10 maybe-uninitialized warning | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | gcc 10.0.1 reports: | ||
10 | |||
11 | ../examples/ipsec-secgw/ipsec_process.c: In function ‘ipsec_process’: | ||
12 | ../examples/ipsec-secgw/ipsec_process.c:132:34: | ||
13 | error: ‘grp.m’ may be used uninitialized in this function | ||
14 | [-Werror=maybe-uninitialized] | ||
15 | 132 | grp[n].cnt = pkts + i - grp[n].m; | ||
16 | | ~~~~~~^~ | ||
17 | |||
18 | This is a correct warning for the initial execution of the statement. | ||
19 | However, it is the design of the loop that grp[0].cnt will later be | ||
20 | written with the correct value using an initialized grp[0].m before it | ||
21 | is used. | ||
22 | |||
23 | In order to remove the warning, initialize grp[0].m for the initial and | ||
24 | unused calculation of grp[0].cnt. | ||
25 | |||
26 | Fixes: 3e5f4625dc17 ("examples/ipsec-secgw: make data-path to use IPsec library") | ||
27 | Cc: stable@dpdk.org | ||
28 | |||
29 | Upstream-Status: Backport | ||
30 | |||
31 | Suggested-by: Konstantin Ananyev <konstantin.ananyev@intel.com> | ||
32 | Signed-off-by: Kevin Traynor <ktraynor@redhat.com> | ||
33 | Acked-by: Konstantin Ananyev <konstantin.ananyev@intel.com> | ||
34 | Signed-off-by: Jens Rehsack <jens.rehsack.ext@safrangroup.com> | ||
35 | --- | ||
36 | examples/ipsec-secgw/ipsec_process.c | 1 + | ||
37 | 1 file changed, 1 insertion(+) | ||
38 | |||
39 | diff --git a/examples/ipsec-secgw/ipsec_process.c b/examples/ipsec-secgw/ipsec_process.c | ||
40 | index 2eb5c8b34..37f406d46 100644 | ||
41 | --- a/examples/ipsec-secgw/ipsec_process.c | ||
42 | +++ b/examples/ipsec-secgw/ipsec_process.c | ||
43 | @@ -125,6 +125,7 @@ sa_group(void *sa_ptr[], struct rte_mbuf *pkts[], | ||
44 | void * const nosa = &spi; | ||
45 | |||
46 | sa = nosa; | ||
47 | + grp[0].m = pkts; | ||
48 | for (i = 0, n = 0; i != num; i++) { | ||
49 | |||
50 | if (sa != sa_ptr[i]) { | ||
51 | -- | ||
52 | 2.17.1 | ||
53 | |||
diff --git a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch b/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch deleted file mode 100644 index 61467377..00000000 --- a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From aa97b9162b68780ca912a226b5045a3ddab41d3c Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Thu, 4 Jul 2019 08:03:56 +0200 | ||
4 | Subject: [PATCH] update WERROR_FLAGS | ||
5 | |||
6 | Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com> | ||
7 | --- | ||
8 | kernel/linux/kni/Makefile | 2 +- | ||
9 | mk/toolchain/gcc/rte.vars.mk | 1 + | ||
10 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile | ||
13 | index 595bac261..a17939996 100644 | ||
14 | --- a/kernel/linux/kni/Makefile | ||
15 | +++ b/kernel/linux/kni/Makefile | ||
16 | @@ -14,7 +14,7 @@ MODULE = rte_kni | ||
17 | MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50 | ||
18 | MODULE_CFLAGS += -I$(RTE_OUTPUT)/include | ||
19 | MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h | ||
20 | -MODULE_CFLAGS += -Wall -Werror | ||
21 | +MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes | ||
22 | |||
23 | -include /etc/lsb-release | ||
24 | |||
25 | diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk | ||
26 | index de5e0d24d..ca2cb5fcd 100644 | ||
27 | --- a/mk/toolchain/gcc/rte.vars.mk | ||
28 | +++ b/mk/toolchain/gcc/rte.vars.mk | ||
29 | @@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual | ||
30 | WERROR_FLAGS += -Wformat-nonliteral -Wformat-security | ||
31 | WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated | ||
32 | WERROR_FLAGS += -Wno-error=pedantic | ||
33 | +WERROR_FLAGS += -Wno-address-of-packed-member | ||
34 | |||
35 | ifeq ($(RTE_DEVEL_BUILD),y) | ||
36 | WERROR_FLAGS += -Werror | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.04.bb b/recipes-extended/dpdk/dpdk_19.11-20.12.bb index 53ee5095..426713c2 100644 --- a/recipes-extended/dpdk/dpdk_19.11-20.04.bb +++ b/recipes-extended/dpdk/dpdk_19.11-20.12.bb | |||
@@ -7,11 +7,9 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr | |||
7 | file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ | 7 | file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ |
8 | file://0001-add-Wno-cast-function-type.patch \ | 8 | file://0001-add-Wno-cast-function-type.patch \ |
9 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ | 9 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ |
10 | file://0004-update-WERROR_FLAGS.patch \ | ||
11 | file://0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch \ | ||
12 | file://0005-use-python3-instead-of-python.patch \ | 10 | file://0005-use-python3-instead-of-python.patch \ |
13 | " | 11 | " |
14 | SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540" | 12 | SRCREV = "7071c27f6f5aefb57de1cffab3484707b1e82e2b" |
15 | 13 | ||
16 | include dpdk.inc | 14 | include dpdk.inc |
17 | 15 | ||