summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-05-24 20:38:39 -0300
committerGitHub <noreply@github.com>2023-05-24 20:38:39 -0300
commit63169d4ba8fd427b0a95c9e666864291e7c191ce (patch)
tree36469562b733b6b5fcb3b18f488620f3294e07fc
parent00b357a78a53de19e8fe44c0f2af710e993bc2e7 (diff)
parenta48a26ff818976ec3df1f11dbfe9ccfed496a30c (diff)
downloadmeta-freescale-63169d4ba8fd427b0a95c9e666864291e7c191ce.tar.gz
Merge pull request #1545 from EstebanSannin/kirkstone
keyctl-caam: add keyctl-caam recipe from meta-imx
-rw-r--r--recipes-security/swm/keyctl-caam_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-security/swm/keyctl-caam_git.bb b/recipes-security/swm/keyctl-caam_git.bb
new file mode 100644
index 00000000..25a5f656
--- /dev/null
+++ b/recipes-security/swm/keyctl-caam_git.bb
@@ -0,0 +1,23 @@
1# Copyright 2020-2022 NXP
2
3SUMMARY = "NXP i.MX CAAM Keyctl"
4DESCRIPTION = "NXP i.MX keyctl tool to manage CAAM Keys"
5SECTION = "base"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8636bd68fc00cc6a3809b7b58b45f982"
8
9SRCBRANCH = "master"
10SRC_URI = "git://github.com/nxp-imx/keyctl_caam.git;protocol=https;branch=${SRCBRANCH}"
11
12SRCREV = "81dc06cdb9c4d0d4ba10459d85af9a8603774948"
13
14S = "${WORKDIR}/git"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_install () {
19 oe_runmake DESTDIR=${D} install
20}
21
22COMPATIBLE_MACHINE = "(imx-generic-bsp)"
23