diff options
author | Jens Rehsack <sno@netbsd.org> | 2020-04-07 12:26:00 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-07 16:09:42 -0300 |
commit | 69652b4462808810ac189af030d9fc13a89e3b27 (patch) | |
tree | 9862a9250beee2b6c2de9498d344d23ee405a2d5 | |
parent | 70067683431d3ce1fe20589a355e24d29aba5fc0 (diff) | |
download | meta-freescale-69652b4462808810ac189af030d9fc13a89e3b27.tar.gz |
linux-qoriq_4.19: upgrade to LSDK-20.04
Upgrade linux-qoriq_4.19 recipe to latest NXP release LSDK-20.04-V4.19
from LSDK-19.09-V4.19 including following changes:
c5f3ab9ac163 (tag: LSDK-20.04-V4.19, qoriq/linux-4.19) fixing self test for tls1.1 and tls1.2 single pass ciphers.
5d5737ee54f7 arm64: defconfig: Enable the SBSA watchdog
b0da7a0070bd arm64: dts: fixed the qdma error interrupt number
17bfa45fc97a ARM: dts: ls1021: Fix SGMII PCS link remaining down after PHY disconnect
8e703d5dad88 mmc: sdhci-of-esdhc: apply HS400 temporary fix-up to LX2160A Rev2.0
6c66fe4a2407 net/enetc: Set MAC Rx FIFO to recommended value
ab53a3444c3a Added the self-test for the TLS1.2 algorithms offload
8947cf783ae1 crypto: caam - added support for TLS1.1 & TLS1.2
30ae8885a6c6 irqchip/gic-v3-its: Allow use of LPI tables in reserved memory
89f5972362f4 irqchip/gic-v3-its: Register LPI tables with EFI config table
8d1e6ffc0b82 irqchip/gic-v3-its: Check that all RDs have the same property table
67a185f444f8 irqchip/gic-v3-its: Use pre-programmed redistributor tables with kdump kernels
11e0c43a3ae8 irqchip/gic-v3-its: Allow use of pre-programmed LPI tables
4860dc3e6e89 irqchip/gic-v3-its: Keep track of property table's PA and VA
5caac43e62b8 irqchip/gic-v3-its: Move pending table allocation to init time
9e9f18693f4c irqchip/gic-v3-its: Split property table clearing from allocation
5f1e021f0282 irqchip/gic-v3-its: Simplify LPI_PENDBASE_SZ usage
a3dcf288bc02 irqchip/gic-v3-its: Change initialization ordering for LPIs
928eb022f786 efi: add API to reserve memory persistently across kexec reboot
ea9d553c998d efi/arm: libstub: add a root memreserve config table
00e5b11fb3bc efi: honour memory reservations passed via a linux specific config table
33d441beeb59 dpaa2-eth: Avoid unbounded while loops
eae0197231f6 dpaa2-eth: Cleanup dead code
e957f2026612 soc: fsl: dpio: register dpio irq handlers after dpio create
5a8c89a492f8 of: Add OF_DMA_DEFAULT_COHERENT & select it on powerpc
696dbc9dcfdc arm64: dts: ls1028a: Add pmu dt nodes
2e5f9623dafc fsl_qbman: enable set link status
4595ddfa92bd arm64: dts: fix user-space networking on ls1028a
3e31c4ce8249 net: felix: check if ocelot port is null in IRQ clean
20147eb4c1e6 net: mscc: ocelot: use skb queue instead of skbs list
8be3bd33b58c net: mscc: ocelot: avoid incorrect consuming in skbs list
9fc33c38bcd3 tsn: fix tsn attribute is not compatible
373b056a0de7 arm64: dts: add overlay support for ls1028a-qds
9c9b3280c676 arm64: dts: fsl-ls1028a: Update DPDK device tree
e407a7ab893b arm64: dts: fsl-ls1028a-qds: Add overlays for various serdes protocols
7dcd061e477c arm64: dts: fsl-ls1028a: prepare dts for overlay
94f7ebe8502e arm64: dts: fsl-ls1028a-rdb: fix QSGMII PHY node names
e0f70ecb57d3 arm64: dts: ls1028a: Disable swp5 by default
2bdc59e11db6 arm64: dts: fsl: ls1028a: Disable eno3 and make swp5 the Felix CPU port
ee4cbfe37613 Revert "arm64: dts: LS1028a-rdb: use Ethernet PHY interrupt"
66fc14ea11f7 net: felix: update tsn driver to align libtsn
f2b4286ff309 PCI: Make the PCIe device can reconfigure the MPS when reset the bus
4dd0d328a908 sdk_dpaa: ceetm: fix recursive dependencies
12059a111852 net: ethernet: freescale: sdk_fman: fix the build warnings
e4fa47ae6dca sdk_fman: address compilation warning
55dd711d6112 sdk_fman: fix identation causing compilation warnings
a78eef21d79a sdk_dpa: align to upstream PHY_INTERFACE_MODE
2d63b52f7e51 sdk/qbman: fix issue in qman_delete_cgr_safe()
8b3b000d7739 imx: dp: Improve the AUX channel signal
931430a79e01 arm64: dts: lx2160a: add iommu-map property to pci nodes
672f44b173aa tsn: keep backward compatible for libtsn
b7dfc7cd4d28 arm64: dts: ls1028a: add chip-specific compatible string to usb nodes.
f3568890952c arm64:move elfcorehdr reservation early for crash dump kernel
0616621c3a4a dpaa2-eth: replace qdisc_put() with qdisc_destroy()
4b8f41137dc8 usb: dwc3: gadget: Fix controller get stuck when wrongly kick transfer
950a8dee2fbb crypto: caam/qi2 - fix typo in algorithm's driver name
68592866f8f8 soc: fsl: dpio: Enable ACP port in Linux QMAN driver
baf6b6652529 arm64: dts: ls208xa: Update qspi node properties for LS2088ARDB
fb53c813a779 fsl_qbman: Framework for enabling Link status notification
3fbc1dae9012 Revert "sdk_dpaa: ceetm: rename qdisc_destroy() to qdisc_put()"
2e74bba16760 Revert "net: sched: rename qdisc_destroy() to qdisc_put()"
82a8a2df6f41 mmc: sdhci-of-esdhc: update tuning erratum A-008171
7256ce8b5375 mmc: sdhci-of-esdhc: convert to use esdhc_tuning_window_ptr()
eef7a193cba7 mmc: sdhci-of-esdhc: fix up erratum A-008171 workaround
e6d3b57b4ef9 mmc: sdhci-of-esdhc: poll ESDHC_FLUSH_ASYNC_FIFO bit until completion
977cf95ef173 drivers/staging/fsl_qbman: Disable Portal Channel IRQs
bd97956ff682 sdk_fman: decrease log severity levels
d92be680d0fb staging: fsl-dpaa2/mac: do not stop MAC when the net_dev is not up
ba70058b9e30 staging: fsl-dpaa2/mac: reverse order of handling stop/start IRQs
41fd9d60a6c0 staging: fsl-dpaa2/mac: do not call dpmac_set_link_state() when nothing changed
6d8bdd8e0ff0 staging: dpaa2-mac: add link up/down events for dpmac
fd57eff1f39a usb: dwc3: Add cache type configuration support
bb7b716b2f1d usb: dwc3: Add chip-specific compatible string
a5c5754c9672 arm64: dts: layerscape: apply dma-coherent for dwc3 nodes
f031faa78956 arm64: dts: layerscape: add chip-specific compatible string to usb nodes
5e898de5a7b0 gpio : mpc8xxx : ls1088a/ls1028a edge detection mode bug fixs.
3e060ab5c18e gpio: mpc8xxx: Don't overwrite default irq_set_type callback
b4c7fa8c97e8 gpio/mpc8xxx: change irq handler from chained to normal
94211782ab8c Revert "gpio/mpc8xxx: change irq handler from chained to normal"
90bf198446a3 soc: fsl: dpio: Replace QMAN array mode by ring mode enqueue.
4996478c3e5a soc: fsl: dpio: QMAN performance improvement. Function pointer indirection.
40fc7f6982d5 soc: fsl: dpio: Adding QMAN multiple enqueue interface.
81b1c3d2dec9 enetc: disable EEE autoneg by default
2cdf670d5bd3 arm64: config: enable usb network card R8152 AX88179 and AX8817X driver
4e569f24ea75 bus: fsl-mc: add the dpdbg device type
2a797f3f428f sdk_dpaa: ceetm: save the root class pointer
5582ec5d14f2 Merge linux-4.19.90 of stable kernel of kernel.org into linux-4.19
Signed-off-by: Jens Rehsack <sno@netbsd.org>
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.19.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb index aed29df6..4c45f2c9 100644 --- a/recipes-kernel/linux/linux-qoriq_4.19.bb +++ b/recipes-kernel/linux/linux-qoriq_4.19.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | |||
8 | 8 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
10 | " | 10 | " |
11 | SRCREV = "4aba815fd6404a9620a66c8a3c2af4ba2a6a701a" | 11 | SRCREV = "c5f3ab9ac163f5c86a5c1ed163afaf24f2eea669" |
12 | 12 | ||
13 | SRC_URI += " file://0001-Makfefile-add-cflags.patch \ | 13 | SRC_URI += " file://0001-Makfefile-add-cflags.patch \ |
14 | " | 14 | " |