summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-08-23 08:31:29 -0300
committerGitHub <noreply@github.com>2021-08-23 08:31:29 -0300
commite15f3efc4c68063833ed3afd48cef30a8dc88d49 (patch)
tree5cf911d0a7e42c3790138de251a70bdac5daae44
parenteecf2602ccdf5106acb08211ffdfae59b2f3ffea (diff)
parent52d3cd841b91d0285e34813ea4a8fe079432adfe (diff)
downloadmeta-freescale-e15f3efc4c68063833ed3afd48cef30a8dc88d49.tar.gz
Merge pull request #847 from thochstein/master
Add OP-TEE support for imx6qdlsabre* machines
-rw-r--r--conf/machine/imx6qdlsabreauto.conf24
-rw-r--r--conf/machine/imx6qdlsabresd.conf21
-rw-r--r--conf/machine/include/imx-base.inc4
-rw-r--r--recipes-security/optee-imx/optee-os_3.10.0.imx.bb2
4 files changed, 37 insertions, 14 deletions
diff --git a/conf/machine/imx6qdlsabreauto.conf b/conf/machine/imx6qdlsabreauto.conf
index 8069fb3f..171b9f00 100644
--- a/conf/machine/imx6qdlsabreauto.conf
+++ b/conf/machine/imx6qdlsabreauto.conf
@@ -33,25 +33,37 @@ KERNEL_DEVICETREE:use-mainline-bsp = " \
33" 33"
34 34
35### u-boot-fslc settings ### 35### u-boot-fslc settings ###
36
37SPL_BINARY:pn-u-boot-fslc = "SPL" 36SPL_BINARY:pn-u-boot-fslc = "SPL"
38UBOOT_MACHINE:pn-u-boot-fslc ?= "mx6sabreauto_defconfig" 37UBOOT_CONFIG:pn-u-boot-fslc ??= "sd-fslc"
39UBOOT_SUFFIX:pn-u-boot-fslc = "img" 38UBOOT_SUFFIX:pn-u-boot-fslc = "img"
40 39
41### u-boot-imx settings ### 40### u-boot-imx settings ###
42
43# The u-boot-imx does not provide unified functionality for DL/Q/QP SoC
44# variants. Change the defconfig to the targeted SoC variant.
45SPL_BINARY:pn-u-boot-imx = "" 41SPL_BINARY:pn-u-boot-imx = ""
46UBOOT_MACHINE:pn-u-boot-imx = "mx6qsabreauto_defconfig" 42UBOOT_CONFIG:pn-u-boot-imx ??= " \
43 sd-imx \
44 ${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'sd-optee-imx', '', d)} \
45"
47UBOOT_MAKE_TARGET:pn-u-boot-imx = "u-boot.imx" 46UBOOT_MAKE_TARGET:pn-u-boot-imx = "u-boot.imx"
48UBOOT_SUFFIX:pn-u-boot-imx = "imx" 47UBOOT_SUFFIX:pn-u-boot-imx = "imx"
49 48
49# The u-boot-imx does not provide unified functionality for DL/Q/QP SoC
50# variants. Change the defconfig to the targeted SoC variant.
51UBOOT_CONFIG[sd-fslc] = "mx6sabreauto_defconfig,sdcard"
52UBOOT_CONFIG[sd-imx] = "mx6qpsabreauto_defconfig,sdcard"
53UBOOT_CONFIG[sd-optee-imx] = "mx6qpsabreauto_optee_defconfig,sdcard"
54UBOOT_CONFIG[eimnor-imx] = "mx6qpsabreauto_eimnor_defconfig"
55UBOOT_CONFIG[nand-imx] = "mx6qpsabreauto_nand_defconfig,ubifs"
56UBOOT_CONFIG[spinor-imx] = "mx6qpsabreauto_spinor_defconfig"
57UBOOT_CONFIG[sata-imx] = "mx6qpsabreauto_sata_defconfig"
58UBOOT_CONFIG[mfgtool-imx] = "mx6qpsabreauto_defconfig"
59
50WKS_FILE = " \ 60WKS_FILE = " \
51 ${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', \ 61 ${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', \
52 'u-boot-fslc', 'imx-uboot-spl-bootpart.wks.in', \ 62 'u-boot-fslc', 'imx-uboot-spl-bootpart.wks.in', \
53 'imx-uboot-bootpart.wks.in', d)}" 63 'imx-uboot-bootpart.wks.in', d)}"
54 64
65OPTEE_BIN_EXT = "6qpauto"
66
55SERIAL_CONSOLES = "115200;ttymxc3" 67SERIAL_CONSOLES = "115200;ttymxc3"
56 68
57MACHINE_FIRMWARE:append:mx6 = " linux-firmware-ath6k" 69MACHINE_FIRMWARE:append:mx6 = " linux-firmware-ath6k"
diff --git a/conf/machine/imx6qdlsabresd.conf b/conf/machine/imx6qdlsabresd.conf
index 215e0183..a5133625 100644
--- a/conf/machine/imx6qdlsabresd.conf
+++ b/conf/machine/imx6qdlsabresd.conf
@@ -42,25 +42,34 @@ KERNEL_DEVICETREE:use-mainline-bsp = " \
42" 42"
43 43
44### u-boot-fslc settings ### 44### u-boot-fslc settings ###
45
46SPL_BINARY:pn-u-boot-fslc = "SPL" 45SPL_BINARY:pn-u-boot-fslc = "SPL"
47UBOOT_MACHINE:pn-u-boot-fslc ?= "mx6sabresd_defconfig" 46UBOOT_CONFIG:pn-u-boot-fslc ??= "sd-fslc"
48UBOOT_SUFFIX:pn-u-boot-fslc = "img" 47UBOOT_SUFFIX:pn-u-boot-fslc = "img"
49 48
50### u-boot-imx settings ### 49### u-boot-imx settings ###
51
52# The u-boot-imx does not provide unified functionality for DL/Q/QP SoC
53# variants. Change the defconfig to the targeted SoC variant.
54SPL_BINARY:pn-u-boot-imx = "" 50SPL_BINARY:pn-u-boot-imx = ""
55UBOOT_MACHINE:pn-u-boot-imx ?= "mx6qsabresd_defconfig" 51UBOOT_CONFIG:pn-u-boot-imx ??= " \
52 sd-imx \
53 ${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'sd-optee-imx', '', d)} \
54"
56UBOOT_MAKE_TARGET:pn-u-boot-imx = "u-boot.imx" 55UBOOT_MAKE_TARGET:pn-u-boot-imx = "u-boot.imx"
57UBOOT_SUFFIX:pn-u-boot-imx = "imx" 56UBOOT_SUFFIX:pn-u-boot-imx = "imx"
58 57
58# The u-boot-imx does not provide unified functionality for DL/Q/QP SoC
59# variants. Change the defconfig to the targeted SoC variant.
60UBOOT_CONFIG[sd-fslc] = "mx6sabresd_defconfig,sdcard"
61UBOOT_CONFIG[sd-imx] = "mx6qsabresd_defconfig,sdcard"
62UBOOT_CONFIG[sd-optee-imx] = "mx6qsabresd_optee_defconfig,sdcard"
63UBOOT_CONFIG[sata-imx] = "mx6qsabresd_sata_defconfig"
64UBOOT_CONFIG[mfgtool-imx] = "mx6qsabresd_defconfig"
65
59WKS_FILE = " \ 66WKS_FILE = " \
60 ${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', \ 67 ${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', \
61 'u-boot-fslc', 'imx-uboot-spl-bootpart.wks.in', \ 68 'u-boot-fslc', 'imx-uboot-spl-bootpart.wks.in', \
62 'imx-uboot-bootpart.wks.in', d)}" 69 'imx-uboot-bootpart.wks.in', d)}"
63 70
71OPTEE_BIN_EXT = "6qsdb"
72
64SERIAL_CONSOLES = "115200;ttymxc0" 73SERIAL_CONSOLES = "115200;ttymxc0"
65 74
66MACHINE_FIRMWARE:append:mx6 = " linux-firmware-ath6k" 75MACHINE_FIRMWARE:append:mx6 = " linux-firmware-ath6k"
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 094b17db..e8605749 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -406,8 +406,8 @@ SOC_DEFAULT_IMAGE_FSTYPES:mxs = "uboot-mxsboot-sdcard wic.bmap wic.gz"
406# Do not update fstab file when using wic images 406# Do not update fstab file when using wic images
407WIC_CREATE_EXTRA_ARGS ?= "--no-fstab-update" 407WIC_CREATE_EXTRA_ARGS ?= "--no-fstab-update"
408 408
409OPTEE_BOOT_IMAGE = "uTee" 409OPTEE_BOOT_IMAGE = "tee.bin uTee-${OPTEE_BIN_EXT}"
410OPTEE_BOOT_IMAGE:aarch64 = "" 410OPTEE_BOOT_IMAGE:aarch64 = "tee.bin"
411 411
412IMAGE_FSTYPES ?= "${SOC_DEFAULT_IMAGE_FSTYPES}" 412IMAGE_FSTYPES ?= "${SOC_DEFAULT_IMAGE_FSTYPES}"
413 413
diff --git a/recipes-security/optee-imx/optee-os_3.10.0.imx.bb b/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
index dc0f1731..8bfaf8dd 100644
--- a/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
@@ -22,6 +22,8 @@ inherit deploy python3native autotools
22 22
23# The platform flavor corresponds to the Yocto machine without the leading 'i'. 23# The platform flavor corresponds to the Yocto machine without the leading 'i'.
24PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}" 24PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}"
25PLATFORM_FLAVOR:imx6qdlsabresd = "mx6qsabresd"
26PLATFORM_FLAVOR:imx6qdlsabreauto = "mx6qsabreauto"
25PLATFORM_FLAVOR:imx6qpdlsolox = "mx6qsabresd" 27PLATFORM_FLAVOR:imx6qpdlsolox = "mx6qsabresd"
26PLATFORM_FLAVOR:imx6ul7d = "mx6ulevk" 28PLATFORM_FLAVOR:imx6ul7d = "mx6ulevk"
27PLATFORM_FLAVOR:imx6ull14x14evk = "mx6ullevk" 29PLATFORM_FLAVOR:imx6ull14x14evk = "mx6ullevk"