diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-04-01 11:14:24 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-04-11 09:00:13 -0300 |
commit | b81ce10b3e94506cea40ae121ea56782511b669d (patch) | |
tree | 209b6a0c6759d70287080dcba72f037c97be227a | |
parent | 0dc8c940fd7e6e556bb2225392bb75f254ed3d01 (diff) | |
download | meta-freescale-b81ce10b3e94506cea40ae121ea56782511b669d.tar.gz |
atf: update to 7e34aeb
*update to lsdk 1903 tag
include the following changes
7e34aeb - Fix 2088 sleep hang
dc16e35 - SDEI: Ensure SDEI handler executes with CVE-2018-3639 mitigation enabled
5eb3190 - Fast path SMCCC_ARCH_WORKAROUND_1 calls from AArch32
cd1e8ce - Add support for dynamic mitigation for CVE-2018-3639
82c570f - aarch32: Implement static workaround for CVE-2018-3639
2a655ec - Implement static workaround for CVE-2018-3639
90c75d3 - Rename symbols and files relating to CVE-2017-5715
179e18a - Fixup SMCCC_FEATURES return value for SMCCC_ARCH_WORKAROUND_1
2671898 - lx2: Remove setting of POWMGTCSR[LPM20_RQ] from LPM20 flow
7ca22ff - Adding LX2160 system power-down (LPM20)
0f81f07 - ls2088ardb: Add support of Non-ECC UDIMM
ee53ed7 - nxp/lx2: Enable Errate ERRATA_A72_859971 on LX2
*add ddr-phy to DEPENDS for lx2160a
*install ddr4_pmu_train_dmem.bin
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
-rw-r--r-- | recipes-bsp/atf/atf_git.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb index 883b7eaf..6583be84 100644 --- a/recipes-bsp/atf/atf_git.bb +++ b/recipes-bsp/atf/atf_git.bb | |||
@@ -5,14 +5,15 @@ LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443" | |||
5 | 5 | ||
6 | inherit deploy | 6 | inherit deploy |
7 | 7 | ||
8 | DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native uefi" | 8 | DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native" |
9 | DEPENDS_append_lx2160a += "ddr-phy" | ||
9 | DEPENDS_append_qoriq-arm64 += "optee-os-qoriq" | 10 | DEPENDS_append_qoriq-arm64 += "optee-os-qoriq" |
10 | do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" | 11 | do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" |
11 | 12 | ||
12 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
13 | 14 | ||
14 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" | 15 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" |
15 | SRCREV = "4971f394cf32e33e3a9ca23a4faa49d606af31c5" | 16 | SRCREV = "7e34aebe658c7c3439d2d68b0ce6b9776e8e6996" |
16 | 17 | ||
17 | SRC_URI += "file://0001-fix-fiptool-build-error.patch \ | 18 | SRC_URI += "file://0001-fix-fiptool-build-error.patch \ |
18 | file://0001-Makefile-add-CC-gcc.patch \ | 19 | file://0001-Makefile-add-CC-gcc.patch \ |
@@ -81,6 +82,9 @@ do_compile() { | |||
81 | bl32opt="BL32=${bl32}" | 82 | bl32opt="BL32=${bl32}" |
82 | spdopt="SPD=opteed" | 83 | spdopt="SPD=opteed" |
83 | fi | 84 | fi |
85 | if [ -f ${DEPLOY_DIR_IMAGE}/ddr-phy/ddr4_pmu_train_dmem.bin ]; then | ||
86 | cp ${DEPLOY_DIR_IMAGE}/ddr-phy/*.bin ${S}/ | ||
87 | fi | ||
84 | 88 | ||
85 | for d in ${BOOTTYPE}; do | 89 | for d in ${BOOTTYPE}; do |
86 | case $d in | 90 | case $d in |