summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-02-08 13:23:00 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-02-08 21:44:20 +0000
commit152c24157187f5ff068aa604a311ad8bb769def3 (patch)
tree4a8ad6e8ec97bdd806f2af094d1ad846eb71645a
parent374cac567108ccf66a9233367f21dd63a06a5235 (diff)
downloadmeta-freescale-152c24157187f5ff068aa604a311ad8bb769def3.tar.gz
imx-test: Update to 5.15.71_2.2.0
Includes support for 8ULP. Changes: ``` 6824398 LF6658: imx-jpeg: Add back support for contiguous NV12 85cf6ee LF-6654: imx-jpeg: Add crop support for encoder db62b23 LF-6654 imx-jpeg: Use selection API in unit test app 0569bed MLK-26028 Remove deprecated mxc_als_test b7257a3 LF-7058: mxc_v4l2_vpu_test: enhance h264 parse to support interlaced streams 4bb37e2 MLK-25799-13: mxc_v4l2_vpu_test: encoder setup capture first 8788be3 LF-6912: mxc_v4l2_vpu_test: dump backtrace when segmentation fault be5b55d LF-6740: mx8_v4l2_cap_drm.c: add camera support for iMX93 platform 8fc40e3 LF-6590-3: mxc_v4l2_vpu_test: fix a mistake in calculating plane alignment bdbfcee LF-6590-2: mxc_v4l2_vpu_test: don't write empty buffer to ofile 835d0bd MGS-6738: Remove SoC limitation from gpu and gpuinfo tool 0f2bfd2 LF-6590: mxc_v4l2_vpu_test: calculate alignment according to plane 2b53a64 LF-6588: mxc_v4l2_vpu_test: unify the encoder and decoder unittest f3840d8 LF-6364 epdc_v2: add two functions for the power consumption measurement f4f321c PM:unit_test: suspend_quick_auto.sh - Added a custom number of cycles for suspend/resume function 41f8fd1 LF-6065-2: mxc_v4l2_vpu_test: mxc_v4l2_vpu_dec.out handle pollerr aaf6a36 LF-6065-1: mxc_v4l2_vpu_test: fix code style according kernel style a57c5dc LF-5444: mxc-jpeg: Add parameter for quality factor 4ce851e MLK-25799-12: mxc_v4l2_vpu_test: G/S_PARM only for encoder's output queue 75a0c53 MLK-25799-11: mxc_v4l2_vpu_test: add git sha and commit date ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit a9ddfb566984739b0ea995cfa0d89bfe6915bf7d)
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index fc4f110c..e041c794 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -9,17 +9,18 @@ LICENSE = "GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-or-later;md5=fed54355545ffd980b814dab4a3b312c" 9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-or-later;md5=fed54355545ffd980b814dab4a3b312c"
10 10
11DEPENDS = "alsa-lib freetype libdrm" 11DEPENDS = "alsa-lib freetype libdrm"
12DEPENDS:append:mx6-nxp-bsp = " imx-lib"
13DEPENDS:append:mx7-nxp-bsp = " imx-lib"
14DEPENDS:append:imxvpu = " virtual/imxvpu" 12DEPENDS:append:imxvpu = " virtual/imxvpu"
13DEPENDS:append:mx6-nxp-bsp = " imx-lib"
14DEPENDS:append:mx7-nxp-bsp = " imx-lib"
15DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib"
15 16
16PE = "1" 17PE = "1"
17PV = "7.0+${SRCPV}" 18PV = "7.0+${SRCPV}"
18 19
19SRC_URI = "git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 20SRC_URI = "git://github.com/nxp-imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
20 file://memtool_profile" 21 file://memtool_profile"
21SRCBRANCH = "lf-5.15.32_2.0.0" 22SRCBRANCH = "lf-5.15.71_2.2.0"
22SRCREV = "c640c7e8456b0516851e76adb2acce6b3866b1fb" 23SRCREV = "68243988862f0e66a37754b4dbe4e7833b903f0c"
23 24
24S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
25 26
@@ -37,6 +38,7 @@ PLATFORM:mx6ul-nxp-bsp = "IMX6UL"
37PLATFORM:mx7d-nxp-bsp = "IMX7D" 38PLATFORM:mx7d-nxp-bsp = "IMX7D"
38PLATFORM:mx7ulp-nxp-bsp = "IMX7D" 39PLATFORM:mx7ulp-nxp-bsp = "IMX7D"
39PLATFORM:mx8-nxp-bsp = "IMX8" 40PLATFORM:mx8-nxp-bsp = "IMX8"
41PLATFORM:mx8ulp-nxp-bsp = "IMX8ULP"
40 42
41PARALLEL_MAKE = "-j 1" 43PARALLEL_MAKE = "-j 1"
42EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" 44EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}"