diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-01 16:44:32 -0500 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-09-05 11:50:05 +0000 |
commit | 19818194763f241ddc4af6881f734f4f4e46aecd (patch) | |
tree | e0b654bda61505dbe22be3a0513f43f168d251cd | |
parent | 81b734d44199797221ba2a6d8f4409bb3f855e81 (diff) | |
download | meta-freescale-19818194763f241ddc4af6881f734f4f4e46aecd.tar.gz |
imx-dsp: Upgrade 1.2.0 -> 2.0.0
Fixes:
1afdb74 MMFMWK-9126 dsp_wrapper: Switch to sw aac/aacp decoder with multi chan
89f44f8 MMFMWK-9123-7 unit_test: fsl-rend: Add pcm gain
d5ff750 MMFMWK-9123-6 unit_test: fsl-dec: Add pcm gain
024ec32 MMFMWK-9123-5 unit_test:src: Add source file for parser pcm info
f073481 MMFMWK-9123-4 dsp_framework: Makefile: Add pcm gain to build
d44697e MMFMWK-9123-3 Change CODEC_PCM_DEC to CODEC_PCM_GAIN
fcdcded MMFMWK-9123-2 common: library_load: Add check lib type
98e594d MMFMWK-9123-1 dsp_framework: main: Enlarge worker_thread_scratch_size
78029ab MMFMWK-9122: fix warning with yocto toolchain
2c5f489 MMFMWK-9122: switch to use yocto toolchain
cb76f5e MMFMWK-9121 libxa_af_hostless: sysdeps:linux: Add check for exit thread
a5c2f24 MMFMWK-9119: dsp_framework: Use production configuration for 8QM and 8QXP
f941878 MMFMWK-9117-2 dsp_framework: fsl-render: Remove checking rate for render
8ffdbbb MMFMWK-9117-1 unit_test: fsl-render: Add to get real dec format
3eae49a MMFMWK-9114-4: dsp_framework: render: fix noise issue after suspend
eeb9918 MMFMWK-9114-3: dsp_framework: hifi-dpf: add dead wait after suspend
cc43096 MMFMWK-9114-2: dsp_framework: render: free memory to avoid memory leak
e130ea1 MMFMWK-9114-1: dsp_framework: render: fix render can't work
67aa852 MMFMWK-9115 dsp_wrapper: Go to send output buffer when received init done
7cda1fc MMFMWK-9109 dsp_framework: unia-codec: Set codec id when load codec wrap
91ad2c9 MMFMWK-9113 dsp_framework: Add consumed len for getpara
3d2167c MMFMWK-9112 common: xaf-fsl-api: Fix no output if do reset before decoding
195faaf MMFMWK-9111-3 dsp_wrapper: fix android build issue
2aff770 MMFMWK-9111-2 common: fix android build issue
04ccf6d MMFMWK-9111-1 libxa_af_hostless: fix android build issue
5dba863 MMFMWK-9110 dsp_wrapper: fix get wrong value from dsp
0ddf545 MMFMWK-9107-2 dsp_wrapper: fix build warning
82685ed MMFMWK-9107-1 dsp_framework: render: fix build warning
1c60ffe MMFMWK-9104 dsp_framework: unia-codec: Ignore some codec decoding errors
9d63a74 MMFMWK-9108 build_dsp: Fix unit test name is not correct when install
11b653e MMFMWK-9105-2 dsp_wrapper: Add check codec library installed or not
464ae43 MMFMWK-9105-1 common: Move macro CORE_LIB_PATH to header
b9c186f MMFMWK-9103 dsp_wrapper: Fix decoding timeout after received eos
db0ac54 MMFMWK-9099 dsp_wrapper: Add channel num check for aac codec
956832e MMFMWK-9100 common: library_load: Add check lib_info section pool
159f7cf MMFMWK-9098 dsp_framework: unia-codec: Clear codec struct when init
f193eca dsp_framework: unia-codec: fixed memory size for chan_map_table
3ce22f9 Makefile: don't remove the tflm_imx8ulp.bin
25ccff0 Add TFLM DSP firmware binary
2803042 Remove TFLM dependency from test
0e3ba22 MMFMWK-9093-2 dsp_wrapper: Process fatal error from event
6dbba43 MMFMWK-9093-1 dsp_framework: unia-codec: Add fatal error for decoding
3fac033 Integrate TFLM
5681b5b common: xf-fsl-ipc: fix addr issue on munmap
b2907c8 dsp_framework: Enlarge dsp local mem
ceb3574 dsp_wrapper: fix seek error when comp status is XAF_EXEC_DONE
61a0b00 dsp_wrapper: Adjust msg flow
d145008 Revert "hifi-dpf: xa-class-audio-codec: Only purse input port if msg from proxy"
fac3a35 dsp_framework: enlarge mem
fa0697c dsp_framework: memory: Add success check for xf_uniacodec_malloc
ec02b01 dsp_wrapper: fix codec data
c01e084 dsp_wrapper: do not set codec data again if already set
f7fc455 dsp_wrapper: fix decoding error when end of stream
c3cd468 dsp_framework: unia-codec: init input_over, clear out_size
27f6a7a dsp_wrapper: Add wma channel layouts
271e820 common: xaf-fsl-api: Add error process
0c5da67 Revert "common: xf-fsl-ipc: fix reference counter issue"
b6f8ad7 dsp_wrapper: fix some wma streams seek error
b268d78 hifi-dpf: xa-class-audio-codec: Only purse input port if msg from proxy
edee928 dsp_wrapper: set wma alway is framed
ccb49dc dsp_wrapper: Remove offset_copy
b6d2e50 release:build_dsp: Generate software link
3e4057a Makefile.am Add dsp_rend_test.out
6398123 release: Add build_dsp
88f9736 Add SCR
731e9e7 Add README
3dde879 EULA: Add EULA.txt V32
56d7b47 dsp_wrapper: Add DEBUG macro to print info
3a4cbc5 dsp_wrapper: remove printf
dd1ef59 common: xf-fsl-ipc: fix reference counter issue
c9253c9 libxa_af_hostless:hifi-dpf: Remove check frame_size * sample_size
3f62eb2 dsp_wrapper: bugfix: Move mem_exit to xaf-fsl-api
805a7df dsp_framework: fix not enough buffer when loading
a796d8b dsp_wrapper: Add aac channel map in local
d58d51f dsp_wrapper: fix some ogg streams can't play
ed8ef02 Makefile: build DSP_WRAPPER
b6213bf testxa_af_hostless: xaf-mem-test: move mem_obj_t to xaf_adev_config_t
6b3f824 dsp_wrapper: fix outputformat error
4cf6f0b host-apf: Change xf_g_ap to local var
56fe689 dsp_wrapper: process decode err
b3c00e0 dsp_wrapper: remove printf
71002fe dsp_wrapper: Remove returned val process
408ae00 common: xaf-fsl-api: Add process XF_EVENT msg
c9af2d0 dsp_wrapper: Add support event msg
245f4ea dsp_framework: unia-codec: fix outbuf size is not correct
7476b62 dsp_framework: Move rpmsg_response to xf-core
197befd dsp_framework:plugins:unia-codec: Avoid to report narmal returned val
3ddf693 unit_test: Makefile: Remove XA_DISABLE_EVENT
40a10d3 dsp_wrapper: Makefile: Remove XA_DISABLE_EVENT
149187f dsp_framework: Makefile: Remove XA_DISABLE_EVENT
42c8b42 common: xaf-fsl-api: fix wrong val convert
c482b5e host-apf: xf-proxy: fix wrong buffer address
bc618a7 dsp_framework: plugins: unia-codec: Add reset buf cmd
c781b46 dsp_wrapper: Add reset dsp cmd in reset func
5d2145e common: fsl_unia: Add cmd UNIA_RESET_BUF
037ae78 dsp_framework: fix end of stream error in bypass mode
1cd2cc0 dsp_framework: unia-codec: Add set decoding fatal error
a127078 unit_test: rend: Add set cmd line param
05239b0 unit_test: rend: Support all codecs in rend
bb987cf dsp_framework: fix multi instances issue
cf07fed dsp_framework: set framework in bypass mode
0302efe dsp_wrapper: set chan map
71824c1 dsp_framework: set chan map
d2d3b09 dsp_framework: enlarge the local buffer size
128097d dsp_wrapper: Add dsp_wrapper
35d6abb xf-proxy: Add xf_flush function
1c7b002 unit_test: Add to support more codecs
ca3aabe unit_test: Add support to build dsp_rend_test
3430046 unit_test: initial xaf-fsl-mp3-dec-rend-test.c
18f9aea dsp_framework: Add renderer and peripherals driver
8b9e95a dsp_framework: initial xa-fsl-renderer.c
f1afdb0 unit_test: Add support MP3 decoder
6182802 unit_test: initial xaf-fsl-dec-test.c
5a19ec6 unit_test: initial xaf-fsl-api.c
0430abf dsp_framework: integrated unified audio codec plugin
8db1736 dsp_framework: Enable the basic rpmsg communication
9747302 rpmsg-lite: Add rpmsg-lite
2a2ab7b XAF: xa_hifi_af_hostless_lib_2_6_api_2_0_src.xws
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
(cherry picked from commit 1109c61e9e59adc31c8157fe97a042872fd81238)
-rw-r--r-- | recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb (renamed from recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb) | 15 |
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb index bfa279a0..03b22167 100644 --- a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb +++ b/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb | |||
@@ -1,19 +1,20 @@ | |||
1 | # Copyright 2017-2021 NXP | 1 | # Copyright 2017-2022 NXP |
2 | 2 | ||
3 | DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries" | 3 | DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries" |
4 | LICENSE = "Proprietary" | 4 | LICENSE = "Proprietary" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011" |
6 | 6 | ||
7 | inherit fsl-eula-unpack autotools pkgconfig | 7 | inherit fsl-eula-unpack autotools pkgconfig |
8 | 8 | ||
9 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | 9 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" |
10 | 10 | ||
11 | SRC_URI[md5sum] = "238d3f0256573ca657228d7090bcb7d3" | 11 | SRC_URI[md5sum] = "34f77ef1078b842e4cd67dc87c4c35a1" |
12 | SRC_URI[sha256sum] = "13f67f267d6d33e8be2a6c258a46cde3667258ac86435776cbf1a370de611476" | 12 | SRC_URI[sha256sum] = "c484a29ab880e8f7ec84d7df736bfa37817c41e64802f07140e9752ba9cd7956" |
13 | 13 | ||
14 | EXTRA_OECONF += " \ | 14 | EXTRA_OECONF = " \ |
15 | -datadir=${base_libdir}/firmware --bindir=/unit_tests \ | 15 | -datadir=${base_libdir}/firmware \ |
16 | ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', ' ', d)} \ | 16 | --bindir=/unit_tests \ |
17 | ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', '', d)} \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | RDEPENDS:${PN} += " imx-dsp-codec-ext" | 20 | RDEPENDS:${PN} += " imx-dsp-codec-ext" |