diff options
author | Nate Drude <nate.d@variscite.com> | 2022-01-13 13:27:44 -0600 |
---|---|---|
committer | Nate Drude <nate.d@variscite.com> | 2022-01-17 11:50:33 -0600 |
commit | b720c96e40bf96e9d8a8196828216dc4cac2f4c0 (patch) | |
tree | 54ae35ed6b211c2bdd9ae09b9484403f15e221d2 | |
parent | ca3e8f9ddc4f0fb314345584e8a2f18f4df12e29 (diff) | |
download | meta-freescale-b720c96e40bf96e9d8a8196828216dc4cac2f4c0.tar.gz |
imx-dsp: add recipe
As per NXP BSP: https://source.codeaurora.org/external/imx/meta-imx/tree/meta-bsp/recipes-multimedia/imx-dsp?h=hardknott-5.10.72-2.2.0
Signed-off-by: Nate Drude <nate.d@variscite.com>
-rw-r--r-- | recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb new file mode 100644 index 00000000..fe650eb1 --- /dev/null +++ b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | # Copyright 2017-2021 NXP | ||
2 | |||
3 | DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries" | ||
4 | LICENSE = "Proprietary" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f" | ||
6 | |||
7 | inherit fsl-eula-unpack autotools pkgconfig | ||
8 | |||
9 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | ||
10 | |||
11 | SRC_URI[md5sum] = "238d3f0256573ca657228d7090bcb7d3" | ||
12 | SRC_URI[sha256sum] = "13f67f267d6d33e8be2a6c258a46cde3667258ac86435776cbf1a370de611476" | ||
13 | |||
14 | EXTRA_OECONF += " \ | ||
15 | -datadir=${base_libdir}/firmware --bindir=/unit_tests \ | ||
16 | ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', ' ', d)} \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN} += " imx-dsp-codec-ext" | ||
20 | |||
21 | HIFI4_BIN ?= "hifi4_imx8qmqxp.bin" | ||
22 | HIFI4_BIN:mx8mp = "hifi4_imx8mp.bin" | ||
23 | HIFI4_BIN:mx8ulp = "hifi4_imx8ulp.bin" | ||
24 | |||
25 | do_install:append () { | ||
26 | # Rename DSP Firmware into hifi4.bin and remove unneeded binary | ||
27 | mv ${D}/lib/firmware/imx/dsp/${HIFI4_BIN} ${D}/lib/firmware/imx/dsp/hifi4.bin | ||
28 | find ${D}/lib/firmware/imx/dsp -name hifi4_*.bin -exec rm {} \; | ||
29 | } | ||
30 | |||
31 | FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \ | ||
32 | ${libdir}/imx-mm/audio-codec/wrap \ | ||
33 | ${base_libdir}/firmware/imx/dsp \ | ||
34 | /unit_tests \ | ||
35 | " | ||
36 | |||
37 | INSANE_SKIP:${PN} = "already-stripped arch ldflags dev-so" | ||
38 | |||
39 | # Fix strip command failed: 'Unable to recognise the format of the input file' | ||
40 | INHIBIT_PACKAGE_STRIP = "1" | ||
41 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
42 | INHIBIT_SYSROOT_STRIP = "1" | ||
43 | |||
44 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
45 | COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8mp|mx8ulp)" | ||