diff options
author | Ting Liu <ting.liu@nxp.com> | 2020-12-15 11:43:50 +0530 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-16 08:38:13 -0300 |
commit | f84d7ca5cf9332a29275870c873b9eac115c2755 (patch) | |
tree | 5bbe968c42c307af266e5494d2ca5749eba14ac9 | |
parent | 7dc2b3051ad148a62cb38cea050a443dd5f4c8ba (diff) | |
download | meta-freescale-f84d7ca5cf9332a29275870c873b9eac115c2755.tar.gz |
ovs-dpdk: update to 07213041
patch applied on git tree. remove it.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r-- | recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch | 34 | ||||
-rw-r--r-- | recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb | 6 |
2 files changed, 2 insertions, 38 deletions
diff --git a/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch b/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch deleted file mode 100644 index 71b2b58c..00000000 --- a/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 95c5c42b9581f595881df11ca8393dc6925f7d7d Mon Sep 17 00:00:00 2001 | ||
2 | From: Nipun Gupta <nipun.gupta@nxp.com> | ||
3 | Date: Thu, 14 Feb 2019 17:57:14 +0530 | ||
4 | Subject: [PATCH] netdev-dpdk: have env based configurable number of packet | ||
5 | buffers | ||
6 | |||
7 | use $export DPDK_NUM_MBUF=number | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Nipun Gupta <nipun.gupta@nxp.com> | ||
12 | --- | ||
13 | lib/netdev-dpdk.c | 5 +++++ | ||
14 | 1 file changed, 5 insertions(+) | ||
15 | |||
16 | diff --git a/lib/netdev-dpdk.c b/lib/netdev-dpdk.c | ||
17 | index 6187129c0..1f456a63f 100644 | ||
18 | --- a/lib/netdev-dpdk.c | ||
19 | +++ b/lib/netdev-dpdk.c | ||
20 | @@ -656,6 +656,11 @@ dpdk_calculate_mbufs(struct netdev_dpdk *dev, int mtu, bool per_port_mp) | ||
21 | { | ||
22 | uint32_t n_mbufs; | ||
23 | |||
24 | + if (getenv("DPDK_NUM_MBUF")) { | ||
25 | + n_mbufs = atoi(getenv("DPDK_NUM_MBUF")); | ||
26 | + return n_mbufs; | ||
27 | + } | ||
28 | + | ||
29 | if (!per_port_mp) { | ||
30 | /* Shared memory are being used. | ||
31 | * XXX: this is a really rough method of provisioning memory. | ||
32 | -- | ||
33 | 2.17.1 | ||
34 | |||
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb index 9b5d2516..9e817579 100644 --- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb +++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb | |||
@@ -7,10 +7,8 @@ RDEPENDS_${PN} = "bash libcrypto libssl python3" | |||
7 | 7 | ||
8 | inherit python3native | 8 | inherit python3native |
9 | 9 | ||
10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ | 10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1" |
11 | file://0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch \ | 11 | SRCREV = "072130412196029bcc284e353023d81019a8daa7" |
12 | " | ||
13 | SRCREV = "71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3" | ||
14 | 12 | ||
15 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
16 | 14 | ||