summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-10-26 09:22:31 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2022-11-28 08:45:08 -0300
commitcf3221cda330fa315d227f5f3941550706898ce2 (patch)
tree403e11813841345e7a645de751321c7274e767c5
parenteefa361a061ea3571d31a6f1a65d4a24e059eeaf (diff)
downloadmeta-freescale-cf3221cda330fa315d227f5f3941550706898ce2.tar.gz
imx-boot: Create missing build directories
These are needed by do_uboot_assemble_fitimage code after https://git.openembedded.org/openembedded-core/commit/?id=5e12dc911d0c541f43aa6d0c046fb87e8b7c1f7e since this code now expects these directories to exist even if we are not using it Fixes run.do_uboot_assemble_fitimage.2153024: line 1 64: cd: /mnt/b/yoe/master/build/tmp/work/imx8qm_var_som-yoe-linux-musl/imx-boot/1.0-r0/git/imx8qm_var_som_defconfig: No such file or directory Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 94374963a83b6d99c696f211aae1a41346ca983a)
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index ae7e2638..5c20fac8 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -72,6 +72,12 @@ REV_OPTION:mx8qxp-generic-bsp = \
72 'REV=C0', d)}" 72 'REV=C0', d)}"
73REV_OPTION:mx8dx-generic-bsp = "REV=C0" 73REV_OPTION:mx8dx-generic-bsp = "REV=C0"
74 74
75do_uboot_assemble_fitimage:prepend:imx-generic-bsp() {
76 for config in ${UBOOT_MACHINE}; do
77 mkdir -p ${B}/${config}
78 done
79}
80
75compile_mx8m() { 81compile_mx8m() {
76 bbnote 8MQ/8MM/8MN/8MP boot binary build 82 bbnote 8MQ/8MM/8MN/8MP boot binary build
77 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do 83 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do