diff options
author | Yuqing Zhu <carol.zhu@nxp.com> | 2018-09-30 16:52:42 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-01 14:54:15 -0300 |
commit | 025c133c7fd9162046b0558dbd98579768a6d6e7 (patch) | |
tree | 950b1729c7dedcaffb0fee0edaa4a3ca76d73f88 | |
parent | 3c5a39289283939c428e16c034d4cd0d929152ad (diff) | |
download | meta-freescale-025c133c7fd9162046b0558dbd98579768a6d6e7.tar.gz |
gstreamer1.0-plugins-base: Update to L4.9.123-2.3.0_8mm_ga release
Add i.MX8MM feature list accoridng to soc_id
Add marcos for i.MX8MM chip code in gstimxcommon
Respect to downstream format priority in glupload
Fix ion.h header inclusion to be standard
Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
2 files changed, 53 insertions, 2 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch new file mode 100644 index 00000000..d3822cfc --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 84f693a70e6f3084ca67063a6336aaf3287abb49 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yuqing Zhu <carol.zhu@nxp.com> | ||
3 | Date: Thu, 27 Sep 2018 13:53:49 +0800 | ||
4 | Subject: [PATCH] gstreamer1.0-plugins-base: Fix ion.h header inclusion to be | ||
5 | standard | ||
6 | |||
7 | NXP "solution" was to manually copy the header to include/linux. | ||
8 | Let's point the Makefile to the proper (mainline) location instead: | ||
9 | https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h | ||
10 | |||
11 | Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | gst-libs/gst/allocators/gstionmemory.c | 2 +- | ||
15 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 51272df..4bea0dd 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -678,7 +678,7 @@ AG_GST_CHECK_FEATURE(CDPARANOIA, [CDParanoia], cdparanoia, [ | ||
22 | dnl check for ion | ||
23 | translit(dnm, m, l) AM_CONDITIONAL(USE_ION, true) | ||
24 | AG_GST_CHECK_FEATURE(ION, [ion], ion, [ | ||
25 | - AC_CHECK_HEADER(linux/ion.h, HAVE_ION="yes", HAVE_ION="no") | ||
26 | + AC_CHECK_HEADER(ion.h, HAVE_ION="yes", HAVE_ION="no") | ||
27 | ]) | ||
28 | |||
29 | dnl FIXME : add second check somehow if that is necessary | ||
30 | diff --git a/gst-libs/gst/allocators/gstionmemory.c b/gst-libs/gst/allocators/gstionmemory.c | ||
31 | index 5e0455c..a285f09 100644 | ||
32 | --- a/gst-libs/gst/allocators/gstionmemory.c | ||
33 | +++ b/gst-libs/gst/allocators/gstionmemory.c | ||
34 | @@ -26,7 +26,7 @@ | ||
35 | #include <sys/ioctl.h> | ||
36 | #include <sys/mman.h> | ||
37 | #include <sys/types.h> | ||
38 | -#include <linux/ion.h> | ||
39 | +#include <ion.h> | ||
40 | #include <linux/dma-buf.h> | ||
41 | #include <linux/version.h> | ||
42 | |||
43 | -- | ||
44 | 1.9.1 | ||
45 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb index 3ea3d571..3d31d22f 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \ | |||
6 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" | 6 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" |
7 | 7 | ||
8 | GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" | 8 | GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" |
9 | SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2" | 9 | SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA" |
10 | 10 | ||
11 | SRC_URI = " \ | 11 | SRC_URI = " \ |
12 | ${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \ | 12 | ${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \ |
@@ -16,8 +16,9 @@ SRC_URI = " \ | |||
16 | file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \ | 16 | file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \ |
17 | file://0003-riff-add-missing-include-directories-when-calling-in.patch \ | 17 | file://0003-riff-add-missing-include-directories-when-calling-in.patch \ |
18 | file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \ | 18 | file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \ |
19 | file://0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch \ | ||
19 | " | 20 | " |
20 | SRCREV = "04bafd740a52757f12496206cfabe282835a1eb5" | 21 | SRCREV = "e1f90437939b147658efed4d86c3f99d5e606968" |
21 | 22 | ||
22 | DEFAULT_PREFERENCE = "-1" | 23 | DEFAULT_PREFERENCE = "-1" |
23 | 24 | ||
@@ -62,6 +63,11 @@ PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" | |||
62 | 63 | ||
63 | EXTRA_OECONF += " \ | 64 | EXTRA_OECONF += " \ |
64 | --enable-zlib \ | 65 | --enable-zlib \ |
66 | CPPFLAGS=" \ | ||
67 | -I${STAGING_KERNEL_DIR}/include/uapi \ | ||
68 | -I${STAGING_KERNEL_DIR}/include \ | ||
69 | -I${STAGING_KERNEL_DIR}/drivers/staging/android/uapi \ | ||
70 | " \ | ||
65 | " | 71 | " |
66 | 72 | ||
67 | CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no" | 73 | CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no" |