summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-31 12:46:27 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 10:02:16 -0200
commitc22fc3bc4e1c4a3e01225ce3d101f5ec1068f8dd (patch)
tree69934fc8e3ba8dd57569f2046a8965bcc5b76532
parenta557c92ecaa2e22e8cef76fb921786f6984ce803 (diff)
downloadmeta-freescale-c22fc3bc4e1c4a3e01225ce3d101f5ec1068f8dd.tar.gz
apptrk: remove
This pkg will not be supported anymore Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch24
-rw-r--r--recipes-bsp/apptrk/apptrk/no-strip.patch20
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb31
3 files changed, 0 insertions, 75 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
deleted file mode 100644
index 6b4a0e83..00000000
--- a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1Upstream-Status: Pending
2
3Signed-off-by: Chunrong Guo <B40290@freescale.com>
4
5
6 for fix the following error:
7 |install: cannot create regular file /usr/bin/apptrk
8 |No such file or directory
9
10
11--- a/Makefileold 2014-12-21 23:46:26.872329032 -0600
12+++ b/Makefile 2014-12-21 23:47:33.724326646 -0600
13@@ -89,9 +89,9 @@
14 # Other Targets
15 install: all
16 if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi
17- install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
18+ install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
19 if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi
20- install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
21+ install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
22
23 clean:
24 -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG)
diff --git a/recipes-bsp/apptrk/apptrk/no-strip.patch b/recipes-bsp/apptrk/apptrk/no-strip.patch
deleted file mode 100644
index a8cf6205..00000000
--- a/recipes-bsp/apptrk/apptrk/no-strip.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Disable stripping of binaries
2
3We don't want to strip these as this is handled separately at package
4time.
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Chunrong Guo <B40290@freescale.com>
9
10--- a/Makefileold 2015-01-07 03:45:32.786477574 -0600
11+++ b/Makefile 2015-01-07 03:46:28.426475588 -0600
12@@ -62,7 +62,7 @@
13 # CFLAGS += -DENABLE_64BIT_SUPPORT
14
15
16-LDFLAGS += -s
17+
18
19 # Add inputs and outputs from these tool invocations to the build variables
20
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
deleted file mode 100644
index 6016d42d..00000000
--- a/recipes-bsp/apptrk/apptrk_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Debug agent for Freescale CodeWarrior"
2SECTION = "apptrk"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
5
6DEPENDS = "elfutils"
7
8inherit kernel-arch
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;branch=sdk-v2.0.x \
11 file://apptrk-install-create-all-components-of-DEST.patch \
12 file://no-strip.patch \
13"
14SRCREV = "873f44ca6b219508f738825299453d92975fb897"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE_qoriq-arm = "ARCH=arm"
19
20CFLAGS_append = " -I${STAGING_INCDIR} -ISource/Linux -ISource/Portable"
21CFLAGS_append_qoriq-arm = "-ISource/Linux_ARM -ISource/ARM"
22CFLAGS_append_qoriq-ppc += "-ISource/Linux_PA -ISource/PA -DPPC"
23CFLAGS_append_powerpc64 += "-DENABLE_64BIT_SUPPORT"
24
25do_install() {
26 oe_runmake install DESTDIR=${D}
27}
28
29COMPATIBLE_MACHINE = "(qoriq)"
30PACKAGE_ARCH = "${MACHINE_SOCARCH}"
31