summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-24 18:43:21 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-11-25 19:46:41 +0000
commit0be949f5bd324a381ec54864df2b2e41218e2aaa (patch)
treee41a03b910024a1fb5069650a887e684517606ed
parentc24381b41c56cad8c482b57b598edc5e352010d4 (diff)
downloadmeta-freescale-0be949f5bd324a381ec54864df2b2e41218e2aaa.tar.gz
kernel-module-isp-vvcam: prevent oe qa warning
When building objects in a path like ${S}/../isp/isp_miv1.o the resulting object files do not get their paths rewriten with the bitbake.conf provided DEBUG_PREFIX_MAP rules. Set DEBUG_PREFIX_MAP to the parent of ${S} to prevent the following warnings: | WARNING: kernel-module-isp-vvcam-4.2.2.19.0-r0 do_package_qa: QA Issue: | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/sensor/ar1335/.debug/ar1335.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/sensor/os08a20/.debug/os08a20.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/sensor/ov2775/.debug/ov2775.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/.debug/vvcam-dwe.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/.debug/vvcam-isp.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/focus/vcm_dw9790/.debug/vcm-dw9790.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR | File /lib/modules/5.15.77-5.15.77-2.1.0+g7547e8bfc01a/extra/video/.debug/vvcam-video.ko in package kernel-module-isp-vvcam-dbg contains reference to TMPDIR [buildpaths] Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit af6f0c510085280500372c07157e9edd68122d38)
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.19.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.19.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.19.0.bb
index 816d4acc..05431165 100644
--- a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.19.0.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.19.0.bb
@@ -10,6 +10,14 @@ SRCBRANCH = "lf-5.15.y_2.1.0"
10SRCREV = "b26ee8a5402afd7488716e06d82147669c05eb4a" 10SRCREV = "b26ee8a5402afd7488716e06d82147669c05eb4a"
11 11
12S = "${WORKDIR}/git/vvcam/v4l2" 12S = "${WORKDIR}/git/vvcam/v4l2"
13DEBUG_PREFIX_MAP = "-fmacro-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
14 -fdebug-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
15 -fmacro-prefix-map=${B}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
16 -fdebug-prefix-map=${B}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
17 -fdebug-prefix-map=${STAGING_DIR_HOST}= \
18 -fmacro-prefix-map=${STAGING_DIR_HOST}= \
19 -fdebug-prefix-map=${STAGING_DIR_NATIVE}= \
20"
13 21
14inherit module 22inherit module
15 23