diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-03-18 15:02:37 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:06:34 -0300 |
commit | 0036be1cd9be96d9048603e56b6fb776627def29 (patch) | |
tree | 67bc8fd00d2030f268cbd6b71fffe55b3096155e | |
parent | 393f232f8042997d27ab964e27c06bbf2e157822 (diff) | |
download | meta-freescale-0036be1cd9be96d9048603e56b6fb776627def29.tar.gz |
u-boot-fslc: Update to U-Boot 2016.03 based fork
This updates the fork for the 2016.03 release. Currently following
patches are applied on top of it:
fd6b196 warp7: Add initial support
f9dc5fe wandboard: Drop revision specific DeviceTree support
b3e771e mx6sabresd: Enable video interfaces in bootargs
e0a65b1 Revert "embestmx6boards: convert to use config_distro_bootcmd.h"
af0e438 iMX6: Change mmcroot to use fixed mmc block index for USDHC
36a641b embestmx6boards: Change default bootenv configuration
f97660e mx6sabresd: Use LDO dtb file until LDO bypass support is added
4064b09 mx6slevk: Use LDO dtb file until LDO bypass support is added
f854376 imx: mx7d: move MX7D to Kconfig entry
8a29233 imx: mx6sx: move MX6SX to Kconfig entry
d85319f arm: mx6: Add CCV xPress board support
fe7917e arm: mx6: Add UART8 base address for i.MX6UL
8730cc5 arm: imx6: Switch DDR3 calibration to wait_for_bit()
91c85e8 warp7: Add initial support
ca3306a mx7_common: Put early/late init configs into board file
1dfebcc mx7: Distinguish between dual and solo versions
dfcf27d mx7dsabresd: Define serial port locally
95817e0 mx7_common: Remove unexisting options
78eb121 arm: imx: Add support for GE Bx50v3 boards
Change-Id: I0e7ddd021fd87ffe8a5ad6916fd1eb7a3243b21b
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb) | 8 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc.inc | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2016.01.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2016.03.bb | 6 |
4 files changed, 12 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb index a0348c57..4ec03577 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.01.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.03.bb | |||
@@ -1,14 +1,14 @@ | |||
1 | DESCRIPTION = "U-boot bootloader mxsboot tool" | 1 | DESCRIPTION = "U-boot bootloader mxsboot tool" |
2 | LICENSE = "GPLv2+" | 2 | LICENSE = "GPLv2+" |
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" | 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
4 | SECTION = "bootloader" | 4 | SECTION = "bootloader" |
5 | DEPENDS = "openssl" | 5 | DEPENDS = "openssl" |
6 | PROVIDES = "u-boot-mxsboot" | 6 | PROVIDES = "u-boot-mxsboot" |
7 | 7 | ||
8 | PV = "v2016.01+git${SRCPV}" | 8 | PV = "v2016.03+git${SRCPV}" |
9 | 9 | ||
10 | SRCREV = "5da79530cef86a4e3a5e618b82f675da5bd3ca37" | 10 | SRCREV = "fd6b196f574ca85d75d6bbe24cf9344e58366ae1" |
11 | SRCBRANCH = "2016.01+fslc" | 11 | SRCBRANCH = "2016.03+fslc" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" | 13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" |
14 | 14 | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc index df67469c..c61c950c 100644 --- a/recipes-bsp/u-boot/u-boot-fslc.inc +++ b/recipes-bsp/u-boot/u-boot-fslc.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | require recipes-bsp/u-boot/u-boot.inc | 4 | require recipes-bsp/u-boot/u-boot.inc |
@@ -10,7 +10,7 @@ order to provide support for some backported features and fixes, or because it \ | |||
10 | was submitted for revision and it takes some time to become part of a stable \ | 10 | was submitted for revision and it takes some time to become part of a stable \ |
11 | version, or because it is not applicable for upstreaming." | 11 | version, or because it is not applicable for upstreaming." |
12 | LICENSE = "GPLv2+" | 12 | LICENSE = "GPLv2+" |
13 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" | 13 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
14 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx6ul|mx7|vf)" | 14 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx6ul|mx7|vf)" |
15 | 15 | ||
16 | DEPENDS_mxs += "elftosb-native openssl-native" | 16 | DEPENDS_mxs += "elftosb-native openssl-native" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb deleted file mode 100644 index aee89c8f..00000000 --- a/recipes-bsp/u-boot/u-boot-fslc_2016.01.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2016.01+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "5da79530cef86a4e3a5e618b82f675da5bd3ca37" | ||
6 | SRCBRANCH = "2016.01+fslc" | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb b/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb new file mode 100644 index 00000000..2358de34 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-fslc_2016.03.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2016.03+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "fd6b196f574ca85d75d6bbe24cf9344e58366ae1" | ||
6 | SRCBRANCH = "2016.03+fslc" | ||