summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 11:51:10 +0530
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 08:38:13 -0300
commit1ecd36e2c99c311dca574cc901b24d32762e5de9 (patch)
treec2e2a78db6f7c4eb5118da1c6c07c3ed1e70fd3b
parentba4431a2c9e42456a7ad918fb97a7bf6554cdbbc (diff)
downloadmeta-freescale-1ecd36e2c99c311dca574cc901b24d32762e5de9.tar.gz
linux-qoriq: update to LSDK 20.12 release (5.4.47)
Upgrade to LSDK-20.12 release with below key updates: * Support of LX2162A QDS * ACPI mode on LX2160A and LS1046A * DPAA2: adding bulking to XDP, building Tx S/G frames instead of realloc-ing skb, update bridge link status * ENETC: adaptive interrupt coalescing * Felix switch: configurable MTU for (jumbo frame support), port and flow policers (DSA) * IEEE1588: one-step timestamping on DPAA2, pps and periodical clock signal on Felix switch, FIPER3 on DPAA2, external trigger * PCIe: power management support * PPFE: driver be built-in instead of module * SDHC: eMMC RPBM partition, HS200 on LS1088A Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch63
-rw-r--r--recipes-kernel/linux/linux-qoriq_5.4.bb5
2 files changed, 2 insertions, 66 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch b/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
deleted file mode 100644
index e3df8084..00000000
--- a/recipes-kernel/linux/linux-qoriq/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From 0ada120c883d4f1f6aafd01cf0fbb10d8bbba015 Mon Sep 17 00:00:00 2001
2From: Changbin Du <changbin.du@gmail.com>
3Date: Tue, 28 Jan 2020 23:29:38 +0800
4Subject: [PATCH] perf: Make perf able to build with latest libbfd
5
6libbfd has changed the bfd_section_* macros to inline functions
7bfd_section_<field> since 2019-09-18. See below two commits:
8 o http://www.sourceware.org/ml/gdb-cvs/2019-09/msg00064.html
9 o https://www.sourceware.org/ml/gdb-cvs/2019-09/msg00072.html
10
11This fix make perf able to build with both old and new libbfd.
12
13Upstream-Status: Submitted [commit 0ada120c883d4f1f6aafd01cf0fbb10d8bbba015 upstream]
14
15Signed-off-by: Changbin Du <changbin.du@gmail.com>
16Acked-by: Jiri Olsa <jolsa@redhat.com>
17Cc: Peter Zijlstra <peterz@infradead.org>
18Link: http://lore.kernel.org/lkml/20200128152938.31413-1-changbin.du@gmail.com
19Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
20Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
21---
22 tools/perf/util/srcline.c | 16 +++++++++++++++-
23 1 file changed, 15 insertions(+), 1 deletion(-)
24
25diff --git a/tools/perf/util/srcline.c b/tools/perf/util/srcline.c
26index 6ccf6f6d09df..5b7d6c16d33f 100644
27--- a/tools/perf/util/srcline.c
28+++ b/tools/perf/util/srcline.c
29@@ -193,16 +193,30 @@ static void find_address_in_section(bfd *abfd, asection *section, void *data)
30 bfd_vma pc, vma;
31 bfd_size_type size;
32 struct a2l_data *a2l = data;
33+ flagword flags;
34
35 if (a2l->found)
36 return;
37
38- if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0)
39+#ifdef bfd_get_section_flags
40+ flags = bfd_get_section_flags(abfd, section);
41+#else
42+ flags = bfd_section_flags(section);
43+#endif
44+ if ((flags & SEC_ALLOC) == 0)
45 return;
46
47 pc = a2l->addr;
48+#ifdef bfd_get_section_vma
49 vma = bfd_get_section_vma(abfd, section);
50+#else
51+ vma = bfd_section_vma(section);
52+#endif
53+#ifdef bfd_get_section_size
54 size = bfd_get_section_size(section);
55+#else
56+ size = bfd_section_size(section);
57+#endif
58
59 if (pc < vma || pc >= vma + size)
60 return;
61--
622.17.1
63
diff --git a/recipes-kernel/linux/linux-qoriq_5.4.bb b/recipes-kernel/linux/linux-qoriq_5.4.bb
index 6a2f9c1f..54fd700c 100644
--- a/recipes-kernel/linux/linux-qoriq_5.4.bb
+++ b/recipes-kernel/linux/linux-qoriq_5.4.bb
@@ -1,15 +1,14 @@
1LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 1LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
2 2
3LINUX_VERSION = "5.4.3" 3LINUX_VERSION = "5.4.47"
4 4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
6 file://0001-Makfefile-linux-5.4-add-warning-cflags-on-LSDK-20.04.patch \ 6 file://0001-Makfefile-linux-5.4-add-warning-cflags-on-LSDK-20.04.patch \
7 file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch \
8 file://0001-perf-tests-bp_account-Make-global-variable-static.patch \ 7 file://0001-perf-tests-bp_account-Make-global-variable-static.patch \
9 file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \ 8 file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \
10 file://0001-perf-bench-Share-some-global-variables-to-fix-build-.patch \ 9 file://0001-perf-bench-Share-some-global-variables-to-fix-build-.patch \
11 file://0001-libtraceevent-Fix-build-with-binutils-2.35.patch \ 10 file://0001-libtraceevent-Fix-build-with-binutils-2.35.patch \
12" 11"
13SRCREV = "134788b16485dd9fa81988681d2365ee38633fa2" 12SRCREV = "6bff40d413b394c2d742e7a42089bfc62aef0a9b"
14 13
15require recipes-kernel/linux/linux-qoriq.inc 14require recipes-kernel/linux/linux-qoriq.inc