summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-10-30 16:14:54 -0500
committerOleksandr Suvorov <oleksandr.suvorov@foundries.io>2022-11-09 15:33:53 +0200
commitf77b39ebdfce535406d2c81860ef944cb46fe2d9 (patch)
treee54668558efb53666428692c59b12bdbc6dcf664
parentd388644623ca60eeb25cc2b38986f155819dc756 (diff)
downloadmeta-freescale-f77b39ebdfce535406d2c81860ef944cb46fe2d9.tar.gz
imx-mkimage: Simplify compile and install tasks
Replace do_compile() with EXTRA_OEMAKE: - The cd ${S} is redundant - The clean operation is already done in do_configure() - The two steps building the bin and mkimage_mx8 are the default behavior of the top-level Makefile with target mkimage_mx8 Drop redundant cd ${S} in do_install(). Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/imx-mkimage/imx-mkimage_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
index 0add1c92..f95f2a2b 100644
--- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
+++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
@@ -10,17 +10,11 @@ SECTION = "BSP"
10 10
11inherit deploy native 11inherit deploy native
12 12
13CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" 13EXTRA_OEMAKE = "SOC=iMX8M mkimage_imx8"
14 14
15do_compile () { 15CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}"
16 cd ${S}
17 oe_runmake clean
18 oe_runmake bin
19 oe_runmake -C iMX8M -f soc.mak mkimage_imx8
20}
21 16
22do_install () { 17do_install() {
23 cd ${S}
24 install -d ${D}${bindir} 18 install -d ${D}${bindir}
25 install -m 0755 iMX8M/mkimage_imx8 ${D}${bindir}/mkimage_imx8m 19 install -m 0755 iMX8M/mkimage_imx8 ${D}${bindir}/mkimage_imx8m
26 install -m 0755 iMX8M/mkimage_fit_atf.sh ${D}${bindir}/mkimage_fit_atf.sh 20 install -m 0755 iMX8M/mkimage_fit_atf.sh ${D}${bindir}/mkimage_fit_atf.sh