summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-08-01 14:48:54 -0500
committerNate Drude <nate.d@variscite.com>2022-10-25 13:50:22 -0500
commit76fdfef4bff0e831914dacf733c9e5c79e1e7bd8 (patch)
tree181cf5220511b1d878f9d9852ab66d53f2edd139
parent9f544ada2af55eebc10dd1cb932cf4899223398a (diff)
downloadmeta-freescale-76fdfef4bff0e831914dacf733c9e5c79e1e7bd8.tar.gz
optee: Upgrade 3.15.0.imx -> 3.17.0.imx
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit d5abe2b1f7afccc879671ca0fba212eca369e825)
-rw-r--r--conf/machine/include/imx-base.inc6
-rw-r--r--recipes-security/optee-imx/optee-client_3.17.0.imx.bb (renamed from recipes-security/optee-imx/optee-client_3.15.0.imx.bb)0
-rw-r--r--recipes-security/optee-imx/optee-os_3.17.0.imx.bb (renamed from recipes-security/optee-imx/optee-os_3.15.0.imx.bb)21
-rw-r--r--recipes-security/optee-imx/optee-test_3.17.0.imx.bb (renamed from recipes-security/optee-imx/optee-test_3.15.0.imx.bb)10
4 files changed, 17 insertions, 20 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 80027072..e9b751e0 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -490,9 +490,9 @@ PREFERRED_VERSION_vulkan-loader:imxvulkan ??= "1.2.182.0"
490PREFERRED_VERSION_vulkan-tools:imxvulkan ??= "1.2.182.0" 490PREFERRED_VERSION_vulkan-tools:imxvulkan ??= "1.2.182.0"
491 491
492# Use i.MX optee Version 492# Use i.MX optee Version
493PREFERRED_VERSION_optee-os:mx8-nxp-bsp ??= "3.15.0.imx" 493PREFERRED_VERSION_optee-os:mx8-nxp-bsp ??= "3.17.0.imx"
494PREFERRED_VERSION_optee-client:mx8-nxp-bsp ??= "3.15.0.imx" 494PREFERRED_VERSION_optee-client:mx8-nxp-bsp ??= "3.17.0.imx"
495PREFERRED_VERSION_optee-test:mx8-nxp-bsp ??= "3.15.0.imx" 495PREFERRED_VERSION_optee-test:mx8-nxp-bsp ??= "3.17.0.imx"
496 496
497#Use i.MX opencv Version for mx8 497#Use i.MX opencv Version for mx8
498PREFERRED_VERSION_opencv:mx8-nxp-bsp ??= "4.5.2.imx" 498PREFERRED_VERSION_opencv:mx8-nxp-bsp ??= "4.5.2.imx"
diff --git a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb b/recipes-security/optee-imx/optee-client_3.17.0.imx.bb
index 53ee5bc4..53ee5bc4 100644
--- a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.17.0.imx.bb
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
index 6d10b93d..d25c0f9d 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
@@ -6,12 +6,11 @@ HOMEPAGE = "http://www.optee.org/"
6LICENSE = "BSD-2-Clause" 6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c1f21c4f72f372ef38a5a4aee55ec173" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=c1f21c4f72f372ef38a5a4aee55ec173"
8 8
9DEPENDS = "python3-pycryptodomex-native python3-pyelftools-native u-boot-mkimage-native" 9DEPENDS = "python3-cryptography-native python3-pyelftools-native u-boot-mkimage-native"
10 10
11SRCBRANCH = "lf-5.15.5_1.0.0"
12SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH}" 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH}"
13 12SRCBRANCH = "lf-5.15.32_2.0.0"
14SRCREV = "807629a0889ad5e888f1fd187932ab7f701ddf8c" 13SRCREV = "984996422c25c99ebfc5194c1bb393028605bb0c"
15 14
16S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
17 16
@@ -49,13 +48,13 @@ OPTEE_ARCH:aarch64 = "arm64"
49# When defining CROSS_COMPILE and CROSS_COMPILE64, we assure that 48# When defining CROSS_COMPILE and CROSS_COMPILE64, we assure that
50# any 32 or 64 bits builds will pass 49# any 32 or 64 bits builds will pass
51EXTRA_OEMAKE = " \ 50EXTRA_OEMAKE = " \
52 PLATFORM=imx \ 51 PLATFORM=imx-${PLATFORM_FLAVOR} \
53 PLATFORM_FLAVOR=${PLATFORM_FLAVOR} \ 52 CROSS_COMPILE=${HOST_PREFIX} \
54 CROSS_COMPILE=${HOST_PREFIX} \ 53 CROSS_COMPILE64=${HOST_PREFIX} \
55 CROSS_COMPILE64=${HOST_PREFIX} \ 54 CFG_TEE_TA_LOG_LEVEL=0 \
56 CFG_TEE_TA_LOG_LEVEL=0 \ 55 CFG_TEE_CORE_LOG_LEVEL=0 \
57 CFG_TEE_CORE_LOG_LEVEL=0 \ 56 OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules \
58 -C ${S} O=${B}\ 57 -C ${S} O=${B} \
59" 58"
60 59
61LDFLAGS = "" 60LDFLAGS = ""
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.17.0.imx.bb
index a3649d74..54f92d72 100644
--- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.17.0.imx.bb
@@ -6,17 +6,15 @@ HOMEPAGE = "http://www.optee.org/"
6LICENSE = "BSD-2-Clause & GPL-2.0-only" 6LICENSE = "BSD-2-Clause & GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa" 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8 8
9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl" 9DEPENDS = "python3-cryptography-native optee-os optee-client openssl"
10
11SRCBRANCH = "lf-5.15.5_1.0.0"
12 10
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}" 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
12SRCBRANCH = "lf-5.15.32_2.0.0"
13SRCREV = "e064126a9769f168d1d0e178b74955e6648683b4"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build" 16B = "${WORKDIR}/build"
17 17
18SRCREV = "e9d8bf6ee121d6686e6e409c727caee76496bb86"
19
20inherit python3native features_check 18inherit python3native features_check
21 19
22REQUIRED_MACHINE_FEATURES = "optee" 20REQUIRED_MACHINE_FEATURES = "optee"
@@ -29,11 +27,11 @@ CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
29 27
30EXTRA_OEMAKE = " \ 28EXTRA_OEMAKE = " \
31 TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \ 29 TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \
32 ARCH=${OPTEE_ARCH} \
33 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ 30 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \
34 CROSS_COMPILE_HOST=${HOST_PREFIX} \ 31 CROSS_COMPILE_HOST=${HOST_PREFIX} \
35 CROSS_COMPILE_TA=${HOST_PREFIX} \ 32 CROSS_COMPILE_TA=${HOST_PREFIX} \
36 CROSS_COMPILE=${HOST_PREFIX} \ 33 CROSS_COMPILE=${HOST_PREFIX} \
34 OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules \
37 -C ${S} O=${B} \ 35 -C ${S} O=${B} \
38" 36"
39 37