summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-10-04 13:06:32 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-10-11 22:01:08 +0000
commit56493d0c5fc8592d0d751d3eefb7d7afe3cfd378 (patch)
treea1bba9eca87bbed0a0de20c4171f3a96d94a77d7
parentbf58f243f888320ff19f494eda271f0f39b9e20f (diff)
downloadmeta-freescale-56493d0c5fc8592d0d751d3eefb7d7afe3cfd378.tar.gz
vulkan: Downgrade to 1.2.182.0 for i.MX GPU
i.MX GPU drivers work with an older version of vulkan, so add the older recipes. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 705d5ca01245e1b0aa42d7380ad79ff1c3db8fcb)
-rw-r--r--conf/machine/include/imx-base.inc9
-rw-r--r--recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.bb22
-rw-r--r--recipes-downgrade/vulkan/vulkan-loader_1.2.182.0.bb41
-rw-r--r--recipes-downgrade/vulkan/vulkan-tools_1.2.182.0.bb32
-rw-r--r--recipes-graphics/vulkan/vulkan-loader_1.2.182.0.bbappend (renamed from recipes-graphics/vulkan/vulkan-loader_%.bbappend)0
5 files changed, 104 insertions, 0 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 9c7b6d29..80027072 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -306,6 +306,11 @@ MACHINE_SOCARCH_FILTER:append:imxvpu = " \
306 libimxvpuapi \ 306 libimxvpuapi \
307 virtual/imxvpu \ 307 virtual/imxvpu \
308" 308"
309MACHINE_SOCARCH_FILTER:append:imxvulkan = " \
310 vulkan-headers \
311 vulkan-loader \
312 vulkan-tools \
313"
309MACHINE_SOCARCH_FILTER:append:imxgpu = " \ 314MACHINE_SOCARCH_FILTER:append:imxgpu = " \
310 virtual/egl \ 315 virtual/egl \
311 virtual/mesa \ 316 virtual/mesa \
@@ -480,6 +485,10 @@ PREFERRED_VERSION_libdrm:mx6-nxp-bsp ??= "2.4.109.imx"
480PREFERRED_VERSION_libdrm:mx7-nxp-bsp ??= "2.4.109.imx" 485PREFERRED_VERSION_libdrm:mx7-nxp-bsp ??= "2.4.109.imx"
481PREFERRED_VERSION_libdrm:mx8-nxp-bsp ??= "2.4.109.imx" 486PREFERRED_VERSION_libdrm:mx8-nxp-bsp ??= "2.4.109.imx"
482 487
488PREFERRED_VERSION_vulkan-headers:imxvulkan ??= "1.2.182.0"
489PREFERRED_VERSION_vulkan-loader:imxvulkan ??= "1.2.182.0"
490PREFERRED_VERSION_vulkan-tools:imxvulkan ??= "1.2.182.0"
491
483# Use i.MX optee Version 492# Use i.MX optee Version
484PREFERRED_VERSION_optee-os:mx8-nxp-bsp ??= "3.15.0.imx" 493PREFERRED_VERSION_optee-os:mx8-nxp-bsp ??= "3.15.0.imx"
485PREFERRED_VERSION_optee-client:mx8-nxp-bsp ??= "3.15.0.imx" 494PREFERRED_VERSION_optee-client:mx8-nxp-bsp ??= "3.15.0.imx"
diff --git a/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.bb b/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.bb
new file mode 100644
index 00000000..7c7d3e39
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Vulkan Header files and API registry"
2DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=master;protocol=https"
13
14SRCREV = "37164a5726f7e6113810f9557903a117498421cf"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES:${PN} += "${datadir}/vulkan"
21
22UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
diff --git a/recipes-downgrade/vulkan/vulkan-loader_1.2.182.0.bb b/recipes-downgrade/vulkan/vulkan-loader_1.2.182.0.bb
new file mode 100644
index 00000000..e7b38222
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-loader_1.2.182.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "3D graphics and compute API common loader"
2DESCRIPTION = "Vulkan is a new generation graphics and compute API \
3that provides efficient access to modern GPUs. These packages \
4provide only the common vendor-agnostic library loader, headers and \
5the vulkaninfo utility."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Loader"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;protocol=https;branch=master \
13 "
14SRCREV = "1896143df69d439b0933c1bb485f5a4587bdf2dc"
15
16S = "${WORKDIR}/git"
17
18REQUIRED_DISTRO_FEATURES = "vulkan"
19
20inherit cmake features_check pkgconfig
21ANY_OF_DISTRO_FEATURES = "x11 wayland"
22
23DEPENDS += "vulkan-headers"
24
25EXTRA_OECMAKE = "\
26 -DBUILD_TESTS=OFF \
27 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
28 -DASSEMBLER_WORKS=FALSE \
29 -DVulkanHeaders_INCLUDE_DIR=${STAGING_INCDIR} \
30 -DVulkanRegistry_DIR=${RECIPE_SYSROOT}/${datadir} \
31 "
32
33# must choose x11 or wayland or both
34PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
35
36PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr"
37PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
38
39RRECOMMENDS:${PN} = "mesa-vulkan-drivers"
40
41UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
diff --git a/recipes-downgrade/vulkan/vulkan-tools_1.2.182.0.bb b/recipes-downgrade/vulkan/vulkan-tools_1.2.182.0.bb
new file mode 100644
index 00000000..242b8973
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-tools_1.2.182.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Vulkan Utilities and Tools"
2DESCRIPTION = "Assist development by enabling developers to verify their applications correct use of the Vulkan API."
3HOMEPAGE = "https://www.khronos.org/vulkan/"
4BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Tools"
5SECTION = "libs"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
9SRC_URI = "git://github.com/KhronosGroup/Vulkan-Tools.git;protocol=https;branch=sdk-1.2.182"
10SRCREV = "9d3305731c3be8de05c9f223a79959d448506a37"
11
12S = "${WORKDIR}/git"
13
14inherit cmake features_check
15ANY_OF_DISTRO_FEATURES = "x11 wayland"
16REQUIRED_DISTRO_FEATURES = "vulkan"
17
18DEPENDS += "vulkan-headers vulkan-loader"
19
20EXTRA_OECMAKE = "\
21 -DBUILD_TESTS=OFF \
22 -DBUILD_CUBE=OFF \
23 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
24 "
25
26# must choose x11 or wayland or both
27PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
28
29PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr"
30PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
31
32UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
diff --git a/recipes-graphics/vulkan/vulkan-loader_%.bbappend b/recipes-graphics/vulkan/vulkan-loader_1.2.182.0.bbappend
index 722896ff..722896ff 100644
--- a/recipes-graphics/vulkan/vulkan-loader_%.bbappend
+++ b/recipes-graphics/vulkan/vulkan-loader_1.2.182.0.bbappend