summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-08-19 16:40:32 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-08-26 20:54:38 +0000
commita2dbc8fbca79ca15929addbbed5b4dcc6b66f5cf (patch)
tree7d65b1587604fe9aacb9a1c485965f14cae7b2bd
parent727e59a88266c7baac4ad8bec59d3c41865b8efb (diff)
downloadmeta-freescale-a2dbc8fbca79ca15929addbbed5b4dcc6b66f5cf.tar.gz
kernel-module-isp-vvcam: Upgrade 4.2.2.16.0 -> 4.2.2.18.0
The patch 0001-dwe_isr.c-fix-error-found-by-gcc12.patch is now in the source, so drop it. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 54df01e57f0a246240567cef3d6971c4c1f78fc3)
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam/0001-dwe_isr.c-fix-error-found-by-gcc12.patch55
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.18.0.bb (renamed from recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb)12
2 files changed, 4 insertions, 63 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam/0001-dwe_isr.c-fix-error-found-by-gcc12.patch b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam/0001-dwe_isr.c-fix-error-found-by-gcc12.patch
deleted file mode 100644
index f317a08d..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam/0001-dwe_isr.c-fix-error-found-by-gcc12.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From 95c353810b55b30a70f1317369fcb179b444f2da Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Tue, 17 May 2022 14:49:55 +0000
4Subject: [PATCH] dwe_isr.c: fix error found by gcc12
5
6| .../vvcam/v4l2/../dwe/dwe_isr.c: In function 'update_dma_buffer':
7| .../vvcam/v4l2/../dwe/dwe_isr.c:107:47: error: the comparison will always evaluate as 'false' for the address of 'dist_map' will never be NULL [-Werror=address]
8| 107 | if (dev->dist_map[dev->index] == NULL) {
9| | ^~
10| cc1: all warnings being treated as errors
11| .../vvcam/v4l2/../dwe/dwe_dev.h:109:20: note: 'dist_map' declared here
12| 109 | dma_addr_t dist_map[MAX_DWE_NUM][MAX_CFG_NUM];
13| | ^~~~~~~~
14| cc1: all warnings being treated as errors
15
16Taking just one element of the first dimension of a multi-dimensional
17array always returns a valid pointer.
18
19Likely what was meant is to check if the later used element
20( dev->dist_map[dev->index][which] ) contains NULL but that isn't
21what the code does.
22Change the code according to that assumption.
23
24Upstream-Status: Pending
25
26Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
27---
28 vvcam/dwe/dwe_isr.c | 4 ++--
29 1 file changed, 2 insertions(+), 2 deletions(-)
30
31diff --git a/vvcam/dwe/dwe_isr.c b/vvcam/dwe/dwe_isr.c
32index ba74302..73ef83b 100644
33--- a/vvcam/dwe/dwe_isr.c
34+++ b/vvcam/dwe/dwe_isr.c
35@@ -104,7 +104,8 @@ static int update_dma_buffer(struct dwe_ic_dev *dev)
36 continue;
37 }
38
39- if (dev->dist_map[dev->index] == NULL) {
40+ which = dev->which[dev->index];
41+ if (dev->dist_map[dev->index][which] == (dma_addr_t)NULL) {
42 vvbuf_ready(dev->sink_bctx, dev->src->pad, dev->src);
43 dev->src = NULL;
44 dev->error = BUF_ERR_WRONGSTATE;
45@@ -121,7 +122,6 @@ static int update_dma_buffer(struct dwe_ic_dev *dev)
46 }
47 } while(dev->dst == NULL);
48
49- which = dev->which[dev->index];
50 dwe_s_params(dev, &dev->info[dev->index][which]);
51 dwe_set_buffer(dev, &dev->info[dev->index][which], dev->dst->dma);
52 dwe_set_lut(dev, dev->dist_map[dev->index][which]);
53--
542.20.1
55
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.18.0.bb
index c5356495..078f6a61 100644
--- a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.18.0.bb
@@ -4,14 +4,10 @@ DESCRIPTION = "Kernel loadable module for ISP"
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${S}/../LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44" 5LIC_FILES_CHKSUM = "file://${S}/../LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
6 6
7SRCBRANCH = "lf-5.10.y_2.2.0" 7SRC_URI = "${ISP_KERNEL_SRC};branch=${SRCBRANCH}"
8ISP_KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/isp-vvcam.git;protocol=https;branch=master" 8ISP_KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/isp-vvcam.git;protocol=https"
9 9SRCBRANCH = "lf-5.15.y_2.0.0"
10SRC_URI = " \ 10SRCREV = "551415470092d6af1d7e11e7a78591f5800333f9"
11 ${ISP_KERNEL_SRC};branch=${SRCBRANCH} \
12 file://0001-dwe_isr.c-fix-error-found-by-gcc12.patch;patchdir=${WORKDIR}/git \
13"
14SRCREV = "b2321c0c513322aca8187ebf0328b74fe45a0f01"
15 11
16S = "${WORKDIR}/git/vvcam/v4l2" 12S = "${WORKDIR}/git/vvcam/v4l2"
17 13