summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-03 15:54:10 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-09-05 11:32:33 +0000
commita1f9ebf7cf508ac11d2e5bd2b001fb3ffb6f156b (patch)
tree917ecdf10926f3be04ca9964f05447cfe6f36c38
parent9166561e6de728c7a884dd952fc561aa38648077 (diff)
downloadmeta-freescale-a1f9ebf7cf508ac11d2e5bd2b001fb3ffb6f156b.tar.gz
imx-atf: Use clang when using toolchain-clang defaults
When clang is default compiler, we need to ensure that its added as dependency as well. Reported-by: Cliff Brake <cbrake@bec-systems.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit d942acf911f2577e081e74cf0f7578ca5221d579)
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b0426f0b..ec943fa5 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -37,6 +37,9 @@ LD[unexport] = "1"
37INHIBIT_DEFAULT_DEPS = "1" 37INHIBIT_DEFAULT_DEPS = "1"
38DEPENDS = "virtual/${HOST_PREFIX}gcc" 38DEPENDS = "virtual/${HOST_PREFIX}gcc"
39 39
40# Bring in clang compiler if using clang as default
41DEPENDS:append:toolchain-clang = " clang-cross-${TARGET_ARCH}"
42
40BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 43BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
41 44
42# CC and LD introduce arguments which conflict with those otherwise provided by 45# CC and LD introduce arguments which conflict with those otherwise provided by