diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-02-18 17:07:08 -0600 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-02-24 13:32:53 -0600 |
commit | d38cf8527d87673d2df0b91dea690aee354aebaa (patch) | |
tree | d1bff002012bb9afd10982fd158ee931c436a2c9 | |
parent | a9ebace6b8d5d4a849c64e4a133dd24da8f9c8a0 (diff) | |
download | meta-freescale-d38cf8527d87673d2df0b91dea690aee354aebaa.tar.gz |
optee-test: Use openssl embedded in optee-test
Building against openssl from Yocto results in a build break:
```
| /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-fsl-linux/optee-test/3.15.0.imx-r0/git/host/xtest/regression_8100.c:133:17: error: 'ERR_get_error_line' is deprecated: Since OpeSL 3.0 [-Werror=deprecated-declarations]
| 133 | e = ERR_get_error_line(&f, &l);
| | ^
| In file included from /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-fsl-linux/optee-test/3.15.0.imx-r0/git/host/xtest/regression_8100.c:18:
| /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-fsl-linux/optee-test/3.15.0.imx-r0/recipe-sysroot/usr/include/openssl/err.h:411:15: note: declared here
| 411 | unsigned long ERR_get_error_line(const char **file, int *line);
| | ^~~~~~~~~~~~~~~~~~
```
Configure optee-test to build with its own openssl.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.15.0.imx.bb | 1 |
1 files changed, 0 insertions, 1 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb index 1efd65c5..22194a39 100644 --- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb | |||
@@ -36,7 +36,6 @@ EXTRA_OEMAKE = " \ | |||
36 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ | 36 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ |
37 | CROSS_COMPILE_TA=${HOST_PREFIX} \ | 37 | CROSS_COMPILE_TA=${HOST_PREFIX} \ |
38 | CROSS_COMPILE=${HOST_PREFIX} \ | 38 | CROSS_COMPILE=${HOST_PREFIX} \ |
39 | OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ \ | ||
40 | -C ${S} O=${B} \ | 39 | -C ${S} O=${B} \ |
41 | " | 40 | " |
42 | 41 | ||