summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-09-21 16:09:07 -0300
committerGitHub <noreply@github.com>2022-09-21 16:09:07 -0300
commite47f9d1e2fabb6d0be08c08a111e94bfc0f61e37 (patch)
tree5892c3530428297d6f3ed0fcb2d55659fdead217
parent6f661995e5c2e7568bfb43cf689c3e9562dfb8ca (diff)
parent1cf05b53dae216a2e34d54c9bf22890c713e746c (diff)
downloadmeta-freescale-e47f9d1e2fabb6d0be08c08a111e94bfc0f61e37.tar.gz
Merge pull request #1220 from Freescale/backport-1214-to-kirkstone
[Backport kirkstone] musl fixes
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend2
-rw-r--r--recipes-graphics/harfbuzz/harfbuzz_%.bbappend5
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb3
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc20
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb7
-rw-r--r--recipes-graphics/pango/pango_%.bbappend5
-rw-r--r--recipes-graphics/wayland/weston_10.0.0.imx.bb4
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend7
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb4
-rw-r--r--recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb4
10 files changed, 57 insertions, 4 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 245adb59..c61e9a58 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl"
3 3
4# links with imx-gpu libs which are pre-built for glibc 4# links with imx-gpu libs which are pre-built for glibc
5# gcompat will address it during runtime 5# gcompat will address it during runtime
6LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined"
7LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" 6LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
8 7
8RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-graphics/harfbuzz/harfbuzz_%.bbappend b/recipes-graphics/harfbuzz/harfbuzz_%.bbappend
new file mode 100644
index 00000000..bf8c38fc
--- /dev/null
+++ b/recipes-graphics/harfbuzz/harfbuzz_%.bbappend
@@ -0,0 +1,5 @@
1# links with imx-gpu libs which are pre-built for glibc
2# gcompat will address it during runtime
3LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
4
5RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
index ad8de74c..e2f5912b 100644
--- a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
@@ -23,5 +23,8 @@ do_install () {
23} 23}
24 24
25INSANE_SKIP:${PN} += "ldflags" 25INSANE_SKIP:${PN} += "ldflags"
26INSANE_SKIP:append:libc-musl = " file-rdeps"
26 27
27COMPATIBLE_MACHINE = "(imxdpu)" 28COMPATIBLE_MACHINE = "(imxdpu)"
29
30RDEPENDS:${PN}:append:libc-musl = " gcompat"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index e95761a1..dcfb049b 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -25,6 +25,8 @@ DEPENDS:append:mx8-nxp-bsp = " patchelf-native"
25# We depend on mesa to fill in what is missing. 25# We depend on mesa to fill in what is missing.
26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}" 26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}"
27 27
28DEPENDS:append:libc-musl = " gcompat"
29
28PROVIDES += " \ 30PROVIDES += " \
29 imx-gpu-viv \ 31 imx-gpu-viv \
30 libgal-imx \ 32 libgal-imx \
@@ -247,6 +249,24 @@ do_install () {
247 chown -R root:root "${D}" 249 chown -R root:root "${D}"
248} 250}
249 251
252do_install:append:libc-musl() {
253 # libs
254 for f in `find ${D}${libdir} -name '*.so*' -type f`
255 do
256 patchelf --add-needed libgcompat.so.0 $f
257 done
258 # binaries
259 for f in `find ${D}/opt ${D}${bindir} -name '*' -type f -executable`
260 do
261 # prune scripts
262 if `patchelf --print-interpreter $f 2>&1 > /dev/null`
263 then
264 patchelf --set-interpreter ${root_prefix}`patchelf --print-interpreter $f` $f
265 patchelf --add-needed libgcompat.so.0 $f
266 fi
267 done
268}
269
250ALLOW_EMPTY:${PN} = "1" 270ALLOW_EMPTY:${PN} = "1"
251 271
252FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h" 272FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
index bd584dbe..4136631b 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
@@ -1,9 +1,10 @@
1require imx-gpu-viv-6.inc 1require imx-gpu-viv-6.inc
2 2
3DEPENDS:append:libc-musl = " gcompat"
4INSANE_SKIP:append:libc-musl = " file-rdeps"
5
6SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" 3SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f"
7SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" 4SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b"
8 5
6INSANE_SKIP:append:libc-musl = " file-rdeps"
7
9COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 8COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
9
10RDEPENDS:${PN}:append:libc-musl = " gcompat"
diff --git a/recipes-graphics/pango/pango_%.bbappend b/recipes-graphics/pango/pango_%.bbappend
new file mode 100644
index 00000000..bf8c38fc
--- /dev/null
+++ b/recipes-graphics/pango/pango_%.bbappend
@@ -0,0 +1,5 @@
1# links with imx-gpu libs which are pre-built for glibc
2# gcompat will address it during runtime
3LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
4
5RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb
index a9f6ec13..b9e8fca5 100644
--- a/recipes-graphics/wayland/weston_10.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb
@@ -202,6 +202,10 @@ EXTRA_OEMESON:append:imxfbdev = " -Dbackend-default=fbdev"
202 202
203EXTRA_OEMESON += "-Ddeprecated-wl-shell=true" 203EXTRA_OEMESON += "-Ddeprecated-wl-shell=true"
204 204
205# links with imx-gpu libs which are pre-built for glibc
206# gcompat will address it during runtime
207LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
208
205PACKAGE_ARCH = "${MACHINE_SOCARCH}" 209PACKAGE_ARCH = "${MACHINE_SOCARCH}"
206COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)" 210COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)"
207 211
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index 69063121..f2141f4f 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" 10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" 11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" 12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"
13
14
15# links with imx-gpu libs which are pre-built for glibc
16# gcompat will address it during runtime
17LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
18
19RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
index ba1b9787..3cbd2179 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
@@ -137,6 +137,10 @@ PACKAGECONFIG[viv-fb] = ",,virtual/libgles2"
137 137
138EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}"" 138EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}""
139 139
140# links with imx-gpu libs which are pre-built for glibc
141# gcompat will address it during runtime
142LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
143
140COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 144COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
141 145
142########### End of i.MX overrides ######### 146########### End of i.MX overrides #########
diff --git a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
index 3d557207..957d6ddf 100644
--- a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
+++ b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
@@ -16,3 +16,7 @@ INSANE_SKIP:${PN} = "already-stripped"
16FILES:${PN} += "${datadir}/imx-mm" 16FILES:${PN} += "${datadir}/imx-mm"
17 17
18COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 18COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
19
20INSANE_SKIP:append:libc-musl = " file-rdeps"
21
22RDEPENDS:${PN}:append:libc-musl = " gcompat"