summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-29 10:13:10 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-09-29 17:53:45 +0000
commitc0c4e30e12290c9aa05dc6451e34ce891b0116ce (patch)
treed47b3fa261dac712a92b85635edb159d232718ce
parentf28fb5c99c8a572669faad73ada559f1e54f2690 (diff)
downloadmeta-freescale-c0c4e30e12290c9aa05dc6451e34ce891b0116ce.tar.gz
weston: Fix the append logic
Previous commit did not really work because we are using bb.utils.filter and that removed the artificial space sadly. Therefore add it outside this function call. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit e3c2e0644a4593ae35270a890e1e3692f234545e)
-rw-r--r--recipes-graphics/wayland/weston_10.0.0.imx.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb
index 1e380ffe..7ab612b0 100644
--- a/recipes-graphics/wayland/weston_10.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb
@@ -177,7 +177,7 @@ PACKAGECONFIG_OPENGL:imxgpu2d = ""
177PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" 177PACKAGECONFIG_OPENGL:imxgpu3d = "opengl"
178 178
179PACKAGECONFIG:remove = "wayland x11" 179PACKAGECONFIG:remove = "wayland x11"
180PACKAGECONFIG:append = "${@bb.utils.filter('DISTRO_FEATURES', ' ${PACKAGECONFIG_OPENGL}', d)}" 180PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}"
181 181
182PACKAGECONFIG:remove:imxfbdev = "kms" 182PACKAGECONFIG:remove:imxfbdev = "kms"
183PACKAGECONFIG:append:imxfbdev = " fbdev clients" 183PACKAGECONFIG:append:imxfbdev = " fbdev clients"