diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-01-11 03:14:04 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-01-14 16:23:38 -0200 |
commit | 4bee74fcaa6538c7b7192a73c91dc086011e0c85 (patch) | |
tree | 4551a32e31aab33d8f7017eb3af3bdc80219a048 | |
parent | 4babcb9d184254805df479695f8bec1e33b447c2 (diff) | |
download | meta-freescale-4bee74fcaa6538c7b7192a73c91dc086011e0c85.tar.gz |
inphi: add recipes
*include the following changes:
f22e9ff - in112525: Add Inphi 112525 10G Phy firmware
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
-rw-r--r-- | recipes-bsp/inphi/inphi_git.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/inphi/inphi_git.bb b/recipes-bsp/inphi/inphi_git.bb new file mode 100644 index 00000000..c0c8a776 --- /dev/null +++ b/recipes-bsp/inphi/inphi_git.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "Firmwares and Standalone Applications" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798" | ||
4 | |||
5 | inherit deploy fsl-eula-unpack | ||
6 | |||
7 | SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;fsl-eula=true;nobranch=1" | ||
8 | SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | do_install () { | ||
13 | install -d ${D}/boot | ||
14 | cp -fr ${S}/in112525-phy-ucode.txt ${D}/boot | ||
15 | } | ||
16 | |||
17 | do_deploy () { | ||
18 | install -d ${DEPLOYDIR}/inphi | ||
19 | cp -fr ${S}/in112525-phy-ucode.txt ${DEPLOYDIR}/inphi | ||
20 | } | ||
21 | addtask deploy before do_build after do_install | ||
22 | |||
23 | PACKAGES += "${PN}-image" | ||
24 | FILES_${PN}-image += "/boot" | ||
25 | |||
26 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
27 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
28 | |||