summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-17 09:53:46 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-09-20 23:52:02 +0000
commit24f2861a3b6a424c3ca5cf9c255e8875a37d288e (patch)
treee8f0e62062934bc91b134d6d1a09c7679ac26437
parent3068a16ff6fde4d025f234332b953456e93cc8f6 (diff)
downloadmeta-freescale-24f2861a3b6a424c3ca5cf9c255e8875a37d288e.tar.gz
imx-dpu-g2d,imx-gpu-viv,imx-sw-pdm: Use gcompat with musl
These recipes contain pre-built binaries and libraries which are built against glibc, we have a way to run such binaries on musl systems via gcompat stubs, however, we have to fool the system to ignore the missing rdeps on libc.so.6, since we know they will be available via gcompat being in rdep. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 61718793a4c04c768ecc829372b9d4de3c6c463b)
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb3
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb7
-rw-r--r--recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb4
3 files changed, 11 insertions, 3 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
index ad8de74c..e2f5912b 100644
--- a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb
@@ -23,5 +23,8 @@ do_install () {
23} 23}
24 24
25INSANE_SKIP:${PN} += "ldflags" 25INSANE_SKIP:${PN} += "ldflags"
26INSANE_SKIP:append:libc-musl = " file-rdeps"
26 27
27COMPATIBLE_MACHINE = "(imxdpu)" 28COMPATIBLE_MACHINE = "(imxdpu)"
29
30RDEPENDS:${PN}:append:libc-musl = " gcompat"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
index bd584dbe..4136631b 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
@@ -1,9 +1,10 @@
1require imx-gpu-viv-6.inc 1require imx-gpu-viv-6.inc
2 2
3DEPENDS:append:libc-musl = " gcompat"
4INSANE_SKIP:append:libc-musl = " file-rdeps"
5
6SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" 3SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f"
7SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" 4SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b"
8 5
6INSANE_SKIP:append:libc-musl = " file-rdeps"
7
9COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 8COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
9
10RDEPENDS:${PN}:append:libc-musl = " gcompat"
diff --git a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
index 3d557207..957d6ddf 100644
--- a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
+++ b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb
@@ -16,3 +16,7 @@ INSANE_SKIP:${PN} = "already-stripped"
16FILES:${PN} += "${datadir}/imx-mm" 16FILES:${PN} += "${datadir}/imx-mm"
17 17
18COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 18COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
19
20INSANE_SKIP:append:libc-musl = " file-rdeps"
21
22RDEPENDS:${PN}:append:libc-musl = " gcompat"