summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-17 10:01:30 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-09-20 23:52:02 +0000
commit047fb6c66a27bbc7fd6f591a1d068731d7cd58de (patch)
treed8d18f42376c68c551c9fff5beecc3f3a8c85abe
parent24f2861a3b6a424c3ca5cf9c255e8875a37d288e (diff)
downloadmeta-freescale-047fb6c66a27bbc7fd6f591a1d068731d7cd58de.tar.gz
cairo,xwayland: Fix compiling with musl with vivante gpu driver libs
This ensures that the symbols from the prebuilt libs are not flagged during build, we are betting on gcompat to provide the missing glibc API stubs at runtime. Depend on gcompat on musl needed for imxgpu machines its needed since graphics driver is precompiled for glibc. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit fa4112e43fc4edc4a8521eddd459606328be647e)
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend2
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend7
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 245adb59..c61e9a58 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl"
3 3
4# links with imx-gpu libs which are pre-built for glibc 4# links with imx-gpu libs which are pre-built for glibc
5# gcompat will address it during runtime 5# gcompat will address it during runtime
6LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined"
7LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" 6LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
8 7
8RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index 69063121..f2141f4f 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" 10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" 11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" 12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"
13
14
15# links with imx-gpu libs which are pre-built for glibc
16# gcompat will address it during runtime
17LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
18
19RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"