diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-04-15 08:56:25 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-16 10:32:45 -0300 |
commit | fcb3b7452d37c189437621440f6aa68393d3e261 (patch) | |
tree | ae71cbc847f70c075e9164c4b9f84152ff33e7ce | |
parent | 9837d52e9bf3b6aa67db9d882543c9e805b15635 (diff) | |
download | meta-freescale-fcb3b7452d37c189437621440f6aa68393d3e261.tar.gz |
optee-imx: upgrade to lf-5.4.y
Upgrade optee recipes to fetch sources from lf-5.4.y branch, this is
aligned with new kernel release from NXP.
optee-os and optee-client has build defines dropped, this is originated
in NXP fork.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r-- | recipes-security/optee-imx/optee-client_3.2.0.imx.bb | 4 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-os_3.2.0.imx.bb | 9 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.2.0.imx.bb | 6 |
3 files changed, 6 insertions, 13 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb index f7b22e1a..707e82fd 100644 --- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb +++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" | |||
7 | 7 | ||
8 | inherit python3native systemd | 8 | inherit python3native systemd |
9 | 9 | ||
10 | SRCBRANCH = "imx_4.19.35_1.1.0" | 10 | SRCBRANCH = "lf-5.4.y" |
11 | OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https" | 11 | OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https" |
12 | SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}" | 12 | SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}" |
13 | 13 | ||
@@ -20,8 +20,6 @@ SRC_URI_append = " file://tee-supplicant.service" | |||
20 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
21 | SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" | 21 | SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" |
22 | 22 | ||
23 | EXTRA_OEMAKE = "CFG_SECURE_DATA_PATH=y" | ||
24 | |||
25 | do_compile () { | 23 | do_compile () { |
26 | if [ ${DEFAULTTUNE} = "aarch64" ]; then | 24 | if [ ${DEFAULTTUNE} = "aarch64" ]; then |
27 | oe_runmake -C ${S} ARCH=arm64 | 25 | oe_runmake -C ${S} ARCH=arm64 |
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb index be07f0ef..ba903519 100644 --- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb +++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb | |||
@@ -9,14 +9,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" | |||
9 | inherit deploy python3native autotools | 9 | inherit deploy python3native autotools |
10 | DEPENDS = "python3-pycrypto-native u-boot-mkimage-native" | 10 | DEPENDS = "python3-pycrypto-native u-boot-mkimage-native" |
11 | 11 | ||
12 | SRCBRANCH = "imx_4.19.35_1.1.0" | 12 | SRCBRANCH = "lf-5.4.y" |
13 | OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" | 13 | OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" |
14 | SRC_URI = "\ | 14 | SRC_URI = "\ |
15 | ${OPTEE_OS_SRC};branch=${SRCBRANCH} \ | 15 | ${OPTEE_OS_SRC};branch=${SRCBRANCH} \ |
16 | file://0001-scripts-update-scripts-to-use-python3.patch \ | 16 | file://0001-scripts-update-scripts-to-use-python3.patch \ |
17 | " | 17 | " |
18 | 18 | ||
19 | SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c" | 19 | SRCREV = "6d99b525af752ecdaabdca6098b2564b2665f2b2" |
20 | 20 | ||
21 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |
22 | B = "${WORKDIR}/build.${PLATFORM_FLAVOR}" | 22 | B = "${WORKDIR}/build.${PLATFORM_FLAVOR}" |
@@ -30,6 +30,7 @@ PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk" | |||
30 | PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk" | 30 | PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk" |
31 | PLATFORM_FLAVOR_mx8mm = "mx8mmevk" | 31 | PLATFORM_FLAVOR_mx8mm = "mx8mmevk" |
32 | PLATFORM_FLAVOR_mx8mn = "mx8mnevk" | 32 | PLATFORM_FLAVOR_mx8mn = "mx8mnevk" |
33 | PLATFORM_FLAVOR_mx8qxp = "mx8qxpmek" | ||
33 | 34 | ||
34 | OPTEE_ARCH ?= "arm32" | 35 | OPTEE_ARCH ?= "arm32" |
35 | OPTEE_ARCH_armv7a = "arm32" | 36 | OPTEE_ARCH_armv7a = "arm32" |
@@ -46,10 +47,6 @@ EXTRA_OEMAKE = "PLATFORM=imx PLATFORM_FLAVOR=${PLATFORM_FLAVOR} \ | |||
46 | NOWERROR=1 \ | 47 | NOWERROR=1 \ |
47 | LDFLAGS= \ | 48 | LDFLAGS= \ |
48 | O=${B} \ | 49 | O=${B} \ |
49 | CFG_SECURE_DATA_PATH=y \ | ||
50 | CFG_TEE_SDP_MEM_BASE=0xCC000000 \ | ||
51 | CFG_TEE_SDP_MEM_SIZE=0x02000000 \ | ||
52 | CFG_TEE_SDP_NONCACHE=y \ | ||
53 | " | 50 | " |
54 | 51 | ||
55 | 52 | ||
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb index fa46720d..03cb2b57 100644 --- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb +++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb | |||
@@ -11,7 +11,7 @@ inherit python3native | |||
11 | 11 | ||
12 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 12 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
13 | 13 | ||
14 | SRCBRANCH = "imx_4.19.35_1.1.0" | 14 | SRCBRANCH = "lf-5.4.y" |
15 | OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https" | 15 | OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https" |
16 | 16 | ||
17 | SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \ | 17 | SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \ |
@@ -25,8 +25,6 @@ S = "${WORKDIR}/git" | |||
25 | 25 | ||
26 | SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" | 26 | SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" |
27 | 27 | ||
28 | |||
29 | |||
30 | do_compile () { | 28 | do_compile () { |
31 | if [ ${DEFAULTTUNE} = "aarch64" ];then | 29 | if [ ${DEFAULTTUNE} = "aarch64" ];then |
32 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/ | 30 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/ |
@@ -40,7 +38,7 @@ do_compile () { | |||
40 | export CROSS_COMPILE_TA=${HOST_PREFIX} | 38 | export CROSS_COMPILE_TA=${HOST_PREFIX} |
41 | export CROSS_COMPILE=${HOST_PREFIX} | 39 | export CROSS_COMPILE=${HOST_PREFIX} |
42 | export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ | 40 | export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ |
43 | oe_runmake V=1 | 41 | oe_runmake V=1 --warn-undefined-variables |
44 | } | 42 | } |
45 | 43 | ||
46 | do_install () { | 44 | do_install () { |