summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-08-24 16:55:57 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-08-26 20:54:38 +0000
commitec4f37a554c660fd470837a3ad9301d41522ecd7 (patch)
tree41f00ff6a6bc7af13a455092244f3946ab4407e5
parent15648530af61558f7f749e57b68f48a9fc86ad3e (diff)
downloadmeta-freescale-ec4f37a554c660fd470837a3ad9301d41522ecd7.tar.gz
mesa-demos: Update formatting for readability
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit b0e0b700fb6736eb77d880952d9e92c3014b1445)
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend24
1 files changed, 11 insertions, 13 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 4b518185..10db1f9e 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,26 +1,24 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI:append:imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ 3SRC_URI:append:imxgpu = " \
4 file://fix-clear-build-break.patch \ 4 file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
5 file://Add-OpenVG-demos-to-support-wayland.patch" 5 file://fix-clear-build-break.patch \
6 file://Add-OpenVG-demos-to-support-wayland.patch"
6 7
8PACKAGECONFIG:remove = " \
9 ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \
10 ${PACKAGECONFIG_REMOVE_IF_GPU}"
7PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" 11PACKAGECONFIG_REMOVE_IF_2D_ONLY = ""
8PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu2d = "gles1 gles2" 12PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu2d = "gles1 gles2"
9PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu3d = "" 13PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu3d = ""
10PACKAGECONFIG_REMOVE_IF_GPU = "" 14PACKAGECONFIG_REMOVE_IF_GPU = ""
11PACKAGECONFIG_REMOVE_IF_GPU:imxgpu = " \ 15PACKAGECONFIG_REMOVE_IF_GPU:imxgpu = " \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)}"
13"
14PACKAGECONFIG:remove = " \
15 ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \
16 ${PACKAGECONFIG_REMOVE_IF_GPU} \
17"
18 17
18PACKAGECONFIG:append = " \
19 ${PACKAGECONFIG_APPEND_IF_GPU}"
19PACKAGECONFIG_APPEND_IF_GPU = "" 20PACKAGECONFIG_APPEND_IF_GPU = ""
20PACKAGECONFIG_APPEND_IF_GPU:imxgpu = " \ 21PACKAGECONFIG_APPEND_IF_GPU:imxgpu = " \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \ 22 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glut', '', d)} \ 23 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glut', '', d)}"
23"
24PACKAGECONFIG:append = " \
25 ${PACKAGECONFIG_APPEND_IF_GPU} \
26" 24"