summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-09-05 08:38:55 -0300
committerGitHub <noreply@github.com>2022-09-05 08:38:55 -0300
commit774b4924c0e1697b6f9195d865507921329648c2 (patch)
tree5407ea781462328cb1793682d9ca611a49d41fdd
parent9166561e6de728c7a884dd952fc561aa38648077 (diff)
parent49d62fd1247b234528b19366568ff9db514ef62e (diff)
downloadmeta-freescale-774b4924c0e1697b6f9195d865507921329648c2.tar.gz
Merge pull request #1195 from Freescale/backport-1194-to-kirkstone
[Backport kirkstone] imx-atf: Use clang when using toolchain-clang defaults
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb3
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend6
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb3
3 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b0426f0b..ec943fa5 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -37,6 +37,9 @@ LD[unexport] = "1"
37INHIBIT_DEFAULT_DEPS = "1" 37INHIBIT_DEFAULT_DEPS = "1"
38DEPENDS = "virtual/${HOST_PREFIX}gcc" 38DEPENDS = "virtual/${HOST_PREFIX}gcc"
39 39
40# Bring in clang compiler if using clang as default
41DEPENDS:append:toolchain-clang = " clang-cross-${TARGET_ARCH}"
42
40BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 43BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
41 44
42# CC and LD introduce arguments which conflict with those otherwise provided by 45# CC and LD introduce arguments which conflict with those otherwise provided by
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 2c73c7f3..245adb59 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -1,2 +1,8 @@
1PACKAGECONFIG:append:imxgpu3d = " egl glesv2" 1PACKAGECONFIG:append:imxgpu3d = " egl glesv2"
2PACKAGECONFIG:remove:imxgpu3d = "opengl" 2PACKAGECONFIG:remove:imxgpu3d = "opengl"
3
4# links with imx-gpu libs which are pre-built for glibc
5# gcompat will address it during runtime
6LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined"
7LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
8
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
index de527cda..bd584dbe 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
@@ -1,5 +1,8 @@
1require imx-gpu-viv-6.inc 1require imx-gpu-viv-6.inc
2 2
3DEPENDS:append:libc-musl = " gcompat"
4INSANE_SKIP:append:libc-musl = " file-rdeps"
5
3SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" 6SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f"
4SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" 7SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b"
5 8