summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-09-01 16:50:39 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-09-05 11:50:05 +0000
commit6a29906a8355648f0eea1ae2983af88ba0f138cb (patch)
tree496e4487f872c3f83cb027838ab7efab5115d810
parent831614eadfa528e559f6553cf019b4caf782f5de (diff)
downloadmeta-freescale-6a29906a8355648f0eea1ae2983af88ba0f138cb.tar.gz
imx-dsp: Add TensorFlow Lite Micro for 8ULP
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 186780dbcf58fcc50dcebee7f1b63fbd275703e7)
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb
index 336bf34d..168ec603 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp_2.0.0.bb
@@ -26,11 +26,18 @@ HIFI4_PLATFORM:mx8dx-nxp-bsp = "imx8qmqxp"
26HIFI4_PLATFORM:mx8mp-nxp-bsp = "imx8mp" 26HIFI4_PLATFORM:mx8mp-nxp-bsp = "imx8mp"
27HIFI4_PLATFORM:mx8ulp-nxp-bsp = "imx8ulp" 27HIFI4_PLATFORM:mx8ulp-nxp-bsp = "imx8ulp"
28 28
29UNSUPPORTED_TESTS = "dsp_tflm"
30UNSUPPORTED_TESTS:mx8ulp-nxp-bsp = ""
31
29do_install:append () { 32do_install:append () {
30 # Remove firmware not for this platform 33 # Remove firmware not for this platform
31 find ${D}/${base_libdir}/firmware/imx/dsp -name hifi4_*.bin -not -name *${HIFI4_PLATFORM}* -exec rm {} \; 34 find ${D}/${base_libdir}/firmware/imx/dsp -name hifi4_*.bin -not -name *${HIFI4_PLATFORM}* -exec rm {} \;
32 # Set the expected generic name for the firmware 35 # Set the expected generic name for the firmware
33 mv ${D}/${base_libdir}/firmware/imx/dsp/hifi4_${HIFI4_PLATFORM}.bin ${D}/${base_libdir}/firmware/imx/dsp/hifi4.bin 36 mv ${D}/${base_libdir}/firmware/imx/dsp/hifi4_${HIFI4_PLATFORM}.bin ${D}/${base_libdir}/firmware/imx/dsp/hifi4.bin
37 # Remove unit tests not for this platform
38 for unsupported_test in ${UNSUPPORTED_TESTS}; do
39 find ${D}/unit_tests/DSP -name $unsupported_test* -exec rm {} \;
40 done
34} 41}
35 42
36FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \ 43FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \