summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-08-16 13:06:08 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-08-18 11:22:14 +0000
commit448a800e7f6e0237d085b9466296dbe145e67925 (patch)
tree9b64a69adf689c79b8cb474035c54cc272e59949
parentb32e4728603af5be76cfb361833302ac11bbf80f (diff)
downloadmeta-freescale-448a800e7f6e0237d085b9466296dbe145e67925.tar.gz
imx-atf: Cleanup
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 9080ae88a08de2cfe6b3709f331020ec4a0c2f4c)
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index 194ef935..b0426f0b 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -1,28 +1,26 @@
1# Copyright (C) 2017-2021 NXP 1# Copyright (C) 2017-2022 NXP
2 2
3DESCRIPTION = "i.MX ARM Trusted Firmware" 3DESCRIPTION = "i.MX ARM Trusted Firmware"
4SECTION = "BSP" 4SECTION = "BSP"
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" 6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
7 7
8FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
9
10PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
11 9
12SRCBRANCH = "lf_v2.6"
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ 10SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
14 file://0001-Makefile-Suppress-array-bounds-error.patch" 11 file://0001-Makefile-Suppress-array-bounds-error.patch"
12SRCBRANCH = "lf_v2.6"
15SRCREV = "c6a19b1a351308cc73443283f6aa56b2eff791b8" 13SRCREV = "c6a19b1a351308cc73443283f6aa56b2eff791b8"
16 14
17S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
18 16
19inherit deploy 17inherit deploy
20 18
21ATF_PLATFORM ??= "INVALID" 19ATF_PLATFORM ??= "INVALID"
22 20
23# FIXME: We should return INVALID here but currently only i.MX8M has support to override the UART 21# FIXME: We should return INVALID here but currently only i.MX8M has support to override the UART
24# base address in source code. 22# base address in source code.
25ATF_BOOT_UART_BASE ?= "" 23ATF_BOOT_UART_BASE ?= ""
26 24
27EXTRA_OEMAKE += " \ 25EXTRA_OEMAKE += " \
28 CROSS_COMPILE="${TARGET_PREFIX}" \ 26 CROSS_COMPILE="${TARGET_PREFIX}" \
@@ -61,20 +59,20 @@ do_compile() {
61 # Clear LDFLAGS to avoid the option -Wl recognize issue 59 # Clear LDFLAGS to avoid the option -Wl recognize issue
62 oe_runmake bl31 60 oe_runmake bl31
63 if ${BUILD_OPTEE}; then 61 if ${BUILD_OPTEE}; then
64 oe_runmake clean BUILD_BASE=build-optee 62 oe_runmake clean BUILD_BASE=build-optee
65 oe_runmake BUILD_BASE=build-optee SPD=opteed bl31 63 oe_runmake BUILD_BASE=build-optee SPD=opteed bl31
66 fi 64 fi
67} 65}
68 66
69do_install[noexec] = "1" 67do_install[noexec] = "1"
70 68
69addtask deploy after do_compile
71do_deploy() { 70do_deploy() {
72 install -Dm 0644 ${S}/build/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/bl31-${ATF_PLATFORM}.bin 71 install -Dm 0644 ${S}/build/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/bl31-${ATF_PLATFORM}.bin
73 if ${BUILD_OPTEE}; then 72 if ${BUILD_OPTEE}; then
74 install -m 0644 ${S}/build-optee/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/bl31-${ATF_PLATFORM}.bin-optee 73 install -m 0644 ${S}/build-optee/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/bl31-${ATF_PLATFORM}.bin-optee
75 fi 74 fi
76} 75}
77addtask deploy after do_compile
78 76
79PACKAGE_ARCH = "${MACHINE_ARCH}" 77PACKAGE_ARCH = "${MACHINE_ARCH}"
80COMPATIBLE_MACHINE = "(mx8-generic-bsp)" 78COMPATIBLE_MACHINE = "(mx8-generic-bsp)"