diff options
author | Carlos Rafael Giani <dv@pseudoterminal.org> | 2016-01-08 09:43:25 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:24 -0300 |
commit | 0e70e727685ee64d19a47251e7886d7eaed549f6 (patch) | |
tree | 1a7facf4959bf352f27184616d957c3f951046fd | |
parent | 918ac45c328b3c3f7de9ab785145bbd53e63aa8f (diff) | |
download | meta-freescale-0e70e727685ee64d19a47251e7886d7eaed549f6.tar.gz |
gstreamer1.0-plugins-imx: Update to version 0.12.0
Changes:
* vpu:
- Completely rewritten plugin code; elements now based on libimxvpuapi
instead of libfslvpuwrap
- imxvpuenc_h264 inserts SPS/PPS data in front of I/IDR frames
- imxvpuenc_mjpeg's quality factor actually has an effect, and is
equivalent to the libjpeg's quality factor (it is used in exactly the
same way to scale the quantization matrix' coefficients)
- the encoder's output buffers no longer have to use DMA memory; they
use regular system memory instead
- new support in imxvpudec (referred to as "chroma interleaving") for
NV12, NV16, NV24 as output formats as an alternative to the I420,
Y42B, Y444 formats
- removed all of the system frame number tracking code, since it is
unnecessary; Instead, the libimxvpuapi's context fields are used to
associate input/output frames with GstVideoCodecFrame system frame
numbers
- fix memory leaks related to missing buffer pool unref'ing
* imxv4l2videosrc:
- support for crop metadata
- element uses the width, height, etc. of the format that the device
actually uses during operation (instead of default values)
- autofocus control support via GstPhotography
- fix incorrect GLib warnings
- fix segmentation fault when shutting down the element
* eglvivsink:
- remove extra g_free() calls, which lead to runtime errors
- remove GLESv2 VIVANTE link dependencies
- add Android platform
- manually retrieve VIV direct texture functions
with this and the link dependency elimination, this means that for
platforms except the framebuffer one, no Vivante specific headers and
libraries are needed anymore
- fix blocking issue in the Wayland platform mainloop
* improved and expanded documentation
* pxp: NV16 *is* supported after all (it was actually a bug in GStreamer
pre-1.5.91)
NOTE: this does not break compatibility with GStreamer versions older
than 1.5.91
* compositor: Update backported aggregator code to GStreamer 1.6
* blitter:
- error handling improvements
- add missing buffer pool unref'ing, which lead to memory leaks
- add missing compositor dependency to blitter base
* uniaudio:
- only build the uniaudio plugin if at least one codec was found during
configuration
- disable plugin if the gstaudio library is not available
- add AAC profile field to the sink caps with GStreamer >= 1.4.4 to
ensure the uniaudio decoder is only used for AAC-LC data
* ipu: increase fill frame width from 8 to 64 pixels to make IPU fill
operations work with pre-3.14 Freescale kernels
* g2d: use padding pixels when setting surface parameters, fixing G2D
failures with frame sizes that aren't aligned
* wscript:
- improve Android support
- fix installation paths for the common, blitter, compositor libraries
Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb) | 14 |
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb index b168ef70..eaccb294 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb | |||
@@ -2,17 +2,21 @@ DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms" | |||
2 | LICENSE = "LGPLv2+" | 2 | LICENSE = "LGPLv2+" |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" |
4 | SECTION = "multimedia" | 4 | SECTION = "multimedia" |
5 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base imx-gpu-viv libfslcodec libfslvpuwrap virtual/kernel virtual/egl \ | 5 | # gstreamer1.0-plugins-bad is in DEPENDS because imxv4l2videosrc requires |
6 | virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" | 6 | # the GstPhotography headers and libraries |
7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad imx-gpu-viv \ | ||
8 | libfslcodec libimxvpuapi virtual/kernel virtual/egl virtual/libgles2 \ | ||
9 | ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" | ||
7 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers | 10 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers |
8 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder | 11 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder |
9 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good and -bad recipes are built | 12 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is |
10 | RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad" | 13 | # build (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS) |
14 | RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good" | ||
11 | RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers" | 15 | RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers" |
12 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" | 16 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" |
13 | 17 | ||
14 | SRCBRANCH ?= "master" | 18 | SRCBRANCH ?= "master" |
15 | SRCREV = "6cbb90f51b12588bb4cb146cb229bf3bad39afc4" | 19 | SRCREV = "f8ad953c458be6a89f474a948b6401664a6a1745" |
16 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" | 20 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" |
17 | 21 | ||
18 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |