summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-23 13:27:52 -0300
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-07-29 21:20:34 +0000
commit017b7c7767258615db3855d0756e51be787c3b45 (patch)
treedb7f67b321af935d92b3481517c64645c59085c3
parent59324fb456d71f03f8071117504d7402276c4733 (diff)
downloadmeta-freescale-017b7c7767258615db3855d0756e51be787c3b45.tar.gz
imx-atf: avoid default dependencies addition
We can use `INHIBIT_DEFAULT_DEPS` to avoid extra dependencies declaration and instead we can explicitly add the `virtual/${HOST_PREFIX}gcc` requirement. This is equivalent to previous code but in a easier to undertand implementation. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> (cherry picked from commit 896b5adc3fb85bd2817174d7aa2a07b64409f422)
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index d491361b..9047fd09 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -32,7 +32,8 @@ AS[unexport] = "1"
32LD[unexport] = "1" 32LD[unexport] = "1"
33 33
34# Baremetal, just need a compiler 34# Baremetal, just need a compiler
35DEPENDS:remove = "virtual/${TARGET_PREFIX}compilerlibs virtual/libc" 35INHIBIT_DEFAULT_DEPS = "1"
36DEPENDS = "virtual/${HOST_PREFIX}gcc"
36 37
37BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 38BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
38 39